#opendaylight-meeting: tsc
Meeting started by skitt at 18:04:40 UTC
(full logs).
Meeting summary
- 
  - TSC members please info in (skitt,
    18:04:53)
- skitt (skitt,
    18:04:58)
- Anil Vishnoi (vishnoianil,
    18:05:01)
 
 
- Rollcall (skitt, 18:05:10)
  - jamoluhrsen (jamoluhrsen,
    18:05:10)
- tykeal - Andrew Grimberg (Proxy for zxiiro /
    Thanh Ha) (tykeal,
    18:05:13)
- anipbu (anipbu,
    18:05:16)
- jamoluhrsen (jamoluhrsen,
    18:05:16)
- abhijitkumbhare (abhijitkumbhare,
    18:05:17)
- jamoluhrsen for shague (jamoluhrsen,
    18:05:21)
- LuisGomez (LuisGomez,
    18:05:27)
- lori (lori,
    18:05:38)
- Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2017/tsc/opendaylight-meeting-tsc.2017-11-09-18.01.html
    (skitt,
    18:05:45)
 
 
- Events (skitt, 18:10:55)
 
- Oxygen (skitt, 18:12:43)
  - klou sent the final M1 reminder last
    week (skitt,
    18:13:06)
- ocpplugin and tsdr didn’t respond and will be
    dropped (skitt,
    18:13:18)
- yangtools asked to be tracked separately
    (skitt,
    18:13:42)
- non-autorelease projects should feel free to
    respond N/A to non-applicable questions in the readouts (skitt,
    18:15:39)
- ACTION: rovarga_ to
    fill in the yangtools milestone readouts until an alternative is in
    place (skitt,
    18:16:55)
- we want to ensure the project in general is
    aware of odlparent and yangtools’ status (skitt,
    18:17:26)
 
 
- Nitrogen (skitt, 18:17:38)
  - still waiting for SR1 sign-off on CSIT
    issues (skitt,
    18:17:54)
- jamoluhrsen and LuisGomez will be looking at
    the remaining problems (skitt,
    18:18:05)
- as soon as we get sign-off we can formally
    release SR1 (skitt,
    18:18:15)
- (hopefully before Thanksgiving) (skitt,
    18:18:24)
- SR2 date is December 7, we won’t hit that
    date (skitt,
    18:18:43)
- SR1 likely early next week, starting November
    21 (skitt,
    18:18:58)
- one fall-out from the TWS session on lessons
    from Nitrogen was reducing the number of SRs (skitt,
    18:19:30)
- so we could perhaps drop the December 7
    release (skitt,
    18:20:24)
- releases take ~6 weeks (skitt,
    18:21:11)
- too much overlap now with six month releases,
    zxiiro and abelur are always in release mode (skitt,
    18:24:57)
- we never hit our release targets (skitt,
    18:26:06)
- specific proposal is to reduce SRs from 4 to
    3 (skitt,
    18:27:39)
- or even doing as-needed SRs, but that would be
    too hard (no consensus) (skitt,
    18:27:53)
- our downstreams don’t track our releases very
    closely (skitt,
    18:32:18)
- we do still need SR1 not too long after GA
    because that release has lots of fixes (skitt,
    18:32:33)
- which indicates that our initial releases are
    hurried and not properly engineered (skitt,
    18:33:25)
- we need to avoid having too many SRs from
    different streams close together (skitt,
    18:38:56)
- we need to conclude the distribution
    discussions before we plan Fluorine, which makes them quite urgent
    (January) (skitt,
    18:39:40)
- the key problem with Oxygen is that we have
    Oxygen GA, Carbon SR and Oxygen SR in quick succession (skitt,
    18:40:09)
- resulting in over two full months spent in full
    release mode (ramp-down Oxygen, then Carbon, then Oxygen
    again) (skitt,
    18:40:42)
- https://wiki.opendaylight.org/view/Release_Dashboard
    <- view of all active releases (klou,
    18:42:03)
- one solution would be to release Oxygen GA,
    Oxygen SR1 and only then Carbon SR (skitt,
    18:42:19)
- which would extend our Carbon support time by
    two months (skitt,
    18:42:29)
- and also give time to back-port issues fixed in
    Oxygen SR1 to Carbon before its last SR (skitt,
    18:43:51)
- we need to ask projects whether they need a
    Carbon release (skitt,
    18:47:21)
- likewise for our downstreams (skitt,
    18:47:26)
- some of this goes back to our decision to
    support Carbon longer (skitt,
    18:47:34)
- we’ve tried asking before, without getting any
    feedback (skitt,
    18:50:04)
- we’ll revisit this issue later (skitt,
    18:50:36)
 
 
- Carbon (skitt, 18:51:41)
  - SR3 planned for December 14 (skitt,
    18:51:53)
 
 
- Infrastructure (skitt, 18:52:38)
  - Gerrit migration coming up next week on Friday
    (black Friday) (skitt,
    18:52:58)
- this will switch ids to LF ids (skitt,
    18:53:11)
- known mappings will be applied (skitt,
    18:53:32)
- unknown accounts will be disabled in
    Gerrit (skitt,
    18:53:41)
- so if you don’t have a wiki account or JIRA
    account yet, pay close attention to tykeal’s email which went out
    yesterday (skitt,
    18:54:05)
- upgrading to the latest version of Gerrit
    too (skitt,
    18:54:23)
- (the issues with Jenkins have been
    fixed) (skitt,
    18:54:34)
- also upgrading to the latest version of
    JIRA (skitt,
    18:54:43)
- should fix a couple of issues and provide a
    couple of features people have been asking for (skitt,
    18:55:01)
- expecting some fallout from Gerrit accounts
    being locked (skitt,
    18:55:11)
- final migration out of Rackspace planned for
    early December (skitt,
    18:55:20)
- as mentioned previously, we’ll be uncapped,
    however overage will cost us (but less than with Rackspace)
    (skitt,
    18:55:53)
- things should be much better after the
    migration: better relations with the provider, no more hybrid
    setup... (skitt,
    18:58:52)
 
 
- LF news (skitt, 18:59:21)
  - the LF has asked that we display the antitrust
    policy notice at the start of every TSC call (skitt,
    18:59:39)
- many people didn’t get the voting emails from
    Condorcet for the CAL election, ping CaseyODL if you haven’t got
    it (skitt,
    19:00:26)
- (he resent them today) (skitt,
    19:00:35)
- the LF is considering moving all their mailing
    lists etc. to groups.io (skitt,
    19:01:13)
- CaseyODL can talk about this at some future
    TWS (skitt,
    19:03:45)
 
 
- Cookies (skitt, 19:04:06)
Meeting ended at 19:04:12 UTC
(full logs).
Action items
  - rovarga_ to fill in the yangtools milestone readouts until an alternative is in place
People present (lines said)
  - skitt (71)
- dfarrell07 (10)
- jamoluhrsen (10)
- abhijitkumbhare (9)
- tykeal (7)
- odl_meetbot (5)
- CaseyODL (4)
- lori (3)
- gzhao (2)
- anipbu (2)
- klou (1)
- LuisGomez (1)
- vishnoianil (1)
Generated by MeetBot 0.1.4.