#opendaylight-meeting: tsc

Meeting started by skitt at 18:00:24 UTC (full logs).

Meeting summary

  1. Agenda bashing and roll-call (skitt, 18:00:48)
    1. abhijitkumbhare (abhijitkumbhare, 18:01:37)
    2. anipbu (anipbu, 18:01:50)
    3. gzhao (IRC only) (gzhao, 18:01:57)
    4. skitt (skitt, 18:02:07)
    5. TSC members please info in (skitt, 18:02:13)
    6. rovarga (rovarga, 18:02:25)
    7. Thanh Ha (zxiiro, 18:03:40)
    8. jamoluhrsen (jamoluhrsen, 18:03:59)
    9. shague (shague, 18:04:05)
    10. lori (lori, 18:04:08)
    11. Brady Johnson (bjohnson, 18:04:21)
    12. Anil Vishnoi (vishnoianil_, 18:04:42)

  2. Groups.io (skitt, 18:06:10)
    1. CaseyODL will send an email out later (skitt, 18:06:17)
    2. there is a setting to limit notifications using hashtag filters (skitt, 18:06:30)
    3. hashtags can be muted, and can have a limited lifetime (skitt, 18:06:40)
    4. it’s also possible to require hashtags in a post (skitt, 18:06:51)
    5. it might be possible to set up mail-to-groups.io forwarding with automated tagging (skitt, 18:07:21)
    6. LuisGomez (LuisGomez, 18:07:48)

  3. TSC chair elections (skitt, 18:09:23)
    1. emails went out very recently to TSC members (skitt, 18:09:31)
    2. two candidates: abhijitkumbhare and bjohnson (skitt, 18:09:41)
    3. if members don’t get their email soon they should contact CaseyODL (skitt, 18:10:29)

  4. Infrastructure (skitt, 18:11:46)
    1. two major changes this week (skitt, 18:12:42)
    2. Gerrit happened last Saturday (skitt, 18:12:50)
    3. IT working through the queue of emails from people without LFid mappings (skitt, 18:13:04)
    4. some groups without committers because the committers didn’t accept their invites (skitt, 18:13:17)
    5. please open a helpdesk ticket with any issues encountered (skitt, 18:13:41)
    6. we now have the latest version of Gerrit (skitt, 18:13:52)
    7. there’s an option for a new UI at the bottom of the screen (skitt, 18:14:01)
    8. the UI is now mobile-compliant (skitt, 18:14:08)
    9. Jenkins also got upgraded yesterday, in a slightly unplanned move (skitt, 18:14:25)
    10. Rackspace’s environment dropped offline so it seemed like the ideal time to move (skitt, 18:14:39)
    11. there are still infra problems in the new provider (skitt, 18:14:50)
    12. we’re hitting them too hard (skitt, 18:14:57)

  5. NETCONF (skitt, 18:18:36)
    1. concerns on the mailing list about the status of the project (skitt, 18:18:55)
    2. currently no PTL, little committer activity (skitt, 18:19:06)
    3. Jakub Morvay stepped forward as PTL and got approved by the committers (skitt, 18:19:36)
    4. he has cycles for bug fixing, milestones and community activity (skitt, 18:19:48)
    5. still important to increase the number of committers (skitt, 18:20:48)
    6. we want to make sure we get quality committers, who won’t just do basic code clean-up (skitt, 18:22:40)
    7. it remains the project’s prerogative to choose the committers it wishes to promote (skitt, 18:23:20)
    8. but it’s also important to give contributors a chance (skitt, 18:24:42)
    9. it’s also necessary to try to keep the docs and test contacts positions filled (skitt, 18:27:41)
    10. reviewing isn’t only up to committers, we need peer reviews too (skitt, 18:29:51)
    11. ACTION: Jakub Morvay to get the NETCONF project revived (reviews going etc.) (skitt, 18:33:33)
    12. ACTION: the TSC to review the NETCONF situation in early January (skitt, 18:33:46)

  6. odlparent 3 / yangtools 2 (skitt, 18:34:11)
    1. migration tracker: https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018#To_Do_prio._critical (skitt, 18:34:42)
    2. migration in progress for offset 0 (skitt, 18:36:20)
    3. the migration was planned at the DDF, with feedback from downstreams who were present then (skitt, 18:37:51)
    4. it was also communicated on the mailing lists (skitt, 18:37:58)
    5. the reasons for the upgrade are: (skitt, 18:41:57)
    6. * upgrading to the latest Karaf, 4.1.3 (with a sane version of SSH, which is important for security and NETCONF, and upgraded Jetty which helps websockets) (skitt, 18:42:21)
    7. * upgrading to Scala (2.12.4), which is a breaking upgrade but brings higher performance, smaller size (mostly dealt with in controller) (skitt, 18:42:57)
    8. * upgrading to Akka 2.5 which is the currently-supported version (skitt, 18:43:13)
    9. * early support for Java 9 (skitt, 18:43:26)
    10. * in yangtools 2, a pile of API changes which were waiting for a semantic versioning breaking change (skitt, 18:43:43)
    11. with YANG 1.1 properly integrated in the meta-model, lots of clean-up, future support for forthcoming Guava changes, use of java.util.Optional (skitt, 18:44:21)
    12. as we peel out projects from autorelease, we can expect more changes where we need to kick everyone out of autorelease and int/dist (skitt, 18:45:52)
    13. we do need to make sure that upstream changes aren’t forced down project’s throats (skitt, 18:49:31)
    14. we’ll soon be in a position to do a platform release (skitt, 18:50:21)
    15. once we get there the whole process will be much more predictable (skitt, 18:50:53)
    16. kkershaw notes Oxygen code freeze for offset 2 projects is 21 Jan. 2018, RC0 is 7 Feb. 2018. So integration w/ ODLParent 3/Yangtools 2 must be done by then (abhijitkumbhare, 18:52:41)
    17. we need some way of tracking progress on projects out of autorelease (odlparent, yangtools) (skitt, 18:55:19)
    18. such projects need to document in advance clear integration windows (skitt, 18:55:30)
    19. VOTE: Voted on "will offset 0 projects start merging patches now for the odlparent 3 / yangtools 2 migration?" Results are (skitt, 19:01:05)
    20. gating requirements are: (skitt, 19:06:45)
    21. 1. CSIT back online (skitt, 19:06:49)
    22. 2. all the critical patch projects ready and tested (skitt, 19:06:58)
    23. (manual validation) (skitt, 19:07:04)
    24. 3. clean out autorelease and int/dist (skitt, 19:07:28)
    25. then we start merging patches, ignoring int/dist (skitt, 19:07:38)
    26. then rebuild autorelease and int/dist, which should give us valid CSIT for all critical migrated projects (skitt, 19:07:54)
    27. this gives us a stable autorelease build containing all the critical projects (skitt, 19:08:07)
    28. vote on the mailing list (skitt, 19:08:35)
    29. ACTION: skitt to write the plan up and start the vote on the mailing list (skitt, 19:09:16)

  7. Cookies (skitt, 19:09:20)
    1. extra cookies for skitt (tykeal, 19:09:43)


Meeting ended at 19:09:46 UTC (full logs).

Action items

  1. Jakub Morvay to get the NETCONF project revived (reviews going etc.)
  2. the TSC to review the NETCONF situation in early January
  3. skitt to write the plan up and start the vote on the mailing list


Action items, by person

  1. skitt
    1. skitt to write the plan up and start the vote on the mailing list
  2. UNASSIGNED
    1. Jakub Morvay to get the NETCONF project revived (reviews going etc.)
    2. the TSC to review the NETCONF situation in early January


People present (lines said)

  1. skitt (79)
  2. odl_meetbot (9)
  3. bjohnson (5)
  4. rovarga (4)
  5. abhijitkumbhare (3)
  6. gzhao (2)
  7. kkershaw (2)
  8. zxiiro (2)
  9. anipbu (2)
  10. tykeal (1)
  11. shague (1)
  12. LuisGomez (1)
  13. vishnoianil_ (1)
  14. lori (1)
  15. jamoluhrsen (1)
  16. CaseyODL (0)


Generated by MeetBot 0.1.4.