#opendaylight-meeting: tsc

Meeting started by skitt at 18:01:30 UTC (full logs).

Meeting summary

  1. Agenda bashing (skitt, 18:01:48)
    1. TSC members please info in (skitt, 18:01:53)
    2. skitt (skitt, 18:01:57)
    3. Brady Johnson (bjohnson, 18:01:57)
    4. gzhao (gzhao, 18:02:00)
    5. abhijitkumbhare (abhijitkumbhare, 18:02:29)
    6. anipbu (anipbu, 18:02:33)
    7. jamoluhrsen (jamoluhrsen, 18:09:34)
    8. LuisGomez (LuisGomez, 18:12:40)
    9. Anil Vishnoi (vishnoianil, 18:12:59)
    10. VOTE: Voted on "Who will be present for next week's TSC call (APAC)?" Results are, +1: 3, -1: 5 (skitt, 18:14:28)
    11. Very little participation in APAC meetings anyway, including from APAC members (skitt, 18:14:56)
    12. Perhaps we should only hold APAC meetings when requested (skitt, 18:15:12)
    13. ACTION: bjohnson to reach out to APAC members to see whether they want to continue the APAC meetings and in what form (skitt, 18:17:16)
    14. Last meeting only had six people join (skitt, 18:18:36)
    15. (last APAC meeting) (skitt, 18:18:46)
    16. We hardly ever meet quorum for APAC calls (skitt, 18:18:58)
    17. We could just cancel next week’s meeting outright anyway (skitt, 18:19:33)
    18. AGREED: Next week’s TSC meeting is cancelled (December 28) (skitt, 18:20:49)
    19. ACTION: CaseyODL to remove the calendar entry for next week’s meeting (skitt, 18:21:10)
    20. The next TSC meeting will be on January 4 at the usual time (skitt, 18:22:09)
    21. The next APAC call will be at the end of January as usual (for the time being) (skitt, 18:22:23)

  2. Events (skitt, 18:23:14)
    1. Nothing new, next big event is at ONS, with an ODL DDF (skitt, 18:25:26)
    2. CaseyODL confirms ODL DDF at ONS will be at start of event, not end, so doesn't conflict with passover on Friday (dfarrell07, 18:25:56)
    3. ACTION: CaseyODL to pressure LF leadership folks to get invites to LF Leadership Summit out ASAP so folks can plan budget (dfarrell07, 18:26:27)
    4. unclear yet whether the ODL DDF will take place before ONS (the previous Friday or over the weekend) or concurrently with the start of ONS (skitt, 18:26:57)
    5. There will also be a cross-project CI/CD mini-summit (skitt, 18:28:03)

  3. Oxygen (skitt, 18:28:11)
    1. https://wiki.opendaylight.org/view/Release_Dashboard (klou, 18:28:17)
    2. ACTION: New TSC Chair to follow up with new NetConf PTL about situation, adding new committers, it has been the week they requested (dfarrell07, 18:33:28)
    3. vishnoianil points out that if Netconf can't get back to TSC in timely manner it seems very likely they can't follow up with community (dfarrell07, 18:35:05)
    4. if new NetConf PTL doesn't reply with plans to get project healthy by TSC meeting 1/4 <something bad will happen> (dfarrell07, 18:35:27)
    5. the lack of updates from yangtools, mdsal etc. raises the question of what to do with projects with a bus factor of 1 (skitt, 18:37:46)
    6. the wiki suggests there are quite a few committers, which seems to be inaccurate (skitt, 18:38:27)
    7. LuisGomez points out that there are lots of committers on yangtools wiki, that it's not okay to have this disconnect between wiki and reality (dfarrell07, 18:38:31)
    8. vishnoianil wants projects to update committer list so TSC can accurately judge health of project (dfarrell07, 18:39:21)
    9. we need to ask projects who is active, and provide a definition of active (skitt, 18:39:45)
    10. skitt points out that they are therefore not correctly reporting "wiki up to date" (dfarrell07, 18:39:52)
    11. we need to compare the official list of committers on the wiki with real levels of activity (skitt, 18:40:07)
    12. dfarrell07 thinks as a part of new release model we will have chance to put better requirements about what "active" means, what to do if project is unhealthy (dfarrell07, 18:40:42)
    13. a big list of inactive committers on the wiki also discourages new contributors (skitt, 18:40:43)
    14. We did not release SR2 on December 7 (skitt, 18:45:01)
    15. recommendation is just to merge SR2 and SR3, and release on February 7 (skitt, 18:45:22)
    16. ACTION: CaseyODL to add "healthy project/committer" discussion to TWS agenda (dfarrell07, 18:45:37)
    17. VOTE: Voted on "Shall we release SR2 on February 7, 2018, merging SR2 and SR3?" Results are, +1: 8 (skitt, 18:46:19)
    18. AGREED: We will release Nitrogen SR2 on February 7, 2018, merging SR2 and SR3 (skitt, 18:46:33)
    19. SR3 will be planned for May 7 (skitt, 18:46:48)
    20. No planned SR4 now (skitt, 18:47:57)
    21. SR3 planned to be released last week (skitt, 18:48:18)
    22. we have a RC, had to re-run CSIT a couple of times (skitt, 18:48:27)
    23. there are 45 failures, all of which have been reviewed (skitt, 18:48:39)
    24. thanks to jamoluhrsen and LuisGomez (skitt, 18:48:44)
    25. 9 remain to deal with, 3 of which appear to be regressions in NetVirt (skitt, 18:48:55)
    26. those bugs will be moved to blocker state, and NetVirt will have to decide what to do (skitt, 18:49:13)
    27. ACTION: shague to decide if three Carbon SR3 regressions are blockers, and if so find someone to fix, else move out of bokcer state (dfarrell07, 18:49:45)
    28. Carbon SR3 is liable to be released only in January (skitt, 18:56:02)

  4. Infrastructure (skitt, 18:56:06)
    1. We will soon be completely switched over to the new Nexus system, which should resolve download speed issues (skitt, 18:57:16)
    2. logs are being rsync'd over, sorry impossible to get to old logs for now (dfarrell07, 18:57:25)
    3. The quick clone issue should be resolved soon, except for projects using submodules (skitt, 18:58:03)
    4. there is a git mirror in our new cloud that mirrors main git in AWS, that makes clones work but some types of interactions with Gerrit are still very slow/don't work at all (dfarrell07, 18:58:17)
    5. dfarrell07 has seen curls of small files from old gerrit just fail, TSC timeout (dfarrell07, 18:58:38)
    6. dfarrell07 has seen curls of small files from old gerrit just fail, TCP timeout (dfarrell07, 18:58:52)
    7. The vendor also have various tweaks in the wings to help fix speed issues (skitt, 18:59:44)

  5. Cookies (skitt, 19:00:25)


Meeting ended at 19:00:30 UTC (full logs).

Action items

  1. bjohnson to reach out to APAC members to see whether they want to continue the APAC meetings and in what form
  2. CaseyODL to remove the calendar entry for next week’s meeting
  3. CaseyODL to pressure LF leadership folks to get invites to LF Leadership Summit out ASAP so folks can plan budget
  4. New TSC Chair to follow up with new NetConf PTL about situation, adding new committers, it has been the week they requested
  5. CaseyODL to add "healthy project/committer" discussion to TWS agenda
  6. shague to decide if three Carbon SR3 regressions are blockers, and if so find someone to fix, else move out of bokcer state


Action items, by person

  1. bjohnson
    1. bjohnson to reach out to APAC members to see whether they want to continue the APAC meetings and in what form
  2. CaseyODL
    1. CaseyODL to remove the calendar entry for next week’s meeting
    2. CaseyODL to pressure LF leadership folks to get invites to LF Leadership Summit out ASAP so folks can plan budget
    3. CaseyODL to add "healthy project/committer" discussion to TWS agenda
  3. UNASSIGNED
    1. New TSC Chair to follow up with new NetConf PTL about situation, adding new committers, it has been the week they requested
    2. shague to decide if three Carbon SR3 regressions are blockers, and if so find someone to fix, else move out of bokcer state


People present (lines said)

  1. skitt (63)
  2. dfarrell07 (30)
  3. odl_meetbot (17)
  4. abhijitkumbhare (8)
  5. anipbu (6)
  6. gzhao (4)
  7. bjohnson (4)
  8. jamoluhrsen (4)
  9. LuisGomez (3)
  10. vishnoianil (3)
  11. klou (2)
  12. CaseyODL (2)
  13. tykeal (1)


Generated by MeetBot 0.1.4.