#opendaylight-meeting: goals

Meeting started by dfarrell07 at 16:45:01 UTC (full logs).

Meeting summary

    1. talking about specific ideas/requests (dfarrell07, 16:45:17)
    2. major challenge to getting new devs onboard is docs (dfarrell07, 16:45:26)
    3. need someone dedicated upstream to work on docs (dfarrell07, 16:45:35)
    4. some docs are project specific and hard for someone to step in and write, others are general, this is where someone can step in (dfarrell07, 16:45:59)
    5. https://bluejeans.com/375326132 (dfarrell07, 16:50:16)
    6. zxiiro suggests this docs resource could be dedicated to LFN generally (dfarrell07, 16:52:56)
    7. discussion about how to get people using opendaylight contributing upstream, LuisGomez points out focusing on companies may be good idea (dfarrell07, 16:55:39)
    8. maybe an LFN resource could focus on messaging to companies that consume LFN projects that they can't just take from open source, they should contribute too (dfarrell07, 16:57:06)
    9. ACTION: All: Make sure the getting started for new developers should be up-to-date (abhijitkumbhare, 16:58:52)
    10. maybe program to help users who are not currently contributing to start contributing by giving more dedicated support, have meetings to answer questions, make sure we address their needs (dfarrell07, 16:59:06)
    11. Incentivize developers to add videos/demos on how to do things? (abhijitkumbhare, 16:59:39)
    12. another request is to make sure member companies send resources to key platform parts of ODL that don't have healthy communities (dfarrell07, 17:01:20)
    13. this will become easier in Managed Release model, but it's a bit of a bandaid, need long term contributors (dfarrell07, 17:01:42)
    14. should make it clear to member companies that they need to staff these projects (dfarrell07, 17:01:58)
    15. maybe also can ask wider LFN audience if they can send resources to help these parts of ODL, "these are the places we need more devs" list (dfarrell07, 17:02:35)
    16. should add label in Jira to mark TODOs that are good for beginners (dfarrell07, 17:04:52)
    17. LuisGomez says we need to be clear to consumers about parts of ODL that need help (dfarrell07, 17:05:07)
    18. https://vexxhost.com/public-cloud/servers/ (zxiiro, 17:10:44)
    19. we need to start getting metrics fow how much we spend on infra so we can know if we're getting better (dfarrell07, 17:11:07)
    20. goal to work on infra usage (dfarrell07, 17:11:23)
    21. likely all LFN projects should get these infra usage reports (dfarrell07, 17:11:54)
    22. jamo suggests we start eating our own dog food by using ODL in our own infra (dfarrell07, 17:15:46)
    23. this would be amazing for marketing^^ (dfarrell07, 17:16:10)
    24. I guess we can list this new Managed Release model as a goal, as we're just starting it this release (dfarrell07, 17:17:46)
    25. should list this cross project CI stuff we've been doing, do more of it (dfarrell07, 17:21:00)
    26. goal: releasing on time (dfarrell07, 17:22:30)
    27. new model will help release on time, but still need to focus on it (dfarrell07, 17:22:43)
    28. should reevaluate release timing and make sure we're still in sync will the external projects we should be in sync with (dfarrell07, 17:24:56)
    29. we want to continue having ddf per release (dfarrell07, 17:27:29)
    30. ACTION: abhijitkumbhare to make this into a wiki (dfarrell07, 17:27:49)


Meeting ended at 17:27:57 UTC (full logs).

Action items

  1. All: Make sure the getting started for new developers should be up-to-date
  2. abhijitkumbhare to make this into a wiki


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to make this into a wiki


People present (lines said)

  1. dfarrell07 (32)
  2. zxiiro (4)
  3. skitt (3)
  4. odl_meetbot (3)
  5. abhijitkumbhare (3)
  6. gzhao (1)
  7. rovarga_ (1)
  8. jamoluhrsen (1)


Generated by MeetBot 0.1.4.