#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 17:04:29 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 17:05:42)
    1. odlparent 3.0.3 (rgoulding, 17:05:58)
    2. MessageBodyWriter Exception in AAA Master (rgoulding, 17:06:06)
    3. ACTION: rgoulding send out Jersey Bump Patches (rgoulding, 17:09:22)

  2. odlparent 3.0.3 (rgoulding, 17:10:00)
    1. Jersey with jersey-client? (rgoulding, 17:10:35)
    2. SXP has issues with SXP CSIT (rgoulding, 17:10:59)
    3. SXP pulls in robot deps that rely on jetty feature (rgoulding, 17:11:10)
    4. In karaf 4.1.3 pulls in jetty 9.3.15 and odl-karaf-feat-jetty (depend on war feature) pull in jetty 9.3.14 (rgoulding, 17:11:36)
    5. our DM relies upon jetty 8.something (rgoulding, 17:11:48)
    6. odlparent 3.0.3 upgrades to karaf 4.1.4 (fixes jetty dependencies issues resolves to 9.3.21) (rgoulding, 17:12:29)
    7. also resolves more bundle refresh issues (rgoulding, 17:12:42)
    8. odl-jersey-1 added to odlparent 3.0.3 (rgoulding, 17:13:04)
    9. war brings in more stuff around jetty (rgoulding, 17:14:15)
    10. do we want to try a 3.0.3 in the intial offering (rgoulding, 17:15:53)
    11. i.e., do we hack something together for oxygen GA for SXP/AAA (rgoulding, 17:16:14)
    12. given the timeline maybe we should stick with 3.0.2 (rgoulding, 17:18:00)
    13. is there a workaround for SXP? (rgoulding, 17:20:52)
    14. skitt thinks that if you manually load jetty feature first that everythign should work (rgoulding, 17:21:03)
    15. 3.0.3 put off until first SR of oxygen (rgoulding, 17:21:43)
    16. skitt does anyone have any thoughts on using managed blueprint feature that karaf provides instead of building our own (rgoulding, 17:23:02)
    17. https://git.opendaylight.org/gerrit/51455 (skitt, 17:23:28)
    18. rovarga points out that we are utilizng an extender which may require some more elegant loading (rgoulding, 17:23:53)
    19. there is investigation needed for htis (rgoulding, 17:23:59)

  3. cohorts (rgoulding, 17:25:28)
    1. https://jira.opendaylight.org/browse/CONTROLLER-1641 (rgoulding, 17:25:30)
    2. tpantelis asking about status of this (rgoulding, 17:25:36)

  4. archetype (rgoulding, 17:25:39)
    1. https://git.opendaylight.org/gerrit/#/c/67511/ (rgoulding, 17:25:59)
    2. archetype probably should live somewhere else (rgoulding, 17:30:30)
    3. the -rest feature depends on NETCONF (rgoulding, 17:30:39)
    4. the day we add tests to make sure archetype isn’t broken, it will cause circular dependency issue (rgoulding, 17:30:55)
    5. or we peel controller out of autorelease and controller/NETCONF have separate release cycles (rgoulding, 17:31:14)

  5. netvirt CSIT (rgoulding, 17:34:23)
    1. restart issue has been worked around (rgoulding, 17:34:28)
    2. tpantelis still thinks there is still something weird going on (rgoulding, 17:34:36)
    3. tpantelis can’t reproduce in toaster example with CFG files (rgoulding, 17:35:06)

  6. odlparent release plans (rgoulding, 17:37:06)
    1. what is the plan? (rgoulding, 17:37:10)
    2. there are a bunch of patches against master which have been kicking around a while (rgoulding, 17:37:24)
    3. patches go into 3.0.X if they are bug fixes (rgoulding, 17:37:35)
    4. 3.1.X is for new features that don’t break stuff (rgoulding, 17:37:47)
    5. that way we should at least be able to start merging things again (rgoulding, 17:38:05)
    6. is guava upgrade 3.0 or 3.1 stuff (rgoulding, 17:38:33)
    7. since it changes behavior (rgoulding, 17:38:37)
    8. and what about the akka stuff? (rgoulding, 17:38:41)
    9. 3.0.X is for intial release and 3.1.Y may be the SR target (rgoulding, 17:39:03)
    10. so perhaps 3.0.X may not actually be used in another distribution (rgoulding, 17:39:14)

  7. feature restarts in SFC (rgoulding, 17:40:29)
    1. bjohnson seeing strange restarts for SFC (rgoulding, 17:40:42)
    2. what would be the best project to create the bug for? (rgoulding, 17:40:49)
    3. rovarga says probably odlparent, but it may require downstream fixes (rgoulding, 17:41:14)
    4. try etc/org.ops4j.pax.url.cfg and adjust featuresBoot property (rgoulding, 17:43:03)
    5. we would need to see the karaf log to see what is going on (rgoulding, 17:43:11)


Meeting ended at 17:44:18 UTC (full logs).

Action items

  1. rgoulding send out Jersey Bump Patches


Action items, by person

  1. rgoulding
    1. rgoulding send out Jersey Bump Patches


People present (lines said)

  1. rgoulding (56)
  2. odl_meetbot (3)
  3. bjohnson (2)
  4. skitt (1)
  5. LuisGomez (1)


Generated by MeetBot 0.1.4.