#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:59:46 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:59:49)
    1. review existing action items (rgoulding, 16:00:05)
    2. https://git.opendaylight.org/gerrit/#/q/topic:simple-dist_web (rgoulding, 16:02:31)
    3. Archi Q: How to feed back if listeners worked?? Neutron requirement. (rgoulding, 16:02:39)
    4. mdsal evolution breaking changeshow to? (rgoulding, 16:02:48)

  2. review existing action items (rgoulding, 16:04:27)
  3. simple-dist_web (rgoulding, 16:06:53)
    1. https://git.opendaylight.org/gerrit/#/q/topic:simple-dist_web (rgoulding, 16:06:55)
    2. ACTION: tpantelis to investigate the TCCL issues in 68840 (rgoulding, 16:10:14)
    3. curl -u admin:admin http://localhost:8181/auth/v1/users (rgoulding, 16:25:26)
    4. the above is a way to invoke the servlet code in AAA (rgoulding, 16:25:44)
    5. this problem only comes up when the servlet is hit due to lazy initialization (rgoulding, 16:26:00)
    6. ACTION: vorburger to create a Jira utilizing older patchset to illustrate the issue (rgoulding, 16:28:01)

  4. Archi Q: How to feed back if listeners worked?? Neutron requirement. (rgoulding, 16:28:42)
    1. In Neutron, if the listeners that are invoked on changes can feedback to REST APIs that things didn’t work. (rgoulding, 16:30:09)

  5. mdsal evolution breaking changeshow to? (rgoulding, 16:35:33)
    1. https://lists.opendaylight.org/pipermail/tsc/2018-March/009053.html (rovarga_, 16:36:20)
    2. https://git.opendaylight.org/gerrit/#/q/topic:binding-tlc+(status:open+OR+status:merged) (rovarga_, 16:40:05)
    3. vorburger asks, for the breaking changes, is there a better way to roll this out with topic branches etc. (rgoulding, 16:43:03)
    4. currently, we don’t have an ok-go-ahead to do this sort of breakage because we don’t have the commitment to fix it up afterwards. hence why it currently has a -2. (rgoulding, 17:07:16)


Meeting ended at 17:24:18 UTC (full logs).

Action items

  1. tpantelis to investigate the TCCL issues in 68840
  2. vorburger to create a Jira utilizing older patchset to illustrate the issue


People present (lines said)

  1. rgoulding (22)
  2. odl_meetbot (4)
  3. rovarga_ (2)


Generated by MeetBot 0.1.4.