#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:01:31 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:01:36)
    1. review existing action items (rgoulding, 16:01:42)
    2. cancel next week’s meeting (rgoulding, 16:01:48)

  2. existing action items (rgoulding, 16:04:11)
    1. tpantelis to investigate the TCCL issues in 68840 (rgoulding, 16:04:24)
    2. vorburger to create a Jira utilizing older patchset to illustrate the issue (rgoulding, 16:04:33)
    3. both DONE (rgoulding, 16:04:38)

  3. Cancel next weeks call; many kernel contributors will be at ONS (rgoulding, 16:06:01)
  4. web service api in AAA (rgoulding, 16:07:48)
    1. a single API might be easier since they seem to go together logically (rgoulding, 16:08:45)
    2. ACTION: rgoulding to test https://git.opendaylight.org/gerrit/#/c/69411/ locally (rgoulding, 16:17:59)
    3. ACTION: tpantelis to take another look and follow up on API patches (rgoulding, 16:20:30)

  5. NETCONF committers (rgoulding, 16:26:52)
    1. make sure to add “JakubToth” with no space instead of “Jakub Toth" (rgoulding, 16:27:05)
    2. https://lists.opendaylight.org/pipermail/infrastructure/ (rgoulding, 16:35:09)
    3. this list is used for infrastructure related issues (rgoulding, 16:35:21)

  6. removal of DCL (rgoulding, 16:36:59)
    1. tpantelis put in Oxygen release notes that it will be removed in Fluorine (rgoulding, 16:37:37)
    2. one user in ovsdb but not as DCL, just using it as a DTO (rgoulding, 16:38:56)
    3. put in milestone, pick a date, enter a weather item, and pull the trigger (rgoulding, 16:39:30)

  7. removal of EOS API in controller (rgoulding, 16:40:10)
    1. just ovsdb as a remaining user (rgoulding, 16:40:18)

  8. config subsystem removal (rgoulding, 16:41:45)
    1. tpantelis had said in release notes that it was deprecated in Nitrogen and would be removed in Fluorine (rgoulding, 16:42:02)
    2. the issue with partial removal is that we will have to keep some APIs and config yang around (rgoulding, 16:42:42)
    3. we can discuss this at DDF (rgoulding, 16:42:48)

  9. sal-dom-api removal (rgoulding, 16:43:54)
    1. everything in sal-dom-api hs a counterpart in mdsal now (rgoulding, 16:44:03)
    2. deprecate all apis in the controller to start the ticking clock (rgoulding, 16:44:19)
    3. this is why DCL removal is first on the list (rgoulding, 16:47:20)
    4. since there is not a counterpart for that (rgoulding, 16:47:28)

  10. which parent to use (rgoulding, 16:53:14)
    1. use binding-parent, which derives from odlparent’s bundle-parent (rgoulding, 16:53:31)
    2. https://github.com/opendaylight/mdsal/blob/master/binding/binding-parent/pom.xml#L14 (rgoulding, 16:53:38)


Meeting ended at 16:54:41 UTC (full logs).

Action items

  1. rgoulding to test https://git.opendaylight.org/gerrit/#/c/69411/ locally
  2. tpantelis to take another look and follow up on API patches


Action items, by person

  1. rgoulding
    1. rgoulding to test https://git.opendaylight.org/gerrit/#/c/69411/ locally


People present (lines said)

  1. rgoulding (37)
  2. odl_meetbot (3)
  3. vorburger (1)


Generated by MeetBot 0.1.4.