#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:01:55 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:01:59)
    1. yangtools json patch request (rgoulding, 16:07:16)

  2. yangtools json patch request (rgoulding, 16:07:27)
    1. https://lists.opendaylight.org/pipermail/yangtools-dev/2018-April/002218.html (rgoulding, 16:08:06)
    2. patch that was reverted (rgoulding, 16:08:50)
    3. https://git.opendaylight.org/gerrit/#/c/68436/ (rgoulding, 16:08:52)
    4. Atul is asking how to do this correctly? (rgoulding, 16:09:02)
    5. the patch is correct but downstreams need to adopt to the changes (rgoulding, 16:09:16)
    6. revert patch here (rgoulding, 16:09:56)
    7. https://git.opendaylight.org/gerrit/#/c/70056/ (rgoulding, 16:09:58)
    8. bug link (rgoulding, 16:11:31)
    9. https://jira.opendaylight.org/browse/NETCONF-486 (rgoulding, 16:11:33)

  3. NETCONF-526 (rgoulding, 16:15:48)
    1. https://git.opendaylight.org/gerrit/#/c/69482/ (rgoulding, 16:15:53)
    2. https://jira.opendaylight.org/browse/NETCONF-526 (rgoulding, 16:16:01)
    3. the issue is that this fixes this just for RESTCONF API and not for other APIS (rgoulding, 16:19:10)
    4. Bala claims that this will only come into effect if there is not operation specified (rgoulding, 16:19:56)
    5. ACTION: jmorvay to look at the patch again and see if this will break someone not using RESTCONF (i.e., using NETCONF transaction APIs), and if it doesn’t appear to break others then it is acceptable. But this is basically cahnging the “edit-config” operation we are sending to a device (rgoulding, 16:26:02)
    6. tpantelis says this may be the lesser of two evils (rgoulding, 16:33:22)
    7. we should emulate the same behaviour in RFC8040 impl (rgoulding, 16:35:23)
    8. advice given to push to master then cherry-pick down to past stable branches (rgoulding, 16:36:39)
    9. use topic branches! (rgoulding, 16:39:07)
    10. git review -t <topic-branch> (rgoulding, 16:39:20)


Meeting ended at 16:44:51 UTC (full logs).

Action items

  1. jmorvay to look at the patch again and see if this will break someone not using RESTCONF (i.e., using NETCONF transaction APIs), and if it doesn’t appear to break others then it is acceptable. But this is basically cahnging the “edit-config” operation we are sending to a device


People present (lines said)

  1. rgoulding (25)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.