#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:58:47 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:58:51)
    1. vorburger: distribution odl-integration-all SingleFeatureTest Build timed out (after 120 minutes) next steps? (rgoulding, 15:58:59)
    2. vorburger: Anyone got any memories if in JAXB it's OK to have non-trivial getters, or if any known weird timing concurrency issues? Asking for https://jira.opendaylight.org/browse/NEUTRON-159 where a trival JSON un-marhshalling fails tests arbitrarily every now and then. (rgoulding, 15:59:09)
    3. configurable NETCONF HELLO message (rgoulding, 16:02:47)

  2. distribution odl-integration-all SingleFeatureTest Build timed out (after 120 minutes) next steps? (rgoulding, 16:04:51)
    1. happening in master (rgoulding, 16:05:14)
    2. vorburger has seen this multiple times in many changes (rgoulding, 16:05:30)
    3. https://jenkins.opendaylight.org/releng/job/neutron-distribution-check-fluorine/26/console (vorburger, 16:06:07)
    4. need the logs from SFT to see what is actually happening (rgoulding, 16:07:29)
    5. rovarga claims this should have timed out much sooner (rgoulding, 16:07:45)
    6. since SFT has timeout much less than 120 minutes (rgoulding, 16:07:54)
    7. surefire logs aren’t kept by default right now (rgoulding, 16:09:18)
    8. configure those logs to be output somewhere else might be a solution (rgoulding, 16:09:30)
    9. integration/distribution could be bumped to utilize a SNAPSHOT for debugging purposes (rgoulding, 16:13:13)
    10. ACTION: vorburger to set up some scaffolding to keep logs for SFT for odlparent 3.1.X (rgoulding, 16:14:25)

  3. Anyone got any memories if in JAXB it's OK to have non-trivial getters, or if any known weird timing concurrency issues? Asking for https://jira.opendaylight.org/browse/NEUTRON-159 where a trival JSON un-marhshalling fails tests arbitrarily every now and then. (rgoulding, 16:15:32)
    1. https://jira.opendaylight.org/browse/NEUTRON-159 (rgoulding, 16:16:17)

  4. Configurable NETCONF HELLO message (rgoulding, 16:17:35)
  5. SFT timeout (rgoulding, 16:23:41)
    1. if the timeout on int/dist cross project feature dependency issue, is this something we can redo? (rgoulding, 16:24:14)
    2. there is an email to assist figuring out how to recreate this (rgoulding, 16:24:44)

  6. javax.annotation issue (rgoulding, 16:27:40)
    1. yanglib feature from NETCONF should be removed from odl-integration-compatible-with-all (rgoulding, 16:27:57)
    2. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/distribution-verify-oxygen/234/console.log.gz (rovarga_, 16:28:15)
    3. ACTION: jmorvay to look at imports for the yanglib artifact to resolve the divergent dependency chain issue (rgoulding, 16:30:58)
    4. similar patch from past: https://git.opendaylight.org/gerrit/#/c/68255/ (rgoulding, 16:32:07)
    5. https://git.opendaylight.org/gerrit/#/c/68255/ (rgoulding, 16:32:09)
    6. https://github.com/opendaylight/netconf/blob/master/netconf/yanglib/pom.xml#L34 (rgoulding, 16:34:10)
    7. So do something like “!javax.annotation, (rgoulding, 16:35:18)
    8. ACTION: jmorvay to look into raising patch for excluding javax.annotation and a particular version for javax.ws.rs (rgoulding, 16:36:15)
    9. ACTION: rgoulding to open bug to have WebContextRegistration to extend ObjectRegistration (rgoulding, 16:41:30)
    10. alternative is to move AAA to jersey2, and see if the other projects are unaffected (rgoulding, 16:45:24)
    11. https://github.com/opendaylight/aaa/blob/master/aaa-shiro/impl/src/main/java/org/opendaylight/aaa/shiro/web/env/WebInitializer.java#L42 (rgoulding, 16:50:32)
    12. is it useful to not repeat this everywhere and do the import in the pom.xml (rgoulding, 16:50:59)
    13. can we hide this behind some API? (rgoulding, 16:51:26)
    14. does the jax-rs api have a way to give you the implementation of the servlet (rgoulding, 16:53:59)
    15. rovarga brings up point that we could create a utility bundle which you can pass a jax-rs Application to and register your servlet with the web-api (rgoulding, 17:01:47)
    16. separate out a bundle (rgoulding, 17:02:56)
    17. https://jira.opendaylight.org/browse/ODLPARENT-148 (vorburger, 17:05:11)


Meeting ended at 17:09:10 UTC (full logs).

Action items

  1. vorburger to set up some scaffolding to keep logs for SFT for odlparent 3.1.X
  2. jmorvay to look at imports for the yanglib artifact to resolve the divergent dependency chain issue
  3. jmorvay to look into raising patch for excluding javax.annotation and a particular version for javax.ws.rs
  4. rgoulding to open bug to have WebContextRegistration to extend ObjectRegistration


Action items, by person

  1. JMorvay
    1. jmorvay to look at imports for the yanglib artifact to resolve the divergent dependency chain issue
    2. jmorvay to look into raising patch for excluding javax.annotation and a particular version for javax.ws.rs
  2. rgoulding
    1. rgoulding to open bug to have WebContextRegistration to extend ObjectRegistration
  3. vorburger
    1. vorburger to set up some scaffolding to keep logs for SFT for odlparent 3.1.X


People present (lines said)

  1. rgoulding (43)
  2. rovarga_ (8)
  3. skitt (7)
  4. odl_meetbot (5)
  5. vorburger (3)
  6. jamoluhrsen (3)
  7. JMorvay (1)


Generated by MeetBot 0.1.4.