#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:01:31 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:01:37)
    1. odlparent 3.1.0 and yangtools 2.0.3 upgrade status (rgoulding, 16:01:58)
    2. increase in frequency in pax-exam timeouts (rgoulding, 16:04:12)

  2. increase in frequency in pax-exam timeouts (rgoulding, 16:04:28)
    1. https://git.opendaylight.org/gerrit/#/c/71041/ (rgoulding, 16:04:50)
    2. vorburger: in the pax-exam tests you can specify the base karaf that you want to deploy into, and asks what the target is (rgoulding, 16:05:44)
    3. these tests are set to use opendaylight-karaf-empty, which should be already converted to equinox (rgoulding, 16:06:13)
    4. are we overriding it in the controller poms? (rgoulding, 16:07:49)
    5. Exception— “ ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker" (rgoulding, 16:12:21)
    6. this used to happen but is happening much more frequently now (rgoulding, 16:12:34)
    7. rovarga there is probably a race and the race window opened (rgoulding, 16:12:48)
    8. this doesn’t reproduce locally (rgoulding, 16:12:56)
    9. either this is reproducible locally or we need to retain the appropriate logs from jenkins to properly investigate (rgoulding, 16:13:58)
    10. the appropriate information is not put into collected surefire logs (rgoulding, 16:14:57)
    11. binding ITs are not using surefire, they are using failsafe (rgoulding, 16:15:47)
    12. the toaster tests are using failsafe not surefire (rgoulding, 16:16:02)
    13. fire off an email to integration to save off the correct information if test timeout after 2 hours (rgoulding, 16:19:27)
    14. rovarga was able to reproduce locally (rgoulding, 16:20:58)
    15. rovarga has logs and can ship over karaf.log (rgoulding, 16:22:12)
    16. https://lists.opendaylight.org/pipermail/controller-dev/2018-April/014350.html (rgoulding, 16:22:15)
    17. ^^ mail for this issue (rgoulding, 16:22:21)
    18. sal-binding-it is pulling in jersey-core, and the same issues are happening that happened with AAA (rgoulding, 16:22:59)
    19. https://git.opendaylight.org/gerrit/#/c/70979/ (rgoulding, 16:23:43)
    20. ^^ fix in AAA (rgoulding, 16:23:48)
    21. pax-exam is getting messed up if the feature service has trouble getting deployed (rgoulding, 16:26:50)
    22. ACTION: tpantelis to try to remove jersey-core dependency (optional) to see if it is actually needed for the tests (rgoulding, 16:40:50)
    23. this might have been used in formatting controller-config.xml, and may not be needed anymore (rgoulding, 16:42:19)

  3. web centralization (rgoulding, 16:45:43)
    1. we are changing api version so we need to recompile every consumer to make sure this would work. we would need to create an adaptor of javax.ws.rs-api in order to do this in a “single switch” (rgoulding, 16:49:18)

  4. odlparent 3.1.0 and yangtools 2.0.3 upgrade (rgoulding, 16:52:00)
    1. stable/oxygen was upgraded to odlparent 3.1.0 to get karaf upgrade (rgoulding, 16:53:24)
    2. upgrade patches have been merged (rgoulding, 16:54:06)


Meeting ended at 16:54:35 UTC (full logs).

Action items

  1. tpantelis to try to remove jersey-core dependency (optional) to see if it is actually needed for the tests


People present (lines said)

  1. rgoulding (34)
  2. odl_meetbot (3)
  3. skitt (1)


Generated by MeetBot 0.1.4.