#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 16:01:44 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 16:02:00)
    1. https://jira.opendaylight.org/browse/INFRAUTILS-41 (rgoulding, 16:02:09)
    2. https://jira.opendaylight.org/browse/TSC-113 (rgoulding, 16:02:18)
    3. https://lists.opendaylight.org/pipermail/netvirt-dev/2018-May/006878.html (rgoulding, 16:02:28)
    4. https://lists.opendaylight.org/pipermail/tsc/2018-May/009739.html (rgoulding, 16:02:37)
    5. Removal of some deprecated APIS in NETCONF (rgoulding, 16:04:24)
    6. jersey2 update (rgoulding, 16:05:04)
    7. swagger UI bug (rgoulding, 16:05:43)

  2. INFRAUTILS-41 (rgoulding, 16:06:13)
    1. https://jira.opendaylight.org/browse/INFRAUTILS-41 (rgoulding, 16:06:26)
    2. vorburger wants to know plan/next steps (rgoulding, 16:06:45)
    3. this is for upgrading dropwizard.metrics from 3.2.5 to 4.0.2 (rgoulding, 16:07:00)
    4. rovarga asks if this is provided by other JVMs (rgoulding, 16:08:08)
    5. vorburger says he has found that it exists in OpenJDK, but hasn’t tested for IBM’s JDK9 (rgoulding, 16:08:33)
    6. definitely good on OpenJDK and Oracle (rgoulding, 16:08:58)
    7. provides GC stats and other JVM things (rgoulding, 16:09:06)
    8. skitt brings up the fact that dropwizard should have an optional dependency on this (rgoulding, 16:10:26)
    9. the manifest should make it optional? (rgoulding, 16:10:35)
    10. rovarga says that if it isn’t optional then ODL will fail to load if the JVM does not have it (rgoulding, 16:11:29)
    11. the question becomes whether the metrics are mission critical; rovarga claims they are not (rgoulding, 16:11:54)

  3. TSC-113 (rgoulding, 16:15:53)
    1. https://jira.opendaylight.org/browse/TSC-113 (rgoulding, 16:15:57)
    2. upgrade webapps to use jersey 2 (rgoulding, 16:16:20)
    3. tpantelis is driving this forward (rgoulding, 16:16:32)
    4. tpantelis is running the multi-patch job to test if this works (rgoulding, 16:16:56)
    5. neutron patch was already merged (rgoulding, 16:17:01)
    6. tpantelis ran into same problem with dual dependency chain via javax.annotation in the aaa / netconf patches (rgoulding, 16:17:41)
    7. the two patches need each other (i.e., this will break temporarily) (rgoulding, 16:18:05)
    8. we are waiting on a successful multi-patch job (rgoulding, 16:19:57)
    9. jmorvay to check after the meeting and add +1, then tpantelis can self-merge (rgoulding, 16:20:29)
    10. for netconf (rgoulding, 16:20:34)
    11. tpantelis and rgoulding can do it for AAA (rgoulding, 16:20:45)
    12. passing multi-patch is a gating requirement (rgoulding, 16:20:56)
    13. AGREED: (rgoulding, 16:21:01)
    14. should we run netvirt csit? (rgoulding, 16:21:46)
    15. skitt claims it is in a good state right now, so if failures occur there is probably a problem (rgoulding, 16:22:00)
    16. to run netvirt CIST, use test-netvirt-current (skitt, 16:22:30)
    17. to run on a multi-patch job there is a different keyword required (rgoulding, 16:22:51)
    18. you need to supply the url of your multi-patch-job build and pass it to CSIT (rgoulding, 16:23:02)

  4. Autorelease oxygen failed to build odl-netvirt-openstack from netvirt (rgoulding, 16:24:41)
    1. https://lists.opendaylight.org/pipermail/netvirt-dev/2018-May/006878.html (rgoulding, 16:24:48)
    2. this has moved on on list discussions (rgoulding, 16:24:54)

  5. Request to split genius repo to enhance usability by other projects (rgoulding, 16:25:11)
    1. https://lists.opendaylight.org/pipermail/tsc/2018-May/009739.html (rgoulding, 16:25:29)
    2. this one is panning out on mailing lists (rgoulding, 16:25:38)

  6. Removal of some deprecated APIS in NETCONF (rgoulding, 16:25:58)
    1. netconf is using many deprecated yangtools, mdsal and controller APIs (rgoulding, 16:26:46)
    2. we need to adapt to new counterparts (rgoulding, 16:26:53)
    3. also, there are many places where NETCONF code exposes deprecated APIs, such as protocol-framework, that we should have a plan to remove such abstractions (rgoulding, 16:27:44)
    4. removal of the former (usage of deprecated APIs) is blocking upstreams from removing the APIs (rgoulding, 16:28:35)
    5. we want to garner support to help with removal of such concepts (rgoulding, 16:28:43)
    6. the question arrises, how do we get people to work on such things? (rgoulding, 16:29:07)
    7. rovarga suggests making a task list that we can prioritize (rgoulding, 16:29:43)
    8. one big thing is to get rid of the protocol-framework (rgoulding, 16:29:53)
    9. and migration to plain netty or mina (rgoulding, 16:30:03)
    10. ACTION: jmorvay to create JIRA tasks to showcase some of the places we can clean up (rgoulding, 16:31:18)

  7. DCL Removal Discussion (rgoulding, 16:36:55)
    1. there is one last patch to remove DCL (rgoulding, 16:37:10)
    2. https://lists.opendaylight.org/pipermail/release/2018-May/015217.html (rgoulding, 16:37:47)
    3. should we agree to merge this? (rgoulding, 16:37:53)
    4. AGREED: (rgoulding, 16:37:55)
    5. rovarga merged. (rgoulding, 16:38:00)
    6. https://git.opendaylight.org/gerrit/#/c/71801/ (rgoulding, 16:38:24)

  8. config subsystem removal (rgoulding, 16:38:34)
    1. tpantelis claims no upstream projects have used for a while (rgoulding, 16:38:44)
    2. downstreams should be migrated by now (we hope) (rgoulding, 16:38:55)
    3. archetype was changed a while ago to utilize blueprint (rgoulding, 16:39:07)
    4. ACTION: tpantelis to send out final removal notice for when it is timed (rgoulding, 16:39:19)
    5. tpantelis claims that he removed the CSS northbound loopback (rgoulding, 16:41:18)
    6. NetconfMonitoringActivator shouldn’t be there (rgoulding, 16:43:35)
    7. https://github.com/opendaylight/netconf/blob/master/netconf/netconf-monitoring/src/main/java/org/opendaylight/netconf/monitoring/osgi/NetconfMonitoringActivator.java (rgoulding, 16:43:37)
    8. so we should work to remove (rgoulding, 16:43:44)
    9. tpantelis already migrated XML stuff to NETCONF; it was only like 3 classes (rgoulding, 16:44:53)

  9. SUBMIT removal (rgoulding, 16:47:16)
    1. ACTION: AsyncWriteTransaction.submit() is only used in controller, so once we switch that we can remove it there (rgoulding, 16:48:13)

  10. removal of controller mdsal apis (rgoulding, 16:56:42)
    1. tpantelis is looking into a plan for removing these (rgoulding, 16:56:52)
    2. this could also solve CheckedFuture removal (rgoulding, 16:56:58)
    3. vorbuger brings up the point that a demo patch of this would help other projects adapt (rgoulding, 16:57:45)
    4. ACTION: tpantelis to look at what other API(s) include CheckedFuture in the signature (rgoulding, 16:59:35)
    5. this is made easier since only Controller is consuming many of these (rgoulding, 16:59:52)


Meeting ended at 17:01:22 UTC (full logs).

Action items

  1. jmorvay to create JIRA tasks to showcase some of the places we can clean up
  2. tpantelis to send out final removal notice for when it is timed
  3. AsyncWriteTransaction.submit() is only used in controller, so once we switch that we can remove it there
  4. tpantelis to look at what other API(s) include CheckedFuture in the signature


People present (lines said)

  1. rgoulding (84)
  2. odl_meetbot (4)
  3. skitt (1)


Generated by MeetBot 0.1.4.