#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:58:03 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:58:08)
    1. AAA AuthZ/AuthN + RESTCONF (rgoulding, 15:58:18)
    2. https://jira.opendaylight.org/browse/ODLPARENT-100 (rgoulding, 15:58:27)
    3. https://git.opendaylight.org/gerrit/#/c/73672/ (rgoulding, 15:58:39)
    4. Clustering CSIT (vpickard, 16:01:54)
    5. https://jira.opendaylight.org/browse/NETVIRT-1315 clustering CSIT (shague, 16:02:18)

  2. NETVIRT-1315 (rgoulding, 16:06:23)
    1. https://jira.opendaylight.org/browse/NETVIRT-1315 (rgoulding, 16:06:26)
    2. vpickard has created a google doc of the controller CSIT jobas (rgoulding, 16:07:52)
    3. vpickard is sharing the document, but we don’t have a public link at this point (rgoulding, 16:08:13)
    4. Oxygen/Ask based is what vpickard has focused on thus far (rgoulding, 16:08:45)
    5. He looked at several jobs, and most of the jobs pass consistently. There are some intermittent failures that occur, but they are generally pretty catostrophic failures (rgoulding, 16:09:25)
    6. tpantelis brought up that we really need to understand what these tests do (rgoulding, 16:09:59)
    7. tpantelis brings up that some of this has to deal with technology that is not fully baked (i.e., prefix-based sharding, etc.) (rgoulding, 16:10:20)
    8. jamoluhrsen asks what does “half baked” mean (rgoulding, 16:10:48)
    9. does that mean we shouldn’t care about the failures? (rgoulding, 16:10:55)
    10. for example, what does “chasing the leader” do? (rgoulding, 16:11:18)
    11. rovarga states that there is a test scenario document to go with these test suites (rgoulding, 16:11:31)
    12. int/test/docs/cluster/carbon/scerarios.rst (rovarga, 16:13:12)
    13. https://github.com/opendaylight/integration-test/blob/master/docs/cluster/carbon/scenarios.rst (rgoulding, 16:14:04)
    14. ACTION: vpickard to review the scenarios file, and figure out if the tests that are failing are ones we actually care about (rgoulding, 16:17:07)
    15. vpickard brings up he will need help on figuring out what ones we don’t actually care about (rgoulding, 16:17:23)
    16. rovarga brings up the fact that refactoring the test suite to focus on individual cases and scenarios might be a good idea, but the original design was to keep it all in an “uber test suite” (rgoulding, 16:19:20)

  3. CONTROLLER-1845 (rgoulding, 16:20:17)
    1. controller takes 7 minutes to start (rgoulding, 16:20:23)
    2. vpickard asks how to debug karaf hanging on startup (rgoulding, 16:23:23)
    3. tpantelis brings up the fact that running jstack and grabbing a thread dump would be helpful (rgoulding, 16:23:56)
    4. vorburger brings up that before we focus on how to reproduce this first, perhpas locally (rgoulding, 16:25:39)
    5. tpantelis says “kill -3 <pid>” will dump to the stdout location (rgoulding, 16:26:26)

  4. CONTROLLER-1848 (rgoulding, 16:27:54)
    1. leader cannot perform its duties (rgoulding, 16:28:54)
    2. tpantelis says that this is expected in this scenario (rgoulding, 16:29:18)

  5. OPNFLWPLUG-1022 (rgoulding, 16:30:41)
    1. exception during ODL startup in cluster (rgoulding, 16:30:49)
    2. OptimisticLockFailedException is failure in application code usually (rgoulding, 16:31:29)
    3. they are taking offline (rgoulding, 16:31:32)
    4. incompatibility between restconf-noauth and restconf (rgoulding, 16:31:52)
    5. the two features are incompatible (rgoulding, 16:32:21)

  6. AAA authorization/authentication + RESTCONF (rgoulding, 16:33:07)
    1. is eventually consistent data fine? (rgoulding, 16:34:46)
    2. https://git.opendaylight.org/gerrit/73475 (rovarga, 16:35:37)
    3. https://git.opendaylight.org/gerrit/73455 (rovarga, 16:35:43)
    4. ACTION: rgoulding to update documentation on eventual consistency (rgoulding, 16:40:31)
    5. everyone agrees that this tradeoff is fine (rgoulding, 16:41:01)

  7. ODLPARENT-100 (rgoulding, 16:43:14)
    1. include error-prone as an opt-in (or opt-out?) feature (rgoulding, 16:43:30)
    2. rovarga asks how complete the code is for this (rgoulding, 16:43:54)
    3. vorburger says they are running with this, and it is more than a prototype (rgoulding, 16:44:11)
    4. vorburger brings up that this might be a good thing to upstream to odlparent (rgoulding, 16:44:25)
    5. https://github.com/opendaylight/infrautils/blob/master/common/parent/pom.xml#L121 (rgoulding, 16:46:13)
    6. extension of this must be made possible since some projects may not care about some rules (rgoulding, 16:48:03)

  8. Bump maven-blueprint-plugin to 1.10.0 (rgoulding, 16:49:35)
    1. https://git.opendaylight.org/gerrit/#/c/73672/ (rgoulding, 16:49:38)
    2. this is used extensively in netvirt / genius (rgoulding, 16:50:46)
    3. it allows annotation based dependency injection (rgoulding, 16:50:54)
    4. ACTION: vorburger will comment to bundle that utilizes this (rgoulding, 16:51:08)
    5. there were issues when we tried to upgrade to 1.5 in the past (rgoulding, 16:51:23)
    6. https://wiki.opendaylight.org/view/BestPractices/DI_Guidelines#NEW:_.40OsgiService_.26_.40OsgiServiceProvider_.28pax-cdi-api.29 (rgoulding, 16:52:01)
    7. may be dated 1.5 years old (rgoulding, 16:52:08)
    8. https://jira.opendaylight.org/browse/TSC-124 (rovarga, 16:53:35)

  9. RFC8345 defines ietf-network(-topology), which we should adopt (rgoulding, 16:53:50)
    1. https://jira.opendaylight.org/browse/TSC-124 (rgoulding, 16:53:57)
    2. https://jira.opendaylight.org/browse/TSC-125 (rgoulding, 16:54:01)
    3. ^^ companion link (rgoulding, 16:54:11)
    4. do we ever want to move away from draft models or not? (rgoulding, 16:54:57)
    5. https://git.opendaylight.org/gerrit/#/c/73661/10/netconf/netconf-console/src/test/resources/schemas/ietf-network%25402018-02-26.yang (rgoulding, 16:55:08)
    6. vishnoianil asks if there is any significant reason to upgrade on the NB side (rgoulding, 16:57:59)
    7. rovarga says that the upside is getting rid of deprecated models/ warnings (rgoulding, 17:00:56)
    8. anytime you touch a class marked as deprecated then you will get a deprecation warning (rgoulding, 17:01:25)


Meeting ended at 17:10:37 UTC (full logs).

Action items

  1. vpickard to review the scenarios file, and figure out if the tests that are failing are ones we actually care about
  2. rgoulding to update documentation on eventual consistency
  3. vorburger will comment to bundle that utilizes this


Action items, by person

  1. rgoulding
    1. rgoulding to update documentation on eventual consistency
  2. vorburger
    1. vorburger will comment to bundle that utilizes this
  3. vpickard
    1. vpickard to review the scenarios file, and figure out if the tests that are failing are ones we actually care about


People present (lines said)

  1. rgoulding (67)
  2. rovarga (4)
  3. odl_meetbot (3)
  4. jamoluhrsen (3)
  5. vpickard (1)
  6. vorburger (1)
  7. shague (1)


Generated by MeetBot 0.1.4.