#opendaylight-meeting: kernel projects

Meeting started by rgoulding at 15:57:20 UTC (full logs).

Meeting summary

  1. agenda bashing (rgoulding, 15:57:24)
    1. OpenEXI vs EXIficient interoperability issue (rgoulding, 15:57:32)
    2. MD-SAL near-term future (rgoulding, 15:57:49)
    3. Neon MRI Integration Window (rgoulding, 15:57:56)

  2. OpenEXI vs EXIficient interoperability issue (rgoulding, 16:06:18)
    1. https://lists.opendaylight.org/pipermail/netconf-dev/2018-August/001912.html (rgoulding, 16:06:47)
    2. there is an interoperability issue between the two (rgoulding, 16:06:58)
    3. fluroine ODL won’t work with oxygen TT and vice versa (rgoulding, 16:07:11)
    4. fluorine ODL with fluorine test tool should work fine (rgoulding, 16:07:23)
    5. jmorvay has made change in fluroine CSIT to utilize fluroine test tool (rgoulding, 16:07:39)
    6. jmorvay was able to successfully mount the test tool and two other devices (rgoulding, 16:07:50)
    7. manually ^^ (rgoulding, 16:07:55)
    8. honeycomb uses ODL netconf northbound based on Oxygen, and this won’t work with Fluorine (rgoulding, 16:09:04)
    9. OpenEXI hosted at sourceforge (rgoulding, 16:09:35)
    10. releases not maintained, mailing lists not monitored (rgoulding, 16:10:05)
    11. Exificient is still maintained (rgoulding, 16:10:42)
    12. or tern off exi on honeycomb server (rgoulding, 16:12:25)
    13. ACTION: jmorvay to release note this limitation (rgoulding, 16:13:11)

  3. clustering update (rgoulding, 16:16:24)
    1. no specific updates (rgoulding, 16:16:40)

  4. MD-SAL near-term future (rgoulding, 16:17:04)
    1. Fluroine branching strategy (rgoulding, 16:17:10)
    2. neon work items (rgoulding, 16:17:13)
    3. https://lists.opendaylight.org/pipermail/mdsal-dev/2018-August/001811.html (rovarga_, 16:17:37)
    4. rovarga pushing for some hard dates for start of Neon (rgoulding, 16:18:36)
    5. we are 4 weeks away from it as perceived by TSC (rgoulding, 16:18:48)
    6. but MD-SAL is transitioning to MRI (rgoulding, 16:18:57)
    7. so MD-SAL to start Neon as soon as Fluorine is branched (rgoulding, 16:19:31)
    8. the details of this conversation are derived form the above email ^^ (rgoulding, 16:22:32)
    9. shague says the intention is to use the same model as fluorine for release of neon (rgoulding, 16:24:08)
    10. there are some assumptions but we do need to do proper release planning (rgoulding, 16:24:24)
    11. the implication is 3/7 and 9/7, but there is question as to whether this is documented (rgoulding, 16:24:57)
    12. deadlines for participating in certain release tracks needs better documentation (rgoulding, 16:25:48)
    13. Quote from Jamo: “n an attempt to synchronize with other related open source projects (e.g., OPNFV and OpenStack), OpenDaylight releases twice per year on a 6 month cadence. These releases are scheduled for September 7th and March 7th. These release dates are also used as the beginning for the subsequent release.” (rgoulding, 16:26:43)
    14. https://docs.opendaylight.org/en/latest/release-process/release-schedule.html?highlight=release%20schedule (rgoulding, 16:26:54)
    15. MRI integration window is also a question (rgoulding, 16:30:02)
    16. according to the existing docs, we could deduce 10/7? (rgoulding, 16:30:38)
    17. this needs to be spelled out better (rgoulding, 16:30:44)
    18. karaf 4.2 doesnt break yangtools/mdsal, but may break aaa/netconf etc. (rgoulding, 16:32:01)
    19. powermock upgrade may break some downstreams (rgoulding, 16:32:20)
    20. integration of yangtools will yield elimination of empty lists from the data store (rgoulding, 16:33:19)
    21. similar to containers (rgoulding, 16:33:33)
    22. shague asks if the powermock stuff we won’t know until we drop in, right? (rgoulding, 16:34:21)
    23. appears to be the case (rgoulding, 16:35:30)
    24. vorburger asks whether we can just use powermock 1 in certain projects (rgoulding, 16:35:52)
    25. then maintenance is owned by the downstream consumer (rgoulding, 16:36:46)
    26. it is driven by the project, you can overwrite the version (rgoulding, 16:37:12)
    27. https://git.opendaylight.org/gerrit/#/q/topic:neon-mri+(status:open+OR+status:merged) (rovarga_, 16:38:00)
    28. MRI integration multipatch topic (rovarga_, 16:38:07)
    29. https://jira.opendaylight.org/browse/TSC-132 (rovarga_, 16:38:29)


Meeting ended at 16:39:57 UTC (full logs).

Action items

  1. jmorvay to release note this limitation


People present (lines said)

  1. rgoulding (49)
  2. rovarga_ (4)
  3. odl_meetbot (3)
  4. vorburger (1)


Generated by MeetBot 0.1.4.