#opendaylight-meeting: kernel-projects

Meeting started by vorburger at 17:03:22 UTC (full logs).

Meeting summary

  1. Who's here (vorburger, 17:03:30)
    1. vorburger skitt TomP jmorvay (vorburger, 17:03:50)

  2. Gerrits waiting for review (vorburger, 17:04:00)
    1. https://git.opendaylight.org/gerrit/#/c/78433/ (vorburger, 17:04:33)
    2. skitt says you had actually reviewed it, so we merged it now (vorburger, 17:05:38)
    3. https://git.opendaylight.org/gerrit/#/c/78507/ (vorburger, 17:05:55)
    4. skitt has +1 this ^^ one, we'll wait for rovarga to review it in January (vorburger, 17:08:00)
    5. https://git.opendaylight.org/gerrit/#/c/78805/ (vorburger, 17:08:03)
    6. TomP gave an explanation about c/78805 and skitt reviewed it on the fly and merged! (vorburger, 17:10:38)

  3. oldparent bump (vorburger, 17:11:00)
    1. release either this week or in January (vorburger, 17:11:23)
    2. skitt looking at including something that prints the release name in the console branding and start up logs (vorburger, 17:12:51)
    3. waiting for Karaf 4.2.2 release which is about to drop (vorburger, 17:13:21)
    4. enable dependency convergence enforcement in autorelease (vorburger, 17:14:43)
    5. This will let us more quickly discover patches who have previous ODL versions that got merged after version bumps (vorburger, 17:15:16)
    6. the actual merge of the bump patches across projects would happen in January (but the odlparent 4.0.3 release could still happen this week) (vorburger, 17:16:17)
    7. This would be likely be the last odlparent for Neon, and open the door for starting to open odlparent 5.x for breaking changes, targeting Sodium (?) (vorburger, 17:17:28)

  4. DataBroker controller vs mdsal API (vorburger, 17:18:42)
    1. skitt has an open patch to switch all of ovsdb over (vorburger, 17:18:54)
    2. ovsdb patch: https://git.opendaylight.org/gerrit/78432 (skitt, 17:19:23)
    3. https://github.com/opendaylight/controller/blob/master/opendaylight/md-sal/sal-dom-compat/src/main/java/org/opendaylight/controller/sal/core/compat/DOMDataBrokerAdapter.java (vorburger, 17:26:45)
    4. ACTION: vorburger to use this ^^^ to get opendaylight-simple to build again (vorburger, 17:27:06)
    5. we're discussion @Deprecated of controller API (vorburger, 17:28:21)
    6. we don't need to @Deprecate every single class, just the entry point Services (vorburger, 17:29:05)
    7. DataBroker already is, not clear if anything (vorburger, 17:29:24)
    8. ACTION: TomP will have a closer look if anything still needs to have a @Deprecated slapped on it for Neon (vorburger, 17:29:43)

  5. ODL Container? (vorburger, 17:33:49)
    1. https://github.com/opendaylight/integration-packaging/tree/master/docker (vorburger, 17:33:57)


Meeting ended at 17:37:02 UTC (full logs).

Action items

  1. vorburger to use this ^^^ to get opendaylight-simple to build again
  2. TomP will have a closer look if anything still needs to have a @Deprecated slapped on it for Neon


Action items, by person

  1. vorburger
    1. vorburger to use this ^^^ to get opendaylight-simple to build again


People present (lines said)

  1. vorburger (29)
  2. odl_meetbot (3)
  3. skitt (1)


Generated by MeetBot 0.1.4.