#opendaylight-meeting: tsc

Meeting started by skitt at 18:00:31 UTC (full logs).

Meeting summary

  1. Roll-call and agenda bashing (skitt, 18:00:37)
    1. TSC members please info in (skitt, 18:00:42)
    2. Brady Johnson (bjohnson, 18:01:43)
    3. skitt (skitt, 18:02:38)
    4. anipbu (anipbu, 18:02:41)
    5. jamoluhrsen (jamoluhrsen, 18:02:42)
    6. Thanh Ha (zxiiro, 18:02:43)
    7. rovarga_ (rovarga_, 18:02:45)
    8. klou (proxy for George Zhao) (klou, 18:02:58)
    9. LuisGomez (LuisGomez, 18:03:17)
    10. LuisGomez proxy for anil vishnoi (LuisGomez, 18:03:24)
    11. lori (lori, 18:03:50)
    12. shague (shague, 18:04:33)
    13. ACTION: abhijitkumbhare to start an email thread providing a proposal for proxy/delegate & request other TSC members to feedback (skitt, 18:05:13)
    14. ACTION: abhijitkumbhare to initiate an email thread regarding the Singularity Principle (skitt, 18:05:19)
    15. ACTION: CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst (skitt, 18:05:26)
    16. ACTION: TSC to check the LFN Webinar and bring out a proposal to decide the TAC representative (skitt, 18:05:49)
    17. ACTION: CaseyODL to respond to the DDF discussion on the mailing list (skitt, 18:06:37)
    18. ACTION: rovarga to revive stalled discussions on TrieMap after he is back from the vacation (skitt, 18:07:40)
    19. last week’s minutes https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-01-04-18.02.html (skitt, 18:07:49)

  2. Mailing list discussions (skitt, 18:09:37)
    1. re Groups.io, auto-hashing will be added soon (skitt, 18:09:47)
    2. https://www.irccloud.com/pastebin/kodDtSg2/ (CaseyODL, 18:10:06)
    3. what rejections look like if tags are enforced: https://www.irccloud.com/pastebin/kodDtSg2/ (skitt, 18:10:23)
    4. the other Groups.io questions are still pending (skitt, 18:10:58)
    5. re the DDF, if we have the DDF on Monday or Tuesday, there will be scheduling conflicts (skitt, 18:12:01)
    6. if the DDF is on the Sunday, many people will have to travel on the previous Friday (skitt, 18:12:15)
    7. One unanswered question from Fd.io I'll ado to CaseyODL's list: "What's their business model? Are we now going to be the product?" (dfarrell07, 18:12:45)
    8. only event on Sunday is OPNFV XCI (skitt, 18:14:23)
    9. Monday/Tuesday are dedicated to cross-project collaboration (skitt, 18:14:33)
    10. the CFP is ongoing so no schedule information yet (skitt, 18:14:41)
    11. https://events.linuxfoundation.org/events/open-networking-summit-north-america-2018/program/cfp/ ONS CFP info and scheduling (bjohnson, 18:15:29)
    12. CFP Closes: Sunday, January 14, 2018 (bjohnson, 18:15:40)
    13. CFP Notifications: Tuesday, February 6, 2018 (bjohnson, 18:15:51)
    14. Schedule Announcement: Thursday, February 8, 2018 (bjohnson, 18:16:00)
    15. bjohnson suggests putting an option on a room for Sunday through Tuesday and cancelling when we know (skitt, 18:17:38)
    16. rovarga_ points out we should really discuss what we want from the DDF (skitt, 18:18:12)
    17. if cross-project collaboration is to be successful the DDF needs to take that into account (skitt, 18:18:43)

  3. Oxygen (skitt, 18:26:03)
    1. still chasing M2/M3 status (skitt, 18:26:24)
    2. four projects still need to provide M2 (skitt, 18:26:33)
    3. 17 for M3 (skitt, 18:26:56)
    4. offset 0 is in M4 now (skitt, 18:27:03)
    5. klou sent reminders for M2 this morning (dlux, dluxapps, p4plugin, faas) (skitt, 18:27:25)
    6. dlux and dluxapps no longer have a PTL effectively (skitt, 18:29:38)
    7. TSC might need to step in and ask for contributors from consuming projects (skitt, 18:30:12)
    8. or investigate removing dlux/dluxapps (skitt, 18:30:21)
    9. perhaps we should introduce a maintenance mode (skitt, 18:30:28)
    10. to be defined (skitt, 18:30:54)
    11. having such projects creates problems for us wrt security etc. (skitt, 18:31:50)
    12. need to encourage mobility from downstreams to upstreams (skitt, 18:33:43)
    13. e.g. if a project uses dlux, encourage its contributors to contribute to dlux (skitt, 18:33:56)
    14. need to communicate upstream situation to downstreams (skitt, 18:35:07)
    15. downstreams are liable to lose features if their upstreams disappear (skitt, 18:35:51)
    16. which is a strong incentive to find a solution (skitt, 18:35:57)
    17. we should reach out to dlux and dluxapps to see what the situation is (skitt, 18:37:55)
    18. in a similar fashion to netconf recently (skitt, 18:38:20)
    19. ACTION: bjohnson to reach out to Maxime re. dlux and dluxapps and his involvement (skitt, 18:39:09)
    20. ACTION: rovarga_ to reach out to Daniel Malachovsky (skitt, 18:40:43)
    21. dlux and dluxapps are actively looking for contributors, so we should encourage people to step up (skitt, 18:41:54)
    22. odlparent 3 / yangtools 2 status: https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018 (skitt, 18:42:40)
    23. depending on the response from Maxime and Daniel, we will reach out to the projects asking someone else to step up and become PTL (bjohnson, 18:43:02)
    24. int/dist patch: https://git.opendaylight.org/gerrit/67013 (skitt, 18:43:11)
    25. projects will all be broken, even for plain builds, until their upstreams have merged (skitt, 18:50:17)
    26. because yangtools 2 is a breaking upgrade (skitt, 18:50:23)
    27. once we start merging, we can fall back by reverting (skitt, 18:55:46)
    28. we need to timebox the change to avoid massive disruption in projects trying to meet the code freeze (skitt, 18:56:11)
    29. few projects are actively racing to meet the code freeze (skitt, 18:57:36)
    30. genius and netvirt in particular, sfc too (skitt, 18:57:42)
    31. VOTE: Voted on "Does the TSC approve starting merges for odlparent 3 / yangtools 2 *right now*, and seeing where things stand on Monday?" Results are, +1: 10 (skitt, 19:06:37)

  4. Cookies (skitt, 19:07:35)


Meeting ended at 19:07:40 UTC (full logs).

Action items

  1. abhijitkumbhare to start an email thread providing a proposal for proxy/delegate & request other TSC members to feedback
  2. abhijitkumbhare to initiate an email thread regarding the Singularity Principle
  3. CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
  4. TSC to check the LFN Webinar and bring out a proposal to decide the TAC representative
  5. CaseyODL to respond to the DDF discussion on the mailing list
  6. rovarga to revive stalled discussions on TrieMap after he is back from the vacation
  7. bjohnson to reach out to Maxime re. dlux and dluxapps and his involvement
  8. rovarga_ to reach out to Daniel Malachovsky


Action items, by person

  1. bjohnson
    1. bjohnson to reach out to Maxime re. dlux and dluxapps and his involvement
  2. CaseyODL
    1. CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
    2. CaseyODL to respond to the DDF discussion on the mailing list
  3. rovarga_
    1. rovarga_ to reach out to Daniel Malachovsky
  4. UNASSIGNED
    1. abhijitkumbhare to start an email thread providing a proposal for proxy/delegate & request other TSC members to feedback
    2. abhijitkumbhare to initiate an email thread regarding the Singularity Principle
    3. TSC to check the LFN Webinar and bring out a proposal to decide the TAC representative
    4. rovarga to revive stalled discussions on TrieMap after he is back from the vacation


People present (lines said)

  1. skitt (66)
  2. odl_meetbot (11)
  3. bjohnson (8)
  4. dfarrell07 (8)
  5. rovarga_ (6)
  6. klou (3)
  7. zxiiro (3)
  8. LuisGomez (3)
  9. jamoluhrsen (3)
  10. shague (2)
  11. lori (2)
  12. anipbu (2)
  13. CaseyODL (1)


Generated by MeetBot 0.1.4.