#opendaylight-meeting: tsc

Meeting started by CaseyODL at 18:00:40 UTC (full logs).

Meeting summary

  1. Roll-call and agenda bashing (skitt, 18:00:59)
    1. Brady Johnson (bjohnson, 18:01:00)
    2. TSC members please info in (skitt, 18:01:06)
    3. abhijitkumbhare (abhijitkumbhare, 18:01:07)
    4. skitt (skitt, 18:01:07)
    5. gzhao (gzhao, 18:01:16)
    6. anipbu (anipbu, 18:01:25)
    7. jamoluhrsen (jamoluhrsen, 18:01:27)
    8. LuisGomez (LuisGomez, 18:04:44)
    9. Welcome Quan to the TSC meeting (abhijitkumbhare, 18:04:52)
    10. Thanh (zxiiro, 18:05:12)

  2. Agenda (abhijitkumbhare, 18:05:47)
    1. https://wiki.opendaylight.org/view/TSC:Main#Agenda (abhijitkumbhare, 18:05:49)
    2. bjohnson suggests we discuss the code freeze deadline (abhijitkumbhare, 18:07:03)
    3. ACTION: abhijitkumbhare to initiate an email thread regarding the Singularity Principle (abhijitkumbhare, 18:07:46)
    4. ACTION: CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst (abhijitkumbhare, 18:08:08)
    5. ACTION: rovarga to revive stalled discussions on TrieMap after he is back from the vacation (abhijitkumbhare, 18:08:23)
    6. shague (shague, 18:10:33)
    7. rovarga (rovarga, 18:10:46)

  3. TAC representative (skitt, 18:11:27)
    1. Options: (abhijitkumbhare, 18:14:37)
    2. Option 1: The TSC Chair by default becomes the TAC representative (abhijitkumbhare, 18:14:47)
    3. Option 2: Another member of the TSC is elected by the TSC (abhijitkumbhare, 18:14:57)
    4. Option 3: Any interested committer approved by the TSC and elected by the TSC (abhijitkumbhare, 18:15:10)
    5. Option 4: further discussion (skitt, 18:16:05)
    6. VOTE: Voted on "Which option does the TSC prefer?" Results are, 3: 8, 2: 2 (skitt, 18:18:37)
    7. AGREED: The TAC representative shall be any interested committer approved by the TSC and elected by the TSC (skitt, 18:19:02)
    8. AGREED: One week self nomination period, followed by one week voting period (abhijitkumbhare, 18:21:52)

  4. Proposal for Releng Team to perform all version bumping activities (skitt, 18:22:13)
    1. Most active projects have bumped to yangtools 2.0.0, LuisGomez has sent out projects that haven't (dfarrell07, 18:24:15)
    2. There is a fix in 2.0.1 yangtools that has critical fixes (dfarrell07, 18:24:30)
    3. LuisGomez is proposing LF do a version bump for projects already on 2.0.0 to 2.0.1 (dfarrell07, 18:24:48)
    4. LuisGomez is not proposing LF bump projects to 2.0.0 if they haven't already (dfarrell07, 18:25:11)
    5. skitt and zxiiro talk about how we have agreed this for minor bumps in the past, and projects can opt out (dfarrell07, 18:25:32)
    6. there may be complex fixes required for going to 2.0.0, so projects would need to do that themselves LuisGomez says (dfarrell07, 18:26:15)
    7. two questions from rovarga (skitt, 18:26:20)
    8. how can the patches be validated before the releng team merges them (skitt, 18:26:33)
    9. what are the gating criteria before a patch is merged (skitt, 18:27:48)
    10. LuisGomez is assuming that minor version bumps will not break projects, so minor version bumps should be okay whereas major version bumps would not be okay (dfarrell07, 18:28:48)
    11. dfarrell07 clarifies that TSC has authority to do this, it's not the case that the governance docs say they can't (dfarrell07, 18:29:49)
    12. LuisGomez and others don't think it's okay to wait on approval for all projects for all version bumps from odlparent and yangtoos to unbreak the world (dfarrell07, 18:33:17)
    13. shague says the world is broken now, so these patches need to get merged one way or another, project committer or someone else (dfarrell07, 18:34:46)
    14. all agree that going forward long term, gov docs need to change to make this situation more clear, deal with inactive projects not holding everyone else up (dfarrell07, 18:35:39)
    15. last time this was voted on it was about projects taking part in the SR bumping versions to release, this is different situation says rovarga (dfarrell07, 18:36:54)
    16. https://www.irccloud.com/pastebin/4JfPKsEt/ (CaseyODL, 18:39:49)
    17. VOTE: Voted on "Does the TSC approve that the releng team can merge patches for the merge from yangtools 2.0.0 to yangtools 2.0.1, as long as they pass the verify job?" Results are, 0: 3, +1: 7 (skitt, 18:40:26)
    18. for the record, Quan voted +1 (skitt, 18:40:58)

  5. Groups.io (skitt, 18:42:44)
  6. Oxygen (skitt, 18:43:28)
    1. bjohnson and others are proposing an extension of code freeze to let offset two projects get changes in, since things have been very broken for quite some time (infra, version bumps) (dfarrell07, 18:48:01)
    2. note: we actually held off the integration to get CSIT environment stabilized (rovarga, 18:48:41)
    3. shague thinks we will not be in good shape by the first RC date, rovarga thinks we should not have that RC if it is expected to be broken (dfarrell07, 18:49:28)
    4. dfarrell07 hopes we will not have to slip release date (dfarrell07, 18:50:27)
    5. jamoluhrsen doesn't want us to steal test time at the end of all of this (dfarrell07, 18:50:39)
    6. VOTE: Voted on "Shall the TSC slip the code freeze and RC0 by one week?" Results are, +1: 1 (skitt, 18:52:56)
    7. Option 1: stick to the current release plan (skitt, 18:53:05)
    8. Option 2: slip code freeze and RC0 by one week (skitt, 18:53:14)
    9. Option 3: slip the rest of the release plan by one week (skitt, 18:53:25)
    10. Option 0: abstain (skitt, 18:53:30)
    11. VOTE: Voted on "Shall the TSC amend the planned dates on the release plan?" Results are, 0: 1, 3: 9, 2: 2 (skitt, 18:56:39)
    12. AGREED: the TSC slips the rest of the release plan by one week (skitt, 18:56:59)

  7. Carbon (skitt, 18:57:15)
    1. klou has an RC out for Carbon SR3 (dfarrell07, 18:57:51)
    2. jamoluhrsen has run CSIT against that Carbon SR3, results are in and klou is updating spreadsheet (dfarrell07, 18:58:13)
    3. jamoluhrsen wants us to vote now to release this RC as carbon SR3 if it passes netvirt tests, others seem sane (dfarrell07, 18:58:37)
    4. VOTE: Voted on "Shall the TSC approve the latest Carbon release candidate as SR3 if it passes netvirt tests?" Results are, +1: 11 (skitt, 18:59:39)

  8. ONS Developer Event (abhijitkumbhare, 19:00:11)
    1. LFN wiki to be live soon (abhijitkumbhare, 19:00:32)
    2. ODL DDF has to be on Sunday (abhijitkumbhare, 19:00:49)
    3. AGREED: ODL DDF will be on Sunday March 25, 2018 (abhijitkumbhare, 19:04:10)

  9. Groups.io (abhijitkumbhare, 19:05:13)
    1. ACTION: CaseyODL to send an email about Groups.io update (abhijitkumbhare, 19:05:32)
    2. Any feedback to be provided over the email thread (abhijitkumbhare, 19:06:02)

  10. Cookies or Beer (abhijitkumbhare, 19:06:24)
    1. As usual (abhijitkumbhare, 19:06:51)


Meeting ended at 19:06:56 UTC (full logs).

Action items

  1. abhijitkumbhare to initiate an email thread regarding the Singularity Principle
  2. CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
  3. rovarga to revive stalled discussions on TrieMap after he is back from the vacation
  4. CaseyODL to send an email about Groups.io update


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to initiate an email thread regarding the Singularity Principle
  2. CaseyODL
    1. CaseyODL to go write a straw-man/skeleton "How to get help" docs page in docs repo via Gerrit/Rst
    2. CaseyODL to send an email about Groups.io update
  3. rovarga
    1. rovarga to revive stalled discussions on TrieMap after he is back from the vacation


People present (lines said)

  1. skitt (45)
  2. abhijitkumbhare (42)
  3. odl_meetbot (37)
  4. dfarrell07 (36)
  5. rovarga (18)
  6. jamoluhrsen (10)
  7. shague (8)
  8. Quan (8)
  9. bjohnson (7)
  10. CaseyODL (7)
  11. zxiiro (5)
  12. LuisGomez (5)
  13. lori (5)
  14. anipbu (5)
  15. gzhao (3)
  16. klou (1)


Generated by MeetBot 0.1.4.