#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 18:02:20 UTC (full logs).

Meeting summary

  1. rollcall (dfarrell07, 18:02:46)
    1. dfarrell07 for shague (dfarrell07, 18:02:52)
    2. LuisGomez (LuisGomez, 18:03:03)
    3. skitt (skitt, 18:03:03)
    4. lori (lori, 18:03:10)
    5. anipbu (anipbu, 18:03:10)
    6. Thanh Ha (zxiiro, 18:03:17)
    7. abhijitkumbhare (abhijitkumbhare, 18:03:27)
    8. https://wiki.opendaylight.org/view/TSC:Main#Agenda (abhijitkumbhare, 18:03:54)
    9. jamoluhrsen (jamoluhrsen, 18:04:11)
    10. Brady Johnson (bjohnson, 18:04:15)

  2. oxygen (dfarrell07, 18:05:28)
    1. meeting is in https://zoom.us/j/441948593 (dfarrell07, 18:06:25)
    2. gzhao (gzhao, 18:06:48)
    3. https://wiki.opendaylight.org/view/Release_Dashboard (klou_, 18:07:25)
    4. m2 and m3 status missing for some projects, klou_ is tracking on link above (dfarrell07, 18:07:28)
    5. m2 dlux and dluxapps, m3 dlux, dluxapps intdist, jsonrpc, mdsal, nic, snmp, unimanager (dfarrell07, 18:08:01)
    6. Im still waiting to hear back from the DLUX PTL (bjohnson, 18:08:07)
    7. we had a deadline last week that we are now past (dfarrell07, 18:08:28)
    8. oxygen release bockers are tagged as such on Jira, there are 5 currently (dfarrell07, 18:08:53)
    9. https://jira.opendaylight.org/issues/?filter=10206 <- Current Oxygen Blockers (klou_, 18:09:33)
    10. netconf 502 is related to bump, same thing aaa was hitting, rgoulding has a fix being tested now (dfarrell07, 18:10:24)
    11. Not all bugs related to the version bump. e.g. MDSAL-228 (abhijitkumbhare, 18:12:31)
    12. there are some bugs that seem to be related to tests, that are very important because we can't get good test coverage, but may not be problems with oxygen (dfarrell07, 18:13:58)
    13. there are others listed as blockers on that filter that maybe should not be, like mdsal228 according to vorburger et al (dfarrell07, 18:14:19)
    14. vorburger says genius109 is a test failure, not a runtime problem, so critical but likely not a blocker (dfarrell07, 18:15:10)
    15. all bug owners should update bugs and maybe remove blocker label (dfarrell07, 18:15:24)
    16. the only version bump blockers are netconf 502 and netconf 504 (bjohnson, 18:16:18)
    17. netvirt 1058 is a blocker but is not related to the bump (dfarrell07, 18:16:22)
    18. so summary is that netconf 502, 504 and netvirt 1058 are actually blockers (dfarrell07, 18:17:31)
    19. looks like we're in good shape for the version bump (bjohnson, 18:19:44)
    20. netvirt and other projects have a large stack of patches they have been holding while csit broken, they are now starting to merge those as csit is good (dfarrell07, 18:20:05)
    21. will continue holding code freeze and branch cutting until that mountain goes through (dfarrell07, 18:20:26)
    22. Code freeze stands 1/28 - but we will monitor (abhijitkumbhare, 18:21:47)
    23. code freeze is still 1/28, but we will be open if patch queues that were held up can't make it (dfarrell07, 18:22:03)

  3. ddf (dfarrell07, 18:22:07)
    1. phrobb gives some background on ddf, lots of projects want to have DDF-like events, which LF hadn't planned for (dfarrell07, 18:23:46)
    2. main issues are that we don't have enough time for DDF and cost is very high (dfarrell07, 18:24:31)
    3. phrobb mentions a discount for contributors but I didn't understand how much (dfarrell07, 18:24:50)
    4. Anil Vishnoi (vishnoianil, 18:25:07)
    5. 50% discount (skitt, 18:25:23)
    6. many groups were asking for time on sunday, which would be a major cost for LF, not in budget (dfarrell07, 18:26:39)
    7. ODL has been clear about wanting a DDF at ONS for very long time (dfarrell07, 18:26:51)
    8. Early bird registration price of $1195 is available until February 11 (bjohnson, 18:27:16)
    9. contributors (broad definition) get a 50% discount on early bird price, covers all of ONS, cost required for attending DDF/cross-project part before ONS-proper (dfarrell07, 18:28:33)
    10. LF is trying to break even (dfarrell07, 18:29:15)
    11. we have a room on Sunday for 30 folks for ODL DDF, in addition to parts of Mon/Tues we want to use for DDF (dfarrell07, 18:30:02)
    12. still not sure if speakers to mon/tues get speaker pass for all of ONS (dfarrell07, 18:31:18)
    13. xci event will still happen on sunday, room for 15 people (dfarrell07, 18:32:10)
    14. we will have DDF all day Sunday, and will extend to mon/tues (dfarrell07, 18:33:24)
    15. if there are folks that still can't pay $600 reach out to phrobb (dfarrell07, 18:33:38)
    16. phil encourages folks who attend DDF on Sunday to also attend everything else, for health of project and cost breaking even (dfarrell07, 18:34:14)
    17. dfarrell07 strongly suspect we will have dev things we want to do on mon/tues, so just attending sun doesn't make sense (dfarrell07, 18:34:59)
    18. xci talks will likely extend to mon/tues (dfarrell07, 18:35:28)
    19. phil thinks it's important to have this cross project part on mon/tues, that we should all stick around and take part (dfarrell07, 18:36:07)
    20. phil will be disappointed in you if you only come for Sunday *father figure shame* ;) (dfarrell07, 18:37:18)
    21. phil has a link with docs about how to get this %50 discount prices (dfarrell07, 18:38:00)
    22. phil will also follow up with LFN wiki where can post topics (dfarrell07, 18:38:11)
    23. if you don't want to come for Mon/Tues, tell Phil because he wants to work with you to make it happen (dfarrell07, 18:39:36)
    24. vishnoianil asks about when CFP results for main OSN will come out, it is before the early bird expires (dfarrell07, 18:40:50)
    25. if you register for early bird and then get accepted as speaker, you will get refunded (dfarrell07, 18:41:45)
    26. if you want to do an ODL demo, don't worry about the deadline, reach out to lisa and phil and they will make it happen (dfarrell07, 18:44:13)
    27. ACTION: CaseyODL to broadcast the option for doing an ODL demo to ODL lists (dfarrell07, 18:45:27)
    28. community seems happy with result of DDF discussion, thanks phrobb for clarifying and finding a good solution for us (dfarrell07, 18:46:40)

  4. Carbon (abhijitkumbhare, 18:50:38)
    1. https://jira.opendaylight.org/issues/?filter=10207 <- Carbon SR3 Bugs (klou_, 18:50:56)
    2. https://jira.opendaylight.org/browse/NETCONF-503 & https://jira.opendaylight.org/browse/NETVIRT-896 are blocking OPNFV (abhijitkumbhare, 18:52:07)
    3. ACTION: jamoluhrsen to ask OPNFV why https://jira.opendaylight.org/browse/NETVIRT-896 is a blocker on the JIRA (abhijitkumbhare, 18:54:17)
    4. jamoluhrsen notes that NetVirt still has other blocking issues for Carbon (abhijitkumbhare, 18:54:51)
    5. it's unclear if netconf 503 and netvirt 896 are actually blockers, they seem to have been over-aggressively bumped to blockers (dfarrell07, 18:55:13)
    6. dfarrell07 is pushing to get more details on netconf503 and jamoluhrsen is doing same for netcirt896 (dfarrell07, 18:55:28)
    7. netvirt 1022 does track actual blockers, jamoluhrsen, sam are looking (dfarrell07, 18:56:07)

  5. Nitrogen (abhijitkumbhare, 18:56:08)
    1. Next SR targeted for 2/7 (abhijitkumbhare, 18:56:22)
    2. Nitrogen autorelease hasn't passed in two weeks (dfarrell07, 18:56:22)
    3. need to start locking nitrogen autorelease down if we are going to hit SR2 release in two weeks (dfarrell07, 18:56:42)
    4. zxiiro asks if there is a pattern to nitrogen fails, klou_ says no, it's all over the place (dfarrell07, 18:58:10)
    5. autorelease build failure trend https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=818416294 (zxiiro, 18:58:14)
    6. latest fail is in lisp, but never happens to lori locally, only sporadically in jenkins, maybe related to slower HDD or maybe not, adding sleeps to let env settle, adding debugging (dfarrell07, 19:01:03)
    7. lori points out that it may just be integration tests generally, not so many projects have then, maybe bgp and others hitting similar post-infra-move (dfarrell07, 19:01:38)
    8. looks like strangeness in mdsal to lori, LuisGomez suggests trying a ramdisk (dfarrell07, 19:04:58)
    9. ACTION: LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big (abhijitkumbhare, 19:07:48)

  6. LFN Demo at the ONS (abhijitkumbhare, 19:09:19)
    1. the netconf 503 bug I was pushing is done, it wasn't a problem with ODL, bug marked as resolved (dfarrell07, 19:09:46)
    2. CaseyODL says there are 4-5 slots - and we can put together a proposal for ODL (abhijitkumbhare, 19:09:48)


Meeting ended at 19:11:07 UTC (full logs).

Action items

  1. CaseyODL to broadcast the option for doing an ODL demo to ODL lists
  2. jamoluhrsen to ask OPNFV why https://jira.opendaylight.org/browse/NETVIRT-896 is a blocker on the JIRA
  3. LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to ask OPNFV why https://jira.opendaylight.org/browse/NETVIRT-896 is a blocker on the JIRA
  2. lori
    1. LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big
  3. LuisGomez
    1. LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big
  4. zxiiro
    1. LuisGomez and zxiiro to work with lori to try ramdisk solution, will not be build itself as too big


People present (lines said)

  1. dfarrell07 (69)
  2. abhijitkumbhare (23)
  3. bjohnson (14)
  4. odl_meetbot (12)
  5. skitt (6)
  6. vorburger (4)
  7. vishnoianil (4)
  8. jamoluhrsen (4)
  9. klou_ (4)
  10. gzhao (3)
  11. zxiiro (2)
  12. lori (2)
  13. LuisGomez (1)
  14. anipbu (1)


Generated by MeetBot 0.1.4.