#opendaylight-meeting: tsc

Meeting started by CaseyODL at 18:02:37 UTC (full logs).

Meeting summary

    1. Daniel Farrell for Stephen Kitt (dfarrell07, 18:03:21)
    2. anipbu (anipbu, 18:03:25)
    3. Thanh Ha (zxiiro, 18:03:28)
    4. https://wiki.opendaylight.org/view/TSC:Main#Agenda Agenda (dfarrell07, 18:03:32)
    5. jamoluhrsen (jamoluhrsen, 18:03:39)
    6. lori (lori, 18:03:41)
    7. Brady Johnson (bjohnson_, 18:03:45)
    8. gzhao (gzhao, 18:04:21)
    9. LuisGomez (LuisGomez, 18:04:25)
    10. rovarga (rovarga, 18:04:42)
    11. shague (shague, 18:05:23)

  1. oxygen (dfarrell07, 18:05:35)
    1. https://jira.opendaylight.org/issues/?filter=10206 <- oxygen release blockers (klou, 18:05:57)
    2. SFC-213 may not be a blocker because it's a new feature for Oxygen (dfarrell07, 18:07:49)
    3. NETVIRT-1123 is actually a blocker, not new code, actively being worked on, upstream devstack causing problems, today or tomorrow ETA (dfarrell07, 18:09:31)
    4. NETVIRT-1122 jamo will ping fassella to update Jira, shague will make sure he reviews if needed (dfarrell07, 18:10:29)
    5. NETVIRT-1106 and NETVIRT-1062 are related, have patches, haven't been able to verify fixes because of devstack (dfarrell07, 18:11:13)
    6. NETVIRT-1101 may not be a regression/blocker, actually being worked on, shague will confirm if blocker (dfarrell07, 18:12:03)
    7. NETVIRT-1045 is a regression, there is a patch, just need devstack verify again (dfarrell07, 18:12:43)
    8. NETCONF-516 is waiting on verify job to finish, will be good to merge after (dfarrell07, 18:14:17)
    9. INFRAUTILS-29 is a pretty new regression skitt and others are still tracking down, the logging problem has been fixed on master, needs to go back to oxygen, Gerrit 68937, has verify about about to get +2 from tomp (dfarrell07, 18:17:07)
    10. for INFRAUTILS-29 there is a second patch on master and not oxygen that may not be critical (dfarrell07, 18:18:12)
    11. GENIUS-115 is being worked on, not sure of ETA (dfarrell07, 18:20:36)
    12. CONTROLLER-1816 is fixed, need to be put in resolved state (dfarrell07, 18:21:02)
    13. https://jira.opendaylight.org/browse/BGPCEP-763 is a new incoming blocker, regression from Nitrogen (rovarga, 18:21:13)
    14. BGPCEP-763 just came up, has a patch (dfarrell07, 18:22:12)
    15. https://git.opendaylight.org/gerrit/#/c/68843/ This is the binary jar to be removed from the repo (bjohnson_, 18:23:36)
    16. ACTION: zxiiro to raise a jira to add way to block large binary files from being merged (dfarrell07, 18:24:41)
    17. AGREED: 68843 is allowed in oxygen (dfarrell07, 18:25:29)
    18. ACTION: shague to raise jira to track GPL violation in netvirt, do same fix odlparent recently merged (dfarrell07, 18:27:00)
    19. klou asks when we want to do RC1 (dfarrell07, 18:28:06)
    20. https://wiki.opendaylight.org/view/Release_Dashboard <- Release Dashboard (klou, 18:29:11)
    21. once we have devstack working again we will be able to verify lots of netvirt patches and fix lots of blockers, so maybe RC after that (dfarrell07, 18:29:11)
    22. when the queens branch was cut, that broke our devstack stuff (dfarrell07, 18:29:21)
    23. shague thinks we're in good shape, just being cautious about getting these well tested (dfarrell07, 18:29:42)
    24. we need to have a longer discussion about dates to make sure we are in good sync pattern with other projects, for example not to get this devstack breakage when they cut openstack branches (dfarrell07, 18:30:55)
    25. this is more about lots of patches going into openstack, across all branches, which broke us across the board (no so much about supporting queens or not) (dfarrell07, 18:32:17)
    26. there is work in progress to get away from devstack, use pre-built/validated images from OPNFV Apex (dfarrell07, 18:33:23)
    27. targeting early next week for RC2 (sorry, not RC1 above) (dfarrell07, 18:34:11)

  2. nitrogen (dfarrell07, 18:34:18)
    1. nothing (dfarrell07, 18:34:20)

  3. carbon (dfarrell07, 18:34:24)
    1. when do we want to do SR4? since last SR was major delayed (dfarrell07, 18:34:43)
    2. rovarga says at least 4 weeks pushed, jamoluhrsen says 6 weeks to get past ONS (dfarrell07, 18:35:08)
    3. AGREED: carbon SR4 is pushed out 6 weeks from 3/15, which is 4/26 (dfarrell07, 18:36:53)

  4. infra (dfarrell07, 18:37:40)
    1. nothing (dfarrell07, 18:37:43)

  5. Managed Release (bjohnson_, 18:40:30)
  6. Managed Release (CaseyODL, 18:40:31)
    1. we need to get a date-based release plan (dfarrell07, 18:40:31)
    2. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/docs-rtd-verify-fluorine/14/html/release-process/managed-release.html <-- release model (jamoluhrsen, 18:40:40)
    3. we want to require managed projects to take the non-sr project releases (jamoluhrsen, 18:48:45)
    4. need vocab section, my bad;) (dfarrell07, 18:48:57)
    5. example jira's created which will be used for milestone reports (see TSC project in JIRA) (jamoluhrsen, 18:51:07)
    6. ACTION: dfarrell07 will change SR Managed Release to Snapshot Integrated and Non-SR Managed Release to Release Integrated (dfarrell07, 18:53:35)
    7. discussion about when the release starts (dfarrell07, 18:53:47)
    8. rovarga thinks branch cutting should happen at code freeze, need cal to see how dates start-date should be (dfarrell07, 18:54:23)
    9. there is a different discussion about taking project out of SR or not, that may impact how we want to do releases in the future (dfarrell07, 18:55:40)
    10. VOTE: Voted on "The TSC wants to something along the lines of the Managed Release plan in Gerrit 68382, more changes will happen but the community should take note?" Results are, +1: 9 (dfarrell07, 18:58:31)

  7. tws (dfarrell07, 18:58:47)
    1. CaseyODL says Lisa (Marketing LFN Dir) will ask us about what we plan to do for next release, we may not have good answers, can follow up later (dfarrell07, 18:59:41)
    2. This marketing request is about Oxygen (dfarrell07, 19:00:24)
    3. ACTION: CaseyODL will make sure lots of projects hear about this marketing request, will follow up with email (dfarrell07, 19:00:49)
    4. rovarga points out the website is verrrry behind, talks about Carbon, no mention of Nitrogen (dfarrell07, 19:01:07)
    5. ACTION: CaseyODL will fix this website homepage carbon bug (dfarrell07, 19:02:07)

  8. cookies (dfarrell07, 19:02:31)


Meeting ended at 19:02:35 UTC (full logs).

Action items

  1. zxiiro to raise a jira to add way to block large binary files from being merged
  2. shague to raise jira to track GPL violation in netvirt, do same fix odlparent recently merged
  3. dfarrell07 will change SR Managed Release to Snapshot Integrated and Non-SR Managed Release to Release Integrated
  4. CaseyODL will make sure lots of projects hear about this marketing request, will follow up with email
  5. CaseyODL will fix this website homepage carbon bug


Action items, by person

  1. CaseyODL
    1. CaseyODL will make sure lots of projects hear about this marketing request, will follow up with email
    2. CaseyODL will fix this website homepage carbon bug
  2. dfarrell07
    1. dfarrell07 will change SR Managed Release to Snapshot Integrated and Non-SR Managed Release to Release Integrated
  3. shague
    1. shague to raise jira to track GPL violation in netvirt, do same fix odlparent recently merged
  4. zxiiro
    1. zxiiro to raise a jira to add way to block large binary files from being merged


People present (lines said)

  1. dfarrell07 (57)
  2. jamoluhrsen (11)
  3. odl_meetbot (10)
  4. bjohnson_ (8)
  5. zxiiro (5)
  6. CaseyODL (4)
  7. rovarga (3)
  8. klou (3)
  9. anipbu (3)
  10. shague (2)
  11. LuisGomez (2)
  12. lori (2)
  13. gzhao (1)


Generated by MeetBot 0.1.4.