#opendaylight-meeting: tsc

Meeting started by abhijitkumbhare at 16:59:19 UTC (full logs).

Meeting summary

    1. Agenda Bashing, Roll Call, Action Items (abhijitkumbhare, 16:59:48)
    2. abhijitkumbhare (abhijitkumbhare, 17:00:14)
    3. jamoluhrsen (jamoluhrsen, 17:01:27)
    4. Anil Vishnoi (vishnoianil, 17:01:33)
    5. Thanh Ha (zxiiro, 17:01:34)
    6. skitt (skitt, 17:01:39)
    7. Brady Johnson (bjohnson_, 17:01:44)
    8. LuisGomez (LuisGomez, 17:02:12)
    9. anipbu (anipbu, 17:02:57)
    10. TSC page split up into https://wiki.opendaylight.org/view/TSC:Meeting & https://wiki.opendaylight.org/view/TSC:Procedures_and_Processes (abhijitkumbhare, 17:03:26)

  1. Oxygen (abhijitkumbhare, 17:04:15)
    1. RC4 include a fix for a blocker in bgpcep, and is being released as Oxygen (skitt, 17:04:49)
    2. rovarga (rovarga, 17:04:49)
    3. gzhao( (irc only) (gzhao, 17:04:52)
    4. Quite a bit of activity since last TSC meeting - a few blockers fixed, signoff, etc. (abhijitkumbhare, 17:04:53)
    5. version bumping going on now (skitt, 17:05:30)
    6. branches unlocked hopefully by the end of the day (Pacific time) (skitt, 17:05:44)
    7. Release notes URL http://docs.opendaylight.org/en/latest/release-notes/index.html (zxiiro, 17:06:11)
    8. Congrats everyone for getting Oxygen out the door (abhijitkumbhare, 17:09:05)

  2. Fluorine (abhijitkumbhare, 17:10:12)
    1. https://jira.opendaylight.org/browse/TSC-56?jql=project%20%3D%20tsc%20AND%20%22ODL%20Release%22%20%3D%20Fluorine%20AND%20%22ODL%20New%20Participation%22%20%3D%20%22SNAPSHOT_Integrated%20(Managed)%22 (jamoluhrsen, 17:12:32)
    2. https://jira.opendaylight.org/browse/TSC-56?jql=project%20%3D%20tsc%20AND%20%22ODL%20Release%22%20%3D%20Fluorine%20AND%20%22ODL%20New%20Participation%22%20%3D%20%22SNAPSHOT_Integrated%20(Managed)%22 <-- projects requesting to be managed (jamoluhrsen, 17:12:47)
    3. Several projects have signed up for being managed (abhijitkumbhare, 17:12:48)
    4. Feedback on Managed Release Process from the projects so far has been positive (abhijitkumbhare, 17:14:48)
    5. Folks plan to sit down at the DDF for more details (abhijitkumbhare, 17:15:32)
    6. Releases for yangtools & odlparent need to be done soon after the DDF (official deadline is April 15?) (abhijitkumbhare, 17:17:00)
    7. deadline is 4/7 for MRI projects to have their releases done: https://wiki.opendaylight.org/view/Release_Dashboard#Fluorine (jamoluhrsen, 17:17:42)
    8. odlparent 3.1.0 is the target for Fluorine and Oxygen SR1 (skitt, 17:17:48)
    9. yangtools 2.0.3 is the target for both (skitt, 17:17:55)
    10. odlparent 3.0.3 and 3.1.0 are being released now (skitt, 17:18:04)
    11. yangtools 2.0.3 will follow shortly thereafter (skitt, 17:18:14)
    12. yangtools-2.0.2 is already in Fluorine, Oxygen-SR1 will go from 2.0.1 to 2.0.3 (rovarga, 17:18:28)
    13. OVSDB, Genius, Neutron, etc. have not yet signed up for being managed (abhijitkumbhare, 17:21:10)
    14. ACTION: Dependent project PTLs to reach out to the PTLs of these project (abhijitkumbhare, 17:22:49)
    15. Ariel Adam from Red Hat will be at ONS and could step in as release manager (abhijitkumbhare, 17:23:49)

  3. Nitrogen & Caarbon (abhijitkumbhare, 17:24:41)
    1. Nitrogen & Carbon SRs coming up really soon (abhijitkumbhare, 17:24:59)
    2. Need to communicate to projects to backport fixes (abhijitkumbhare, 17:25:26)

  4. JIRA linking across LFN projects (abhijitkumbhare, 17:25:53)
    1. Most LFN projects use JIRA (abhijitkumbhare, 17:26:29)
    2. JIRA allows to join Jira instances in a federation and cross reference (abhijitkumbhare, 17:26:53)
    3. VOTE: Voted on "Shall the OpenDaylight TSC approve linking to other LFN projects (ONAP, OPNFV, FD.io)?" Results are, +1: 7 (abhijitkumbhare, 17:29:41)
    4. AGREED: ODL TSC approves linking ODL JIRA to OPNFV, ONAP & FD.io (abhijitkumbhare, 17:30:14)
    5. ACTION: dfarrell07 to reach out to the other TSCs at the TAC about JIRA linking (abhijitkumbhare, 17:31:43)

  5. Kicking off ODL Internship Program (abhijitkumbhare, 17:32:05)
    1. Several interns usually reach out to ODL around this time (abhijitkumbhare, 17:32:39)
    2. https://wiki.lfnetworking.org/display/LN/LF+Networking+Internships Link to Internships page for LFN. (CaseyLF, 17:32:45)
    3. dfarrell07 thinks we should assume budget is available & kick off the internship program (abhijitkumbhare, 17:33:45)
    4. OPNFV and others also have a possibility to have longer internships (abhijitkumbhare, 17:34:50)
    5. for the 3 month option, interns would be asked to work 40 hours/week, whereas for the 6 month option, they would be asked to work 20 hours/week (bjohnson_, 17:36:14)
    6. CaseyLF says that 6 month interns need to work only 20 hours a week as opposed to the current 3 month internships of 40 hrs/week (abhijitkumbhare, 17:36:16)
    7. For a 3 month internship, new interns would barely have time to get up to speed on ODL (bjohnson_, 17:36:52)
    8. ACTION: abhijitkumbhare send out a broadcast email to solicit intern project proposals (abhijitkumbhare, 17:38:24)
    9. ACTION: CaseyLF to update ODL wiki page to be more clear on how to apply for internships and work with Trishan to actively solicit for Interns. (CaseyLF, 17:39:11)

  6. Infrastructure (abhijitkumbhare, 17:40:06)
    1. CaseyLF has communicated privately to the TSC about the infra costs (abhijitkumbhare, 17:41:12)

  7. DDF (abhijitkumbhare, 17:42:48)
    1. CaseyLF has updated the venue info on the wiki (abhijitkumbhare, 17:43:18)
    2. https://www.irccloud.com/pastebin/TnTJMm2t/ (abhijitkumbhare, 17:45:50)

  8. Weather Item (abhijitkumbhare, 17:48:53)
    1. https://jira.opendaylight.org/browse/TSC-45 (rovarga, 17:49:03)
    2. MDSAL Fluorine API breakage window 1 (abhijitkumbhare, 17:49:26)
    3. All the projects thru dependency tree need to be remerged (abhijitkumbhare, 17:49:51)
    4. rovarga thinks best window would be March 31st as most people will be traveling (abhijitkumbhare, 17:51:00)
    5. jamoluhrsen asks whether this should be done after unmanaged projects are removed, rovarga thinks it does not matter (abhijitkumbhare, 17:52:39)
    6. This change is for https://jira.opendaylight.org/browse/MDSAL-325 (abhijitkumbhare, 17:54:18)
    7. and for https://jira.opendaylight.org/browse/MDSAL-326 (rovarga, 17:54:40)

  9. TSC call during the ONS week (abhijitkumbhare, 17:56:55)
    1. TSC meeting will be held - we will try to make it Wednesday lunch (abhijitkumbhare, 17:58:22)
    2. ACTION: CaseyLF to get us a room for Wed lunch TSC meeting (jamoluhrsen, 17:58:58)
    3. ACTION: CaseyLF will try to work out the logistics of holding the TSC meeting on Wednesday (abhijitkumbhare, 17:59:01)

  10. Cookies (abhijitkumbhare, 17:59:15)


Meeting ended at 17:59:22 UTC (full logs).

Action items

  1. Dependent project PTLs to reach out to the PTLs of these project
  2. dfarrell07 to reach out to the other TSCs at the TAC about JIRA linking
  3. abhijitkumbhare send out a broadcast email to solicit intern project proposals
  4. CaseyLF to update ODL wiki page to be more clear on how to apply for internships and work with Trishan to actively solicit for Interns.
  5. CaseyLF to get us a room for Wed lunch TSC meeting
  6. CaseyLF will try to work out the logistics of holding the TSC meeting on Wednesday


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare send out a broadcast email to solicit intern project proposals
  2. CaseyLF
    1. CaseyLF to update ODL wiki page to be more clear on how to apply for internships and work with Trishan to actively solicit for Interns.
    2. CaseyLF to get us a room for Wed lunch TSC meeting
    3. CaseyLF will try to work out the logistics of holding the TSC meeting on Wednesday
  3. UNASSIGNED
    1. Dependent project PTLs to reach out to the PTLs of these project
    2. dfarrell07 to reach out to the other TSCs at the TAC about JIRA linking


People present (lines said)

  1. abhijitkumbhare (61)
  2. skitt (14)
  3. odl_meetbot (12)
  4. bjohnson_ (9)
  5. zxiiro (7)
  6. jamoluhrsen (7)
  7. rovarga (5)
  8. LuisGomez (3)
  9. gzhao (2)
  10. anipbu (2)
  11. CaseyLF (2)
  12. vishnoianil (1)


Generated by MeetBot 0.1.4.