#opendaylight-meeting: tsc

Meeting started by CaseyLF at 20:33:19 UTC (full logs).

Meeting summary

    1. Anil Vishnoi (vishnoianil, 20:33:38)
    2. anipbu (anipbu, 20:34:02)
    3. https://zoom.us/j/219174946 (CaseyLF, 20:34:09)
    4. shague (shague, 20:34:09)
    5. Thanh Ha (zxiiro, 20:34:13)
    6. rovarga_ (rovarga_, 20:34:13)
    7. jamoluhrsen (jamoluhrsen, 20:34:22)

  1. dlux archival (jamoluhrsen, 20:35:10)
    1. LuisGomez (LuisGomez, 20:35:20)
    2. Discussion on the future of DLux (abhijitkumbhare, 20:36:09)
    3. Need the apps to remove the dependency on Dlux (abhijitkumbhare, 20:36:47)
    4. https://www.opendaylight.org/what-we-do/lifecycle-releases (vishnoianil, 20:36:51)
    5. skitt (skitt, 20:38:40)
    6. we can just let the managed release process work like we expect and probably DLUX will just not end up in the release. (jamoluhrsen, 20:39:51)
    7. we can also do the more formal process of archival and removal (jamoluhrsen, 20:40:08)
    8. side note from rovarga_ ( we still need to remove/archive tcpmd5 ) (jamoluhrsen, 20:43:03)
    9. ACTION: dfarrell07 to make an official DLUX termination request (jamoluhrsen, 20:43:52)
    10. everything discussed and planned for DLUX applies to DLUX-APPS (jamoluhrsen, 20:44:32)
    11. rovarga_ noting that we probably should not approve a UI project going forward, if they come. (jamoluhrsen, 20:45:49)

  2. VTN archival proposal (abhijitkumbhare, 20:46:15)
    1. Termination review to be done in two weeks (April 12) (abhijitkumbhare, 20:46:49)
    2. ACTION: dfarrell07 to follow up with VTN to see their plans to support existing releases (jamoluhrsen, 20:48:29)

  3. Release Manager (abhijitkumbhare, 20:49:14)
    1. Welcome Ariel Adam (abhijitkumbhare, 20:49:24)
    2. VOTE: Voted on "Does the TSC approve Ariel Adam as the release manager?" Results are, +1: 10 (jamoluhrsen, 20:52:01)
    3. Congrats Ariel (abhijitkumbhare, 20:52:31)

  4. Releases (abhijitkumbhare, 20:53:27)
  5. Carbon SR4 due in one month? (jamoluhrsen, 20:54:02)
    1. Carbon SR due on April 26th (abhijitkumbhare, 20:54:21)
    2. Carbon autorelease not passing (abhijitkumbhare, 20:54:34)
    3. regresssion in yangtools is one reason autorlease is not passing (jamoluhrsen, 20:54:42)
    4. ACTION: jamoluhrsen to bump carbon autorelease run once a day (jamoluhrsen, 20:54:57)
    5. AGREED: should be a default process that we bump autorelease jobs to once a day with four weeks before planned release (jamoluhrsen, 20:55:20)
    6. Whether we can make tests run in parallel (abhijitkumbhare, 20:56:51)
    7. Not going to happen soon (abhijitkumbhare, 20:57:06)
    8. nitrogen SR3 coming May 7th. 6 weeks from now (jamoluhrsen, 20:57:10)
    9. there is no successful build of nitrogen since Feb 21st (jamoluhrsen, 20:57:27)
    10. ACTION: jamoluhrsen to turn on nitrogen autorelease jobs once per day in two weeks (jamoluhrsen, 20:57:53)
    11. Oxygen SR1 is april 14th (jamoluhrsen, 20:58:19)
    12. https://wiki.opendaylight.org/view/Release_Dashboard Release Dashboard (dfarrell07, 20:58:39)
    13. need the new odlparent and yangtools version bumps for oxy sr1 (jamoluhrsen, 21:01:03)
    14. new odlparent and yangtools need their new releases approved by the TSC for Fluorine and when/if approved they can be given to oxy and nitro (jamoluhrsen, 21:04:01)
    15. yangtools 2.0.3 is a safe, non-breaking upgrade (skitt, 21:05:39)
    16. there was a regression related to vbd — that has been dealt with in both projects, so yangtools is non-breaking but vbd is no longer broken either (skitt, 21:06:00)
    17. odlparent 3.1.0 is also intended to be a safe upgrade (skitt, 21:06:27)
    18. rovarga_ and skitt are running final checks (skitt, 21:06:47)
    19. https://lists.opendaylight.org/pipermail/release/2018-March/014493.html <-- odlparent 3.1.0 release information (jamoluhrsen, 21:09:17)
    20. ACTION: dfarrell07 to clarify in MR docs what happens when MRI projects only want to do non-major version bumps in the integration window (dfarrell07, 21:15:30)
    21. VOTE: Voted on "Does the TSC approve the upgrade to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions) for Fluorine?" Results are, +1: 8 (skitt, 21:18:20)
    22. abhijitkumbhare concerned about making a karaf upgrade in between SR releases (jamoluhrsen, 21:24:01)
    23. VOTE: Voted on "Does the TSC request that the release engineering team merge all the patches to upgrade Oxygen SR1 to odlparent 3.1.0 and yangtools 2.0.3 (and any subsequent patch versions)?" Results are, +1: 9, -1: 1 (abhijitkumbhare, 21:24:34)

  6. Fluorine (abhijitkumbhare, 21:25:41)
    1. lispflowmapping and netvirt have dependencies which haven't applied to be managed (skitt, 21:25:46)
    2. https://docs.google.com/document/d/1c0rpB_7VMtWKIIgldbpVXnb77yUxUtbw1ayvOONrJvg/edit?usp=sharing <-- MRI requests (jamoluhrsen, 21:26:39)
    3. lispflowmapping depends on honeycomb.vbd which hasn't yet applied but is working on it (skitt, 21:28:10)
    4. netvirt depends on coe which is also working on it (skitt, 21:28:23)
    5. Patch for removing DLUX from lispflowmapping is pending verify and will be merged soon (vina_ermagan, 21:28:40)
    6. lispflowmapping is using vbd in an experimental feature only so it can easily be dropped (skitt, 21:30:22)
    7. but it would have to be for the full release (projects can't join MR after the deadline) (skitt, 21:30:36)
    8. ACTION: dfarrell07 to ping honeycomb/vbd about joining Managed ASAP (dfarrell07, 21:31:23)
    9. ACTION: dfarrell07 to follow up with fkautz about COE applying to Managed (dfarrell07, 21:31:53)
    10. https://docs.google.com/document/d/1c0rpB_7VMtWKIIgldbpVXnb77yUxUtbw1ayvOONrJvg/edit (anipbu, 21:36:28)
    11. ovsdb has committer vishnoianil who will normally be at TSC (dfarrell07, 21:40:25)
    12. shague, skitt also as committers on ovsdb and in TSC (shague, 21:40:59)
    13. AGREED: ovsdb is approved as an MSI project for Fluorine (abhijitkumbhare, 21:42:21)
    14. Daexim proposal for MSI https://jira.opendaylight.org/browse/TSC-61 (abhijitkumbhare, 21:43:25)
    15. michael will come to TSC for DAEXIM (dfarrell07, 21:43:30)
    16. AGREED: daexim is approved as an MSI project for Fluorine (skitt, 21:43:30)
    17. BGPCEP MSI proposal: https://jira.opendaylight.org/browse/TSC-56 (abhijitkumbhare, 21:44:12)
    18. jamoluhrsen says bgpcep is active on test front, even if few committers (dfarrell07, 21:44:53)
    19. bgpcep seems responsive, did have a blocker bug late in oxygen but handled it well (dfarrell07, 21:45:18)
    20. bgpcep only really has one active committer currently (jamoluhrsen, 21:45:25)
    21. rovarga_ is a bgpcep committer but he doesn't look at it much, "active backup" (dfarrell07, 21:45:52)
    22. should keep level of committers on radar for bgpcep, if he seems gone may be issue TSC needs to deal with (dfarrell07, 21:46:23)
    23. rovarga_ will represent the project (skitt, 21:46:43)
    24. AGREED: bgpcep is approved as an MSI project for Fluorine (skitt, 21:47:01)
    25. OpenFlow Plugin: https://jira.opendaylight.org/browse/TSC-50 (abhijitkumbhare, 21:48:08)
    26. vishnoianil has already done a committer cleanup for openflow plugin recently (dfarrell07, 21:48:19)
    27. openflow plugin has about five active people, multiple companies (dfarrell07, 21:48:36)
    28. rovarga_ has seem small patches that were not reviewed, vishnoianil is apparently only one reviewing, has been pushing committers to do reviews (dfarrell07, 21:49:25)
    29. there are one or two people in the contribution pipeline for becoming committers (dfarrell07, 21:49:49)
    30. AGREED: openflowplugin is approved as an MSI project for Fluorine (skitt, 21:50:15)
    31. Distribution Project: https://jira.opendaylight.org/browse/TSC-48 (abhijitkumbhare, 21:51:26)
    32. distribution has committers who are very active in ODL, can step up in times of need easily (dfarrell07, 21:51:41)
    33. AGREED: distribution is approved as an MSI project for Fluorine (skitt, 21:51:44)
    34. genius - jamoluhrsen reports that from a test side they are very active, very responsive (dfarrell07, 21:52:21)
    35. Genius project: https://jira.opendaylight.org/browse/TSC-63 (abhijitkumbhare, 21:52:23)
    36. AGREED: genius is approved as an MSI project for Fluorine (skitt, 21:52:30)
    37. genius meets every week, speaks up lots when things break them (dfarrell07, 21:52:36)
    38. Neutron Northbound: https://jira.opendaylight.org/browse/TSC-60 (abhijitkumbhare, 21:53:03)
    39. josh h is going to take over as PTL for Neutron NB (dfarrell07, 21:53:09)
    40. AGREED: neutron is approved as an MSI project for Fluorine (skitt, 21:53:22)
    41. NNB does have good integration tests, and is also very well tested by other projects (dfarrell07, 21:53:37)
    42. maybe should be watching number of committers for NNB, fairly healthy but more might be better (dfarrell07, 21:54:29)
    43. LISP project: https://jira.opendaylight.org/browse/TSC-54 (abhijitkumbhare, 21:55:30)
    44. lisb needs to deal with honeycomb/vbd dep, who has not applied for Managed (dfarrell07, 21:56:09)
    45. Vote deferred for LISP till next week (abhijitkumbhare, 21:56:14)
    46. ACTION: lori to resolve the situation wrt honeycomb by next week's TSC call (skitt, 21:56:28)
    47. lisp can comment out honeycomb/vbd, but they *will not be able to add them back in Fluorine even if they become Managed* (dfarrell07, 21:56:36)
    48. rovarga_ points out that in some future version of MR, we may want to think about how MR projects could have experimental features, say that depend on unmanaged projects (dfarrell07, 21:58:52)
    49. waiting on lisp to cut dep, will vote no next week (dfarrell07, 21:59:28)
    50. sfc depends on lisp, so also waiting on vote until lisp cuts vbd dep (dfarrell07, 22:00:23)
    51. sfc has very active contributors in opnfv xci, so very good test coverage, also someone is is doing ODL-side testing I see frequently (dfarrell07, 22:01:38)
    52. bjohnson_ is on TSC, so will be at meetings for SFC (dfarrell07, 22:02:16)
    53. AGREED: NetVirt is approved as an MSI project for Fluorine (abhijitkumbhare, 22:10:58)
    54. skitt has experience with tsdr waking up once or so a release to merge patches, but not watching frequently (dfarrell07, 22:13:34)
    55. it may be that tsdr depends on SNMP, which is not managed (dfarrell07, 22:14:10)
    56. it seems possible that tsdr doesn't understand that they can still be fully "a part of opendaylight" by being unmanaged, maybe just need to reassure them of that (dfarrell07, 22:15:22)
    57. tsdr doesn't come to tsc, doesn't have active committers, doesn't have contribution history says jamoluhrsen (dfarrell07, 22:15:41)
    58. VOTE: Voted on "Does the TSC approve TSDR as a managed project for Fluorine?" Results are, 0: 1, -1: 8 (skitt, 22:22:23)
    59. ACTION: dfarrell07 will communicate with TSDR (abhijitkumbhare, 22:24:29)
    60. AGREED: all other projects will be removed from distribution and autorelease (LISP and SFC will be deferred) (jamoluhrsen, 22:26:17)

  7. Coffee, cookies & beer (abhijitkumbhare, 22:27:25)


Meeting ended at 22:28:17 UTC (full logs).

Action items

  1. dfarrell07 to make an official DLUX termination request
  2. dfarrell07 to follow up with VTN to see their plans to support existing releases
  3. jamoluhrsen to bump carbon autorelease run once a day
  4. jamoluhrsen to turn on nitrogen autorelease jobs once per day in two weeks
  5. dfarrell07 to clarify in MR docs what happens when MRI projects only want to do non-major version bumps in the integration window
  6. dfarrell07 to ping honeycomb/vbd about joining Managed ASAP
  7. dfarrell07 to follow up with fkautz about COE applying to Managed
  8. lori to resolve the situation wrt honeycomb by next week's TSC call
  9. dfarrell07 will communicate with TSDR


Action items, by person

  1. dfarrell07
    1. dfarrell07 to make an official DLUX termination request
    2. dfarrell07 to follow up with VTN to see their plans to support existing releases
    3. dfarrell07 to clarify in MR docs what happens when MRI projects only want to do non-major version bumps in the integration window
    4. dfarrell07 to ping honeycomb/vbd about joining Managed ASAP
    5. dfarrell07 to follow up with fkautz about COE applying to Managed
    6. dfarrell07 will communicate with TSDR
  2. jamoluhrsen
    1. jamoluhrsen to bump carbon autorelease run once a day
    2. jamoluhrsen to turn on nitrogen autorelease jobs once per day in two weeks
  3. lori
    1. lori to resolve the situation wrt honeycomb by next week's TSC call


People present (lines said)

  1. dfarrell07 (40)
  2. jamoluhrsen (34)
  3. abhijitkumbhare (34)
  4. skitt (32)
  5. odl_meetbot (27)
  6. shague (23)
  7. rovarga_ (9)
  8. LuisGomez (7)
  9. anipbu (7)
  10. vishnoianil (7)
  11. zxiiro (5)
  12. CaseyLF (4)
  13. lori (3)
  14. aadam (2)
  15. vina_ermagan (1)
  16. abelur (1)


Generated by MeetBot 0.1.4.