#opendaylight-meeting: tsc

Meeting started by abhijitkumbhare at 16:59:06 UTC (full logs).

Meeting summary

  1. Agenda Bashing, Roll Call, Action Items (abhijitkumbhare, 17:00:07)
    1. https://docs.google.com/presentation/d/1wmngPmZ52lYloQI_6XnsdlaU23yDzGCBk44SnZF2Nv4/edit?usp=sharing Antitrust Policy (CaseyLF, 17:00:41)
    2. Andrew Grimberg (proxy for Thanh Ha) (tykeal, 17:00:49)
    3. abhijitkumbhare (abhijitkumbhare, 17:00:56)
    4. Brady Johnson (bjohnson_, 17:01:10)
    5. anipbu (anipbu, 17:02:09)
    6. #project bgpcep (cdgasparini, 17:02:09)
    7. jamoluhrsen (jamoluhrsen, 17:02:34)
    8. Anil Vishnoi (vishnoianil, 17:02:38)
    9. gzhao proxy (anipbu, 17:02:46)
    10. jhershbe (jhershbe, 17:02:58)
    11. #project #usc (anipbu, 17:03:03)
    12. lori (lori, 17:03:05)
    13. shague (via jamoluhrsen) (jamoluhrsen, 17:03:06)
    14. rovarga_ (rovarga_, 17:03:22)
    15. LuisGomez (LuisGomez, 17:03:24)
    16. #project netvirt genius (jamoluhrsen, 17:03:26)
    17. #project infrautils (jamoluhrsen, 17:03:45)
    18. #project lispflowmapping (lori, 17:03:45)
    19. #project neutron (jhershbe, 17:03:46)
    20. distribution (LuisGomez, 17:04:00)

  2. Fluorine (abhijitkumbhare, 17:04:12)
  3. Nitrogen SR3 (abhijitkumbhare, 17:05:09)
    1. blocking bug CONTROLLER-1827 in Nitro SR3 (jamoluhrsen, 17:05:19)
    2. https://git.opendaylight.org/gerrit/71808 <-- just a stab at fixing CONTROLLER-1827 (jamoluhrsen, 17:06:16)
    3. rovarga_ has pushed the patch for 1827 - waiting for verify (abhijitkumbhare, 17:06:23)
    4. https://git.opendaylight.org/gerrit/#/c/71808/ has verify -1 now (dfarrell07, 17:06:30)
    5. rovarga_ does not have cycles for this - but pantelis_ says this is not a blocker (abhijitkumbhare, 17:07:04)
    6. Per last TSC this is a regression from SR2 (dfarrell07, 17:08:01)
    7. Seems to only impact NetConf (dfarrell07, 17:08:21)
    8. this is all related to config subsystem, so only impacts Nitrogen, is going away (dfarrell07, 17:08:52)
    9. tomp and LuisGomez say they don't know of people using this feature (dfarrell07, 17:10:46)
    10. AGREED: CONTROLLER-1827 is a regression but is not a blocker (abhijitkumbhare, 17:11:59)
    11. we marked this a blocker last week when we didn't really know root cause, impact, if other things were impacted, (dfarrell07, 17:12:24)
    12. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U nitrogen spreadsheet (dfarrell07, 17:16:12)
    13. we now have all sign-offs for Nitrogen SR3, should promote the RC to release (dfarrell07, 17:17:32)
    14. Since CONTROLLER-1827 is not a blocker, there is nothing blocking Nitrogen SR3 (abhijitkumbhare, 17:18:08)
    15. AGREED: Nitrogen SR3 is ready to go (abhijitkumbhare, 17:18:40)
    16. we release https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan#SR3_Download (anipbu, 17:19:06)
    17. aadam will update the wiki to reflect the right SR3 build (abhijitkumbhare, 17:20:00)
    18. ACTION: aadam to email release team to promote autorelease 2160 to Nitrogen SR3 (dfarrell07, 17:20:01)

  4. Fluorine (abhijitkumbhare, 17:20:07)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (aadam, 17:20:33)
    2. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 < release dashboard (jamoluhrsen, 17:20:47)
    3. Fluorine CSIT checkpoint passed: https://jira.opendaylight.org/projects/TSC/versions/10612 (abhijitkumbhare, 17:21:29)
    4. Next milestone for Fluorine: middle checkpoint on July 5: https://jira.opendaylight.org/browse/TSC/fixforversion/10613 (abhijitkumbhare, 17:23:14)
    5. aadam asking the status of Swagger page (abhijitkumbhare, 17:24:02)
    6. faseelak (faseelak, 17:25:12)
    7. No longer works on Oxygen onwards - looks to be a bug and will be filed by aadam (abhijitkumbhare, 17:25:14)
    8. Michael's weather item tool working for TSC-99 (abhijitkumbhare, 17:26:22)
    9. faseelak reports that TSC99 is making progress, working through projects and fixing using Michael's tool (dfarrell07, 17:26:33)
    10. genius is next project to check for TSC99 (jamoluhrsen, 17:27:57)
    11. faseelak to fix the issues in genius patch for TSC-99 and run multi-patch (faseelak, 17:28:22)

  5. Project Archival / reinstatement (abhijitkumbhare, 17:31:24)
    1. https://jira.opendaylight.org/browse/TSC-106 Issue to add process for reactivating archived projects (dfarrell07, 17:33:23)
    2. AGREED: Project reinstatement will need project creation review but can use the old repo (abhijitkumbhare, 17:34:17)
    3. https://jira.opendaylight.org/browse/AALLDP-1 (abhijitkumbhare, 17:35:04)
    4. we need to create a termination review, likely good (but I think not required) notify the committers/PTL (dfarrell07, 17:40:10)
    5. https://wiki.opendaylight.org/view/Project_Proposals:Main#Termination_Review (vishnoianil, 17:41:47)
    6. ACTION: abhijitkumbhare to create Jira against TSC for each of these archivals, also create termination review for each, post each termination review to lists, CC committers, wait two weeks (dfarrell07, 17:42:10)
    7. example of the mail we used to sendd https://lists.opendaylight.org/pipermail/affinity-dev/2016-May/000158.html (vishnoianil, 17:42:27)

  6. Release dashboard (abhijitkumbhare, 17:45:08)
    1. aadam asks folks to review release dashboard, give any feedback (abhijitkumbhare, 17:45:15)

  7. Managed Projects with less than 2 active committers (abhijitkumbhare, 17:45:41)
    1. LuisGomez asks if we want to go through Managed projects and ask if they are in good shape wrt active committers (dfarrell07, 17:46:34)
    2. vishnoianil suggests having "grievance" as an agenda item on the TSC call (abhijitkumbhare, 17:49:43)
    3. ACTION: abhijitkumbhare to add grievances to agenda (dfarrell07, 17:51:34)

  8. Permissions in JIRA (abhijitkumbhare, 17:52:55)
    1. Only assignee can change the JIRA ticket - the ask is to allow anyone to change the JIRA ticket (abhijitkumbhare, 17:54:12)
    2. https://gerrit.linuxfoundation.org/infra/#/q/project:lfn/process LFN docs (dfarrell07, 18:00:33)

  9. Internships (abhijitkumbhare, 18:02:36)
    1. Internship can start anytime (abhijitkumbhare, 18:02:48)
    2. ACTION: CaseyLF to send an email about the status of internships (abhijitkumbhare, 18:03:24)

  10. Cookies :) (abhijitkumbhare, 18:03:36)


Meeting ended at 18:03:42 UTC (full logs).

Action items

  1. aadam to email release team to promote autorelease 2160 to Nitrogen SR3
  2. abhijitkumbhare to create Jira against TSC for each of these archivals, also create termination review for each, post each termination review to lists, CC committers, wait two weeks
  3. abhijitkumbhare to add grievances to agenda
  4. CaseyLF to send an email about the status of internships


Action items, by person

  1. aadam
    1. aadam to email release team to promote autorelease 2160 to Nitrogen SR3
  2. abhijitkumbhare
    1. abhijitkumbhare to create Jira against TSC for each of these archivals, also create termination review for each, post each termination review to lists, CC committers, wait two weeks
    2. abhijitkumbhare to add grievances to agenda
  3. CaseyLF
    1. CaseyLF to send an email about the status of internships


People present (lines said)

  1. abhijitkumbhare (43)
  2. dfarrell07 (26)
  3. tykeal (9)
  4. jamoluhrsen (9)
  5. odl_meetbot (8)
  6. bjohnson_ (6)
  7. vishnoianil (6)
  8. anipbu (4)
  9. cdgasparini (3)
  10. jhershbe (3)
  11. LuisGomez (3)
  12. faseelak (3)
  13. lori (3)
  14. rovarga_ (2)
  15. aadam (2)
  16. CaseyLF (1)


Generated by MeetBot 0.1.4.