#opendaylight-meeting: tsc

Meeting started by abhijitkumbhare at 16:59:00 UTC (full logs).

Meeting summary

    1. jhershbe (jhershbe, 16:59:06)
    2. Brady Johnson (bjohnson_, 16:59:18)

  1. Agenda-bashing and roll-call (skitt, 16:59:27)
    1. skitt (skitt, 16:59:36)
    2. lori (lori, 16:59:49)
    3. project neutron (jhershbe, 17:00:12)
    4. abhijitkumbhare (abhijitkumbhare, 17:00:16)
    5. project sfc (bjohnson_, 17:00:46)
    6. rovarga (rovarga, 17:00:58)
    7. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda (abhijitkumbhare, 17:01:04)
    8. jamoluhrsen (jamoluhrsen, 17:01:25)
    9. shague (shague, 17:01:40)
    10. gzhao (gzhao, 17:01:45)
    11. #project netvirt (shague, 17:01:54)
    12. ACTION: abhijitkumbhare to send TSC agenda the day prior to the TSC meeting when possible (jamoluhrsen, 17:02:49)
    13. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda <-- agenda wiki that is updated weekly (jamoluhrsen, 17:03:10)

  2. General topics (skitt, 17:03:36)
    1. LuisGomez (LuisGomez, 17:04:00)
    2. Ryan Goulding for AAA (rgoulding, 17:04:08)
    3. CaseyLF and phrobb went through the wiki recently and noticed lots of pages are out of date (skitt, 17:04:30)
    4. it would be nice if projects could check their pages and update them (skitt, 17:04:41)
    5. CaseyLF noticed the wiki is out of date in many places (project proposals, project facts, release planning, etc.) Asking for people to do some cleanup (jamoluhrsen, 17:04:44)
    6. #project genius (shague, 17:04:51)
    7. people can also tag info as out of date if they notice it (skitt, 17:05:16)
    8. dfarrell07 points out that some, if not a lot, of our documentation has moved off of the wiki to readthedocs (jamoluhrsen, 17:05:51)
    9. possible conflicting information between LF and ODL wiki about the same topics (jamoluhrsen, 17:08:24)
    10. ideally project-specific docs should go in the project (skitt, 17:09:42)
    11. further discussion will take place in the docs call (skitt, 17:10:53)
    12. docs call is tuesdays 12pm PST, for those that want to help and give ideas about making docs better (jamoluhrsen, 17:11:50)
    13. the LF is looking into switching to EPL2 (the license) (skitt, 17:12:52)
    14. CaseyLF has info forthcoming (skitt, 17:13:12)
    15. we'll have a more formal presentation next week (skitt, 17:13:22)
    16. CaseyLF invites participants to reach out to their legal departments regarding this (skitt, 17:13:43)
    17. as far as the Eclipse Foundation (originator of the EPL) is concerned, EPL1 is now deprecated (skitt, 17:14:39)
    18. multiple issues with EPL1 are addressed in EPL2: choice of venue, files as unit of licensing rather than modules, GPL compatibility etc. (skitt, 17:15:08)
    19. faseelak (faseelak, 17:15:24)
    20. CaseyLF believes the TSC could vote to migrate and "force" all projects to migrate (skitt, 17:15:50)
    21. we'd also need an update to the charter, section 7bi, which specifies the license in use (skitt, 17:16:16)
    22. ACTION: CaseyLF Send an email providing the details about the EPL2 change - rationale, etc. to the TSC mailing list (abhijitkumbhare, 17:17:07)
    23. ACTION: CaseyLF to schedule TWS for EPL2 change (jamoluhrsen, 17:17:21)
    24. anipbu (anipbu, 17:17:42)
    25. re Mailman, the LF needs to know definitively by the end of the quarter what ODL wants to do (skitt, 17:20:26)
    26. the Mailman services were supposed to switch to Groups.io by then (skitt, 17:20:38)
    27. the LF needs permission from ODL to hand over Mailman management to Oregon State Labs which is where they're hosted (skitt, 17:21:11)
    28. the hosting wouldn't change, it's just that the LF wouldn't be taking care of it (skitt, 17:21:32)
    29. AGREED: We will stay on mailman - Oregon State Labs will be taking over the management/support for mailman on June 1 (abhijitkumbhare, 17:25:36)
    30. https://doodle.com/poll/5fi657n95dgz8xqb <-- poll for possible new TSC time (jamoluhrsen, 17:26:03)
    31. we no longer need to have an official agenda item for system integration and test (jamoluhrsen, 17:28:24)

  3. Releases (abhijitkumbhare, 17:28:38)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 <-- release dashboard (jamoluhrsen, 17:28:38)
    2. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403# (dfarrell07, 17:28:38)
    3. TSC-99 went very well, much less downtime than previous migrations (skitt, 17:29:23)
    4. TSC-101 up next (skitt, 17:29:28)
    5. Fluorine middle checkpoint coming up (skitt, 17:30:48)
    6. work ongoing to improve automation to track the checkpoints (attendance, broken autorelease, CLM violations...) (skitt, 17:31:11)
    7. should the drop-dead date for pending weather items be the middle checkpoint? (skitt, 17:34:11)
    8. with patch queues for weather items, projects which get started early are penalised because they need to rebase a lot (skitt, 17:37:07)
    9. shague suggests that the answer is to get the patches ready more quickly (skitt, 17:37:32)
    10. instead of aiming for a drop-dead date, we should encourage projects to work on weather items ASAP (skitt, 17:38:17)
    11. (having a drop-dead date leads some projects to wait until then to prepare their patches) (skitt, 17:38:35)
    12. we could also have name-and-shame emails every day (skitt, 17:38:44)

  4. removing SFT from autorelease (abhijitkumbhare, 17:44:56)
    1. rovarga suggests we modify autorelease so that it ignores SFT failures (logs them but continues) (skitt, 17:49:17)
    2. jamoluhrsen says there’s an issue with stuck SFTs (skitt, 17:49:30)
    3. https://jira.opendaylight.org/browse/ODLPARENT-89 <-- sft hanging bug (jamoluhrsen, 17:50:52)
    4. https://jira.opendaylight.org/browse/ODLPARENT-88 <-- the real sft hanging bug (jamoluhrsen, 17:51:22)
    5. now that autorelease feeds into int/dist, we should have equivalent coverage at least for managed projects (skitt, 17:57:05)
    6. SFT patch: https://git.opendaylight.org/gerrit/72168 (skitt, 17:57:29)

  5. Cookies & Beer (abhijitkumbhare, 18:00:57)


Meeting ended at 18:01:01 UTC (full logs).

Action items

  1. abhijitkumbhare to send TSC agenda the day prior to the TSC meeting when possible
  2. CaseyLF Send an email providing the details about the EPL2 change - rationale, etc. to the TSC mailing list
  3. CaseyLF to schedule TWS for EPL2 change


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to send TSC agenda the day prior to the TSC meeting when possible
  2. CaseyLF
    1. CaseyLF Send an email providing the details about the EPL2 change - rationale, etc. to the TSC mailing list
    2. CaseyLF to schedule TWS for EPL2 change


People present (lines said)

  1. skitt (47)
  2. jamoluhrsen (24)
  3. abhijitkumbhare (15)
  4. bjohnson_ (8)
  5. rovarga (6)
  6. vorburger (6)
  7. odl_meetbot (5)
  8. shague (3)
  9. jhershbe (3)
  10. dfarrell07 (3)
  11. gzhao (2)
  12. faseelak (2)
  13. lori (2)
  14. CaseyLF (2)
  15. cdgasparini (1)
  16. rgoulding (1)
  17. scottmelton (1)
  18. LuisGomez (1)
  19. anipbu (1)


Generated by MeetBot 0.1.4.