#opendaylight-meeting: tsc

Meeting started by abhijitkumbhare at 15:59:49 UTC (full logs).

Meeting summary

  1. Agenda Bashing, Roll Call, Action Items (abhijitkumbhare, 16:00:34)
    1. gzhao (gzhao, 16:00:40)
    2. abhijitkumbhare (abhijitkumbhare, 16:00:55)
    3. skitt (skitt, 16:01:20)
    4. jamoluhrsen (jamoluhrsen, 16:01:36)
    5. Vishal (vthapar, 16:01:39)
    6. LuisGomez (LuisGomez, 16:02:10)
    7. lori (lori, 16:02:45)
    8. ArielAdam (aadam, 16:03:28)
    9. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:03:46)
    10. project neutron (aadam, 16:03:47)
    11. https://r.lfnetworking.org/Antitrust%20Slide.pdf anti trust policy (CaseyLF, 16:03:53)
    12. faseelak (faseelak, 16:04:20)
    13. jamoluhrsen asks to add the odltools project proposal to the agenda (skitt, 16:04:30)
    14. Tom Pantelis in for Brady Johnson (pantelis, 16:04:38)

  2. Infrastructure (skitt, 16:04:42)
    1. Thanh Ha (zxiiro, 16:05:18)
    2. No updates (abhijitkumbhare, 16:05:41)

  3. Neon DDF (skitt, 16:05:56)
    1. still planning to have the DDF on the Thursday and Friday before ONS Europe at the end of September in Amsterdam (skitt, 16:07:04)
    2. rgoulding (rgoulding, 16:08:36)
    3. ONS Europe: https://events.linuxfoundation.org/events/open-networking-summit-europe-2018/ (skitt, 16:08:52)
    4. ACTION: CaseyLF to initiate a doodle poll for either Sunday-Monday or Thursday-Friday before the ONS (abhijitkumbhare, 16:12:50)

  4. Releases (abhijitkumbhare, 16:13:11)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard (abhijitkumbhare, 16:13:50)
    2. need projects to update tracking spreadsheet for oxy sr2 (jamoluhrsen, 16:14:33)
    3. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=790452366 <-- tracking sheet for oxy sr2 (jamoluhrsen, 16:14:50)
    4. TSC-101 weather item is finished. (jamoluhrsen, 16:15:40)
    5. ACTION: Ariel to send Jaime a mail regarding weather item TSC-114 (aadam, 16:17:41)
    6. TSC-111 underway as per pantelis (abhijitkumbhare, 16:18:49)
    7. ACTION: Ariel to check if he can filter out weather items which are scheduled +1 month (aadam, 16:20:25)
    8. Fluorine middle check point is July 5 (abhijitkumbhare, 16:21:43)
    9. Grievances will be looked at during the middle checkpoint (abhijitkumbhare, 16:23:06)
    10. ACTION: to change the due dates of the release grievances to the mid checkpoint and only talk about it then (aadam, 16:23:06)
    11. ACTION: Ariel to change the due dates of the release grievances to the mid checkpoint and only talk about it then (aadam, 16:23:39)

  5. Autorelease failures and LispFlowMapping Tests (abhijitkumbhare, 16:24:31)
    1. autorelease failures have been an ongoing issue (abhijitkumbhare, 16:25:08)
    2. the lispflowmapping integration tests are much more comprehensive than the CSIT tests (skitt, 16:25:27)
    3. even after CSIT was created, development of the integration tests in LFM continued (skitt, 16:25:43)
    4. they are very useful in detecting failures in lispflowmapping and upstream projects (skitt, 16:26:04)
    5. there were problems in the past with infrastructure changes (skitt, 16:26:17)
    6. sometimes the tests fail in Jenkins, but never locally (skitt, 16:26:27)
    7. the switch to log4j2 means the IT logs are no longer available either (skitt, 16:27:08)
    8. the current workaround is to keep the IT Karaf directory (skitt, 16:27:32)
    9. and extract the logs from there (skitt, 16:27:41)
    10. lispflowmapping test failure https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-fluorine/108/lispflowmapping/integrationtest/target/exam/721ef9e4-0e44-4d1e-b458-3386f589d22b/data/log/karaf.log.gz (lori, 16:28:31)
    11. the logs on failed jobs show problems in Karaf rather than assertion errors from the tests (skitt, 16:28:39)
    12. shague suggested disabling the IT tests in autorelease (but leave them in the patch jobs) (skitt, 16:30:05)
    13. lori has no major objection to this (skitt, 16:30:44)
    14. as long as we can re-enable them in autorelease once we know they’re stable (skitt, 16:30:58)
    15. jamoluhrsen also suggests increasing the frequency of the lispflowmapping merge job (skitt, 16:31:59)
    16. dfarrell07 doesn’t like the idea of turning tests which may be finding a real failure (skitt, 16:37:42)
    17. shague suggests keeping the job but ignoring errors (skitt, 16:40:47)

  6. Project Proposal : ODL Tools (abhijitkumbhare, 16:43:06)
    1. jamoluhrsen says that we should keep with the ODL tools (abhijitkumbhare, 16:43:38)
    2. the project name will be "ODL Support Tools" but the repo and PIP name will be "odltools" (skitt, 16:44:55)
    3. https://wiki.opendaylight.org/view/Project_Proposals:ODLTools <-- ODL Support Tools project proposal (jamoluhrsen, 16:45:21)
    4. VOTE: Voted on "Does the TSC approve project "ODL Support Tools" to be approved?" Results are, +1: 8 (abhijitkumbhare, 16:48:23)
    5. dfarrell07 voted in proxy for shague (abhijitkumbhare, 16:48:42)
    6. dfarrell07's vote was on behalf of Sam, although skitt is shague's proxy, just for mechanical reasons (dfarrell07, 16:48:46)
    7. LuisGomez also voted as +1 (abhijitkumbhare, 16:49:12)
    8. AGREED: Project "ODL Support Tools" is approved to be an ODL project (abhijitkumbhare, 16:49:49)

  7. LFN update (abhijitkumbhare, 16:51:22)
    1. dfarrell07 informs that the governance docs are being currently finalized - roughly to be finished in a month (abhijitkumbhare, 16:52:14)
    2. https://gerrit.linuxfoundation.org/infra/#/q/project:lfn/process repo with LFN gov docs (dfarrell07, 16:52:20)

  8. Community awards (abhijitkumbhare, 16:53:51)
    1. https://linuxfoundation.store LFN Webstore (CaseyLF, 16:54:02)
    2. CaseyLF informs that the community awards are planned for the Fluorine release (abhijitkumbhare, 16:54:26)
    3. They will be awarded at the Neon DDF (abhijitkumbhare, 16:54:51)

  9. Cookies with tea (abhijitkumbhare, 16:54:55)


Meeting ended at 16:55:04 UTC (full logs).

Action items

  1. CaseyLF to initiate a doodle poll for either Sunday-Monday or Thursday-Friday before the ONS
  2. Ariel to send Jaime a mail regarding weather item TSC-114
  3. Ariel to check if he can filter out weather items which are scheduled +1 month
  4. to change the due dates of the release grievances to the mid checkpoint and only talk about it then
  5. Ariel to change the due dates of the release grievances to the mid checkpoint and only talk about it then


Action items, by person

  1. CaseyLF
    1. CaseyLF to initiate a doodle poll for either Sunday-Monday or Thursday-Friday before the ONS
  2. UNASSIGNED
    1. Ariel to send Jaime a mail regarding weather item TSC-114
    2. Ariel to check if he can filter out weather items which are scheduled +1 month
    3. to change the due dates of the release grievances to the mid checkpoint and only talk about it then
    4. Ariel to change the due dates of the release grievances to the mid checkpoint and only talk about it then


People present (lines said)

  1. skitt (38)
  2. abhijitkumbhare (34)
  3. odl_meetbot (11)
  4. jamoluhrsen (7)
  5. vorburger (6)
  6. aadam (6)
  7. zxiiro (5)
  8. dfarrell07 (4)
  9. CaseyLF (4)
  10. vthapar (3)
  11. lori (3)
  12. rovarga_ (3)
  13. gzhao (2)
  14. rgoulding (2)
  15. pantelis (2)
  16. LuisGomez (2)
  17. faseelak (2)
  18. shague (1)
  19. ScottM (1)


Generated by MeetBot 0.1.4.