#opendaylight-meeting: tsc

Meeting started by CaseyLF at 15:58:44 UTC (full logs).

Meeting summary

  1. Roll-call and agenda bashing (skitt, 16:00:12)
    1. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:00:18)
    2. abhijitkumbhare (abhijitkumbhare, 16:00:25)
    3. *TSC members* please #info in (skitt, 16:00:30)
    4. anipbu (anipbu, 16:00:37)
    5. Project representatives please #project in (skitt, 16:00:38)
    6. skitt (skitt, 16:00:41)
    7. lori (lori, 16:00:55)
    8. gzhao (proxy) (anipbu, 16:01:03)
    9. Brady Johnson (bjohnson, 16:01:56)
    10. jhershbe (jhershbe, 16:02:05)
    11. rovarga (rovarga, 16:02:11)
    12. Anil Vishnoi (vishnoianil, 16:02:28)
    13. LuisGomez (LuisGomez, 16:02:48)
    14. gzhao (gzhao, 16:02:59)
    15. Thanh Ha (zxiiro, 16:03:17)
    16. jamoluhrsen (jamoluhrsen, 16:03:51)

  2. Neon DDF (abhijitkumbhare, 16:04:06)
    1. the LF has inquired about moving the DDF but hasn’t received an official reply (skitt, 16:04:44)
    2. CaseyLF thinks we’ll receive a positive response (skitt, 16:04:55)
    3. Waiting for the update about moving DDF dates - but hopeful (abhijitkumbhare, 16:05:21)

  3. LFN TAC / Board updates (abhijitkumbhare, 16:05:52)
    1. shague (shague, 16:05:53)
    2. #project netvirt odltools (shague, 16:06:35)
    3. Abhijit/Daniel provided update to the board (abhijitkumbhare, 16:07:13)
    4. Slides: https://docs.google.com/presentation/d/1DHp5d4BmlPMCn8sRQWdre6s8zz5_o4JWEL9voTrm1Fc/edit?usp=sharing (abhijitkumbhare, 16:07:22)
    5. #project genius (shague, 16:07:44)

  4. ODL Parent (skitt, 16:09:01)
    1. https://gerrit.linuxfoundation.org/infra/#/c/11139/ new project LFN induction process/lifecycle/principles docs passed TAC vote (dfarrell07, 16:09:21)
    2. https://gerrit.linuxfoundation.org/infra/#/c/10545/ budget proposal passed TAC vote, but dfarrell07 thinks it's half-baked and will be rejected by the Board (dfarrell07, 16:09:49)
    3. https://wiki.opendaylight.org/view/Tech_Work_Stream:Main#Information_From_Past_Meetings (CaseyLF, 16:09:54)
    4. ODL Parent 3.1.3 released today, minor bump with Xtend Maven plugin fix (skitt, 16:10:58)
    5. ODL Parent 4 in preparation for Neon, projects needing features from ODL Parent should speak up now (skitt, 16:11:14)
    6. the big item in 4 is Mockito and PowerMock (skitt, 16:11:37)

  5. Action Items Checks (abhijitkumbhare, 16:12:16)
    1. Make a due date mandatory for TSC JIRA tickets which are grievances - next week (abhijitkumbhare, 16:12:51)
    2. Accessing CSIT debug environments - no progress yet (abhijitkumbhare, 16:13:26)
    3. CaseyLF following up with the LF staff - but no response yet (abhijitkumbhare, 16:13:49)

  6. Autorelease failures (abhijitkumbhare, 16:14:34)
    1. Maybe the autorelease failures related to something happening in the environment (abhijitkumbhare, 16:15:08)
    2. jamoluhrsen says it might be actually problems on the projects side (abhijitkumbhare, 16:16:34)
    3. shague says that the tests may need to be tweaked (abhijitkumbhare, 16:17:20)
    4. jamoluhrsen ran an autorelease job that did nothing (in the sandbox). the sysstats output did not show anything major and the build system really did seem to be totally idle (jamoluhrsen, 16:17:23)
    5. https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-merge-fluorine/ (jamoluhrsen, 16:18:52)
    6. The failures are hard to reproduce locally (abhijitkumbhare, 16:19:33)
    7. https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-merge-fluorine/218/org.opendaylight.bgpcep$odl-bgpcep-concepts/testReport/installFeatureCatchAndLog(org.opendaylight.odlparent.featuretest.SingleFeatureTest)[repoUrl_%20file__w_workspace_bgpcep-merge-fluorine_features_concepts_odl-bgpcep-concepts_target_feature_feature.xml,%20Feature_%20odl-bgpcep-concepts%200.10.0/SNAPSHOT]/installFeatureCatchAnd (jamoluhrsen, 16:19:54)
    8. It may be related to timing (abhijitkumbhare, 16:20:05)
    9. : https://git.opendaylight.org/gerrit/#/c/66714/ - bgpcep connetion handling patch (shague, 16:21:22)
    10. ACTION: zxiiro will try to get a single VM on Rackspace for a limited time and try to reproduce to isolate whether problems are due to Vexhost (abhijitkumbhare, 16:28:45)

  7. Release Dashboard (abhijitkumbhare, 16:29:03)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (abhijitkumbhare, 16:29:16)
    2. Weather Item TSC-128 (abhijitkumbhare, 16:30:24)
    3. https://jira.opendaylight.org/browse/TSC-128 (abhijitkumbhare, 16:30:30)
    4. odl-mdsal-models features is being removed (abhijitkumbhare, 16:31:43)
    5. This has been integrated and does speed up single feature tests (abhijitkumbhare, 16:32:41)
    6. Weather Item TSC-130 (abhijitkumbhare, 16:33:40)
    7. https://jira.opendaylight.org/browse/TSC-130 (abhijitkumbhare, 16:33:44)
    8. Generated unions will lose getValue() and char[] constructor (abhijitkumbhare, 16:34:02)
    9. Weather TSC-114 (abhijitkumbhare, 16:37:49)
    10. https://jira.opendaylight.org/browse/TSC-114 (abhijitkumbhare, 16:38:04)
    11. First list of patches merged - second list needs to be merged (abhijitkumbhare, 16:38:35)
    12. Grievance TSC-127 (abhijitkumbhare, 16:40:53)
    13. https://jira.opendaylight.org/browse/TSC-127 (abhijitkumbhare, 16:41:01)
    14. rovarga indicates that the turnaround for the patch was longer than expected (abhijitkumbhare, 16:41:46)

  8. Clustering (abhijitkumbhare, 16:46:50)
    1. jamoluhrsen requests someone to work on Controller-1742 (abhijitkumbhare, 16:49:14)
    2. MDSAL-362 maybe behind some other bugs like Controller-1848 (abhijitkumbhare, 16:52:21)
    3. Suggestion by rovarga is to consult with some Akka expert (abhijitkumbhare, 17:01:31)
    4. ACTION: rovarga to drive technically consultation with Akka expert (abhijitkumbhare, 17:03:14)
    5. ACTION: dfarrell07 to drive budget aspects within LFN for consultation with Akka expert (abhijitkumbhare, 17:04:00)


Meeting ended at 17:04:08 UTC (full logs).

Action items

  1. zxiiro will try to get a single VM on Rackspace for a limited time and try to reproduce to isolate whether problems are due to Vexhost
  2. rovarga to drive technically consultation with Akka expert
  3. dfarrell07 to drive budget aspects within LFN for consultation with Akka expert


Action items, by person

  1. dfarrell07
    1. dfarrell07 to drive budget aspects within LFN for consultation with Akka expert
  2. rovarga
    1. rovarga to drive technically consultation with Akka expert
  3. zxiiro
    1. zxiiro will try to get a single VM on Rackspace for a limited time and try to reproduce to isolate whether problems are due to Vexhost


People present (lines said)

  1. abhijitkumbhare (40)
  2. skitt (13)
  3. jamoluhrsen (11)
  4. CaseyLF (9)
  5. rovarga (6)
  6. dfarrell07 (6)
  7. odl_meetbot (5)
  8. shague (4)
  9. anipbu (3)
  10. gzhao (2)
  11. bjohnson (2)
  12. jhershbe (2)
  13. LuisGomez (2)
  14. lori (2)
  15. vishnoianil (2)
  16. ScottMelton (1)
  17. vthapar (1)
  18. Claudio (1)
  19. aadam (1)
  20. zxiiro (1)


Generated by MeetBot 0.1.4.