#opendaylight-meeting: tsc

Meeting started by CaseyLF at 15:56:29 UTC (full logs).

Meeting summary

  1. Agenda Bashing (CaseyLF, 15:59:33)
    1. anipbu (anipbu, 16:01:49)
    2. rovarga (rovarga, 16:01:54)
    3. jhershbe (jhershbe, 16:01:58)
    4. Brady Johnson (bradyjohnson, 16:01:58)
    5. shague (shague, 16:02:00)
    6. Daniel Farrell for Stephen Kitt (dfarrell07, 16:02:01)
    7. jamoluhrsen (jamoluhrsen, 16:02:22)
    8. #project netvirt ovsdb (shague, 16:02:55)
    9. https://wiki.opendaylight.org/view/Events:Neon_Dev_Forum DDF Agenda (CaseyLF, 16:03:47)
    10. lori (lori, 16:03:49)
    11. Thanh Ha (zxiiro, 16:04:30)
    12. gzhao proxy (anipbu, 16:04:57)
    13. abhijitkumbhare (abhijitkumbhare, 16:05:54)

  2. Releases (abhijitkumbhare, 16:07:24)
  3. Fluorine (abhijitkumbhare, 16:07:42)
  4. Oxygen (abhijitkumbhare, 16:07:58)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 (faseelak, 16:08:40)
    2. aadam updates that there are still more projects left for Sign Off (faseelak, 16:09:03)
    3. netconf and controller sign-offs missing (dfarrell07, 16:09:24)
    4. tomp says there haven't been many changes to controller, I guess implying that risk the failure is problem is low (dfarrell07, 16:13:16)
    5. pantelis updates that if all the downstream projects have signed off, controller is good too (faseelak, 16:13:22)
    6. VOTE: Voted on "Does the ODL TSC approve the Oxygen 08-06 build to be Oxygen SR3 for release?" Results are, +1: 10 (abhijitkumbhare, 16:15:15)
    7. faseelak vote was a proxy for Anil Vishnoi (abhijitkumbhare, 16:15:37)
    8. Oxygen SR3 has been approved for release (rovarga, 16:16:07)

  5. Fluorine (abhijitkumbhare, 16:17:10)
    1. stable/fluorine branch cut is done (faseelak, 16:17:36)
    2. https://github.com/openstack-infra/meetbot/blob/master/ircmeeting/meeting.py#L576 (zxiiro, 16:17:53)
    3. Anil Vishnoi (vishnoianil, 16:18:27)
    4. Anil Vishnoi (On behalf of Luis Gomez) (vishnoianil, 16:18:50)
    5. rovarga says for some reason in the release dashboard, we dont see odlparent upcoming releases (faseelak, 16:19:41)
    6. aadam says we have not added it yet, and asks for inputs on the milestones to be sent to him (faseelak, 16:20:24)
    7. https://docs.opendaylight.org/en/latest/release-process/release-schedule.html release schedule (dfarrell07, 16:21:20)
    8. "OpenDaylight releases twice per year on a 6 month cadence. These releases are scheduled for September 7th and March 7th" (jamoluhrsen, 16:21:36)
    9. need to make explicit dates for neon, following template schedule above (dfarrell07, 16:22:48)
    10. we also need to make it clear in the relmang docs that tsc needs to approve release plan by branch cutting (dfarrell07, 16:23:16)
    11. rovarga thinks TSC should vote on each release plan, sign-off on it, even if may be fairly mechanical copy+paste from last release (dfarrell07, 16:24:26)
    12. abhijitkumbhare suggests defaulting to always doing the template, only voting if we want to change something (dfarrell07, 16:25:16)
    13. aadams thinks most important point is that we need to make branch-cutting time more clear, that it's basically the start of neon (dfarrell07, 16:25:51)
    14. ACTION: dfarrell07 and zxiiro to branch docs, add neon exact dates to release schedule (dfarrell07, 16:27:52)
    15. ACTION: aadam to input exact dates for neon into jira for milestones on dashboard (dfarrell07, 16:28:21)
    16. some discussion about if we need to vote on copying schedule forward or if should be automatic (dfarrell07, 16:29:06)
    17. bug scrubbing for fluorine (dfarrell07, 16:32:49)
    18. ACTION: OPENFLOWPLUG-1028 Anil to review the patch which is up for review (faseelak, 16:34:13)

  6. Grievances (faseelak, 16:35:29)
    1. anilvishnoi says TSC-74 was added to see if the situation betters if we have more committers on BGPCEP (faseelak, 16:36:08)
    2. rovarga says if the situation requires, he is ready to step up (faseelak, 16:36:32)
    3. vishnoianil is concerned that there are only 1 or 2 active people for BGPCEP, wants to make sure project is healthy since it's Managed (dfarrell07, 16:36:45)
    4. aadam asks if there is anyone who actually has cycles/desire to step up and contribute (dfarrell07, 16:37:24)
    5. rovarga points out that it really amounts to if downstream stakeholders think bgpcep is important, allocate cycles (dfarrell07, 16:38:45)
    6. I am currently also working on BGPCEP full-time, still getting familiar with project itself but in time I can step in as commiter if situation requires it (mperina, 16:42:52)

  7. Technical announcement for release (abhijitkumbhare, 16:47:07)
    1. Lisa says that current press releases are & should be focused toward the users (abhijitkumbhare, 16:48:17)
    2. The vehicle for technical update would be a blog about the release (abhijitkumbhare, 16:48:41)
    3. https://docs.opendaylight.org/en/stable-oxygen/release-process/managed-release.html#final-checkpoint final checkpoint docs, please start on marketing blurb in final checkpoint jira (dfarrell07, 16:56:33)

  8. ODL SW quality metrics (abhijitkumbhare, 16:57:38)
    1. This was presented at DDF, in the TWS over email threads (abhijitkumbhare, 16:58:34)
    2. Current thought is for now start with checkstyle and findbugs (abhijitkumbhare, 16:58:56)
    3. https://docs.google.com/presentation/d/134O2NKS00SyTq4RziqFfJQfXc7C_MskfcZH7R3rYHF4/edit#slide=id.g35bfb30282_0_0 SW Quality improvements preso (bradyjohnson, 16:59:21)

  9. Cookies (abhijitkumbhare, 17:05:33)


Meeting ended at 17:05:44 UTC (full logs).

Action items

  1. dfarrell07 and zxiiro to branch docs, add neon exact dates to release schedule
  2. aadam to input exact dates for neon into jira for milestones on dashboard
  3. OPENFLOWPLUG-1028 Anil to review the patch which is up for review


Action items, by person

  1. dfarrell07
    1. dfarrell07 and zxiiro to branch docs, add neon exact dates to release schedule
  2. zxiiro
    1. dfarrell07 and zxiiro to branch docs, add neon exact dates to release schedule
  3. UNASSIGNED
    1. aadam to input exact dates for neon into jira for milestones on dashboard
    2. OPENFLOWPLUG-1028 Anil to review the patch which is up for review


People present (lines said)

  1. dfarrell07 (24)
  2. abhijitkumbhare (21)
  3. faseelak (17)
  4. rovarga (16)
  5. jamoluhrsen (12)
  6. bradyjohnson (9)
  7. odl_meetbot (9)
  8. zxiiro (7)
  9. anipbu (4)
  10. CaseyLF (4)
  11. vishnoianil (4)
  12. shague (3)
  13. lori (3)
  14. jhershbe (2)
  15. abelur (2)
  16. mperina (2)
  17. vorburger (1)


Generated by MeetBot 0.1.4.