#opendaylight-meeting: tsc

Meeting started by skitt at 15:59:55 UTC (full logs).

Meeting summary

  1. Rollcall and agenda-bashing (skitt, 16:00:25)
    1. agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:00:37)
    2. TSC members, please #info in (skitt, 16:00:48)
    3. rovarga (rovarga, 16:00:55)
    4. Project representatives, please #project in (skitt, 16:01:04)
    5. skitt (skitt, 16:01:06)
    6. Thanh Ha (zxiiro, 16:01:30)
    7. abhijit (skitt, 16:02:17)
    8. jhershbe (jhershbe, 16:02:18)
    9. jamoluhrsen (jamoluhrsen, 16:03:12)
    10. abhijitkumbhare (abhijitkumbhare, 16:03:46)
    11. LuisGomez (LuisGomez, 16:04:01)
    12. shague (shague, 16:04:16)

  2. Fluorine release candidate discussion (skitt, 16:05:00)
    1. #project netvirt serviceutils ovsdb genius (shague, 16:05:09)
    2. there's been discussion on the mailing list about when to cut the release candidate (skitt, 16:06:27)
    3. we already have an autorelease build since autorelease has been stable for a long time (skitt, 16:07:39)
    4. since we have no blocking bugs, there should be no changes in the release candidate except for self-managed projects (skitt, 16:08:01)
    5. we're currently leaning towards an RC date of August 23rd (skitt, 16:09:19)
    6. which leaves a week for projects to test and sign off (skitt, 16:09:31)
    7. any change would require a new autorelease build and new sign-offs (skitt, 16:09:46)
    8. if a self-managed project finds a blocking bug, the fix will have to wait until the next SR (skitt, 16:10:18)
    9. adding self-managed projects doesn't change the base artifact (skitt, 16:10:54)
    10. self-managed projects have a week to test against autorelease (skitt, 16:12:05)
    11. anything found after the 23rd would require discussion: do we slip the release, or do we fix in the first SR (skitt, 16:12:23)
    12. with a strong preference for postponing since projects have had time to test (skitt, 16:14:28)
    13. we need a release candidate build with artifacts now (skitt, 16:20:05)
    14. then projects sign off on that (skitt, 16:20:10)
    15. then we release it (August 23rd or earlier) (skitt, 16:20:18)
    16. then self-managed projects bump their dependencies to use it (skitt, 16:20:28)
    17. then they release, and we build the full distribution (skitt, 16:20:45)
    18. ACTION: LuisGomez to check the managed project documentation to make sure it documents the steps involved in a release (skitt, 16:22:41)
    19. VOTE: Voted on "The first Fluorine release candidate will be signed off by August 23rd?" Results are, +1: 8 (skitt, 16:23:05)
    20. https://docs.google.com/document/d/18DNhtuX0673l2yHhbNNkfEGWmZxDC8JxPo1Nyp-X17M/edit#heading=h.mlqhpi9q6t8r (abhijitkumbhare, 16:24:07)
    21. all projects need to document the improvements that are going into Fluorine (skitt, 16:24:57)
    22. and flag those which users should care about (skitt, 16:25:09)
    23. document listing the changes: https://docs.google.com/document/d/18DNhtuX0673l2yHhbNNkfEGWmZxDC8JxPo1Nyp-X17M/edit#heading=h.mlqhpi9q6t8r (skitt, 16:25:31)
    24. there will be a TWS session around marketing soon (skitt, 16:30:14)
    25. ACTION: CaseyLF to follow up with Lisa about marketing concerns (how to gather data, what's relevant etc.) (skitt, 16:33:11)
    26. the marketing group are looking for people to help them (skitt, 16:34:43)

  3. Release dashboard (skitt, 16:34:53)
    1. the overall trend is positive, autorelease is stable (skitt, 16:35:29)
    2. aadam_ manually added milestones for the next three months (skitt, 16:35:45)
    3. two blocker bugs currently (skitt, 16:36:08)
    4. MDSAL-362 is 70% done according to rovarga (skitt, 16:36:19)
    5. rovarga will need someone to run CSIT with the candidate fix, jamoluhrsen agreed to take care of that (skitt, 16:36:59)
    6. abhijitkumbhare thanks aadam_ for all his work herding people to get the release done (skitt, 16:37:15)
    7. OPNFLWPLUG-1028 is ready to go, already merged on Oxygen, waiting for a +2 on Fluorine (skitt, 16:37:56)

  4. Clustering (abhijitkumbhare, 16:40:02)
    1. CONTROLLER-1742 waiting for jamoluhrsen to dig up some logs and give them to rovarga (skitt, 16:40:33)
    2. CONTROLLER-1858 has no update, there have been attempts to get more debugging info but the job doesn't fail when run with extra output (so far) (skitt, 16:41:13)
    3. CONTROLLER-1849 is waiting for jamoluhrsen to look into Artery (skitt, 16:41:28)
    4. CONTROLLER-1790 might be a duplicate of 1849, jamoluhrsen needs to check (skitt, 16:41:42)
    5. NETVIRT-1324 is waiting for shague to get better logs (skitt, 16:42:05)
    6. NETVIRT-1015 might be a duplicate of 1849 again, jamoluhrsen needs to check (skitt, 16:42:30)
    7. OPNFLWPLUG-1022 needs action from vishnoianil (skitt, 16:42:49)
    8. ACTION: LuisGomez to prod Anil regarding OPNFLWPLUG-1022 (skitt, 16:43:08)
    9. CONTROLLER-1788 is waiting for shague to check whether it still happens (skitt, 16:43:35)
    10. NETVIRT-1027 is an issue in IPv6 land, waiting for more info (skitt, 16:44:03)
    11. NETVIRT-1395 has patches in progress, might be fixed in a week or so (skitt, 16:44:36)

  5. Neon calendar (skitt, 16:48:03)
    1. dfarrell07 has submitted a patch to duplicate the Fluorine release plan as the Neon release plan (skitt, 16:48:22)
    2. https://git.opendaylight.org/gerrit/#/c/75111/ (dfarrell07, 16:48:25)
    3. candidate Neon release plan: https://git.opendaylight.org/gerrit/75111 (skitt, 16:48:54)
    4. anipbu (anipbu, 16:50:41)
    5. gzhao (proxy) (anipbu, 16:50:56)
    6. all interested parties should vote on Gerrit (skitt, 16:51:11)
    7. (after dfarrell07 updates the patch and sends an email requesting reviews) (skitt, 16:51:31)

  6. Marketing (skitt, 16:52:35)
    1. abhijitkumbhare invites all project reps and PTLs to attend next Monday's TWS (skitt, 16:54:04)
    2. the session will address release planning as well as developer onboarding etc. (skitt, 16:54:22)
    3. for 2H18 the marketing group is working on determining our primary market/audience (skitt, 16:56:21)
    4. measuring traction in primary markets (skitt, 16:56:39)
    5. (numbers of real users, downloads, external press coverage) (skitt, 16:57:05)
    6. analysing community health stats (numbers of current contributors, their diversity, number of commercial products built on ODL) (skitt, 16:57:34)
    7. for 2019: what's our top priority, what adjacent techs are relevant, what are our top barriers, what are our top dev priorities (skitt, 17:00:20)
    8. Martin (our marketing liaison) will participate in TSC calls weekly from now on (skitt, 17:02:27)

  7. Cookies (skitt, 17:03:37)


Meeting ended at 17:03:44 UTC (full logs).

Action items

  1. LuisGomez to check the managed project documentation to make sure it documents the steps involved in a release
  2. CaseyLF to follow up with Lisa about marketing concerns (how to gather data, what's relevant etc.)
  3. LuisGomez to prod Anil regarding OPNFLWPLUG-1022


Action items, by person

  1. LuisGomez
    1. LuisGomez to check the managed project documentation to make sure it documents the steps involved in a release
    2. LuisGomez to prod Anil regarding OPNFLWPLUG-1022


People present (lines said)

  1. skitt (79)
  2. odl_meetbot (10)
  3. abhijitkumbhare (6)
  4. rovarga (3)
  5. shague (3)
  6. jhershbe (3)
  7. anipbu (3)
  8. aadam_ (3)
  9. pantelis (2)
  10. LuisGomez (2)
  11. dfarrell07 (2)
  12. jamoluhrsen (2)
  13. zxiiro (2)
  14. faseelak (1)
  15. abelur (1)


Generated by MeetBot 0.1.4.