#opendaylight-meeting: tsc

Meeting started by skitt at 16:01:11 UTC (full logs).

Meeting summary

  1. Roll-call and agenda-bashing (skitt, 16:01:20)
    1. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:01:40)
    2. skitt (skitt, 16:01:43)
    3. anipbu (anipbu, 16:01:45)
    4. gzhao (anipbu, 16:02:29)
    5. Thanh Ha (zxiiro, 16:02:42)
    6. rovarga (rovarga, 16:02:47)
    7. faseelak proxy for Abhijit (faseelak, 16:03:22)
    8. jamoluhrsen (jamoluhrsen, 16:03:30)

  2. Impromptu infrastructure update (skitt, 16:03:32)
    1. we need to disable all our CLM jobs (skitt, 16:03:41)
    2. we found out that the way we use the jobs doesn't respect Sonatype's ToS (skitt, 16:04:01)
    3. LuisGomez (LuisGomez, 16:04:25)
    4. vina_ermagan (vina_ermagan_, 16:04:41)
    5. Anil Vishnoi (vishnoianil_, 16:04:56)
    6. vina_ermagan proxy for lori (vina_ermagan_, 16:05:17)
    7. gzhao (gzhao, 16:06:16)

  3. Action items (skitt, 16:07:53)
    1. LuisGomez provided a patch for the managed project documentation to document the steps involved in a release (skitt, 16:08:20)
    2. https://git.opendaylight.org/gerrit/#/c/75312/ (LuisGomez, 16:08:24)
    3. CaseyLF followed up with Lisa re marketing concerns, Lisa will join the call in a few minutes (skitt, 16:09:23)
    4. OPNFLWPLUG-1022 has a fix which is merged (skitt, 16:09:57)

  4. ODL Parent updates (skitt, 16:10:21)
    1. ODL Parent 4 is nearly ready, waiting for a Karaf release and a couple of bug fixes (skitt, 16:10:36)
    2. YANG Tools is ready for Neon, MD-SAL is 50% there (skitt, 16:10:48)
    3. the integration window patches for kernel projects are in progress (skitt, 16:11:06)

  5. ONAP CVE reports (skitt, 16:11:39)
    1. apparently some of our third-party tooling has open CVEs (skitt, 16:12:11)
    2. but more importantly, CaseyLF would like us to formalise security relationships with our sister communities (skitt, 16:12:56)
    3. our vulnerability management process: https://wiki.opendaylight.org/view/Security:Vulnerability_Management (skitt, 16:15:09)
    4. the conversation started because ONAP is shooting for silver CII and needs security issues reported in CLM to be resolved in ODL (skitt, 16:17:37)
    5. shague (shague, 16:18:29)
    6. realistically, ONAP can get silver CII only if ODL gets it too, which means investment on our end, hopefully with help from ONAP (skitt, 16:18:34)
    7. CaseyLF thinks our CLM reports might be different, which would explain why ONAP sees more issues than we do (skitt, 16:20:31)
    8. other LFN projects share a CLM instance, we have our own (skitt, 16:21:30)
    9. ACTION: zxiiro to open a bug to migrate our CLM instance to the shared infra (skitt, 16:22:25)
    10. so far the security team aren't aware of this discussion with ONAP (skitt, 16:26:33)

  6. Update on SSH/VM access (skitt, 16:26:49)
    1. there's a workaround to get SSH access to VMs (skitt, 16:27:16)
    2. apparently the LF hasn't offered SSH access in the past because of an OpenStack bug (skitt, 16:27:39)
    3. once that's dealt with we'll be able to have SSH access (skitt, 16:28:36)

  7. Release dashboard (skitt, 16:28:48)
    1. today is the Fluorine final checkpoint (skitt, 16:29:10)
    2. ACTION: aadam to find a way to identify the releases affected by MRI blocker bugs (skitt, 16:30:17)
    3. Fluorine autorelease is looking good (skitt, 16:30:53)
    4. the release integration window starts on September 7 (skitt, 16:34:13)
    5. for Neon, the affected projects are ODL Parent, YANG Tools and MD-SAL (skitt, 16:34:43)
    6. they should all be ready by September 7 and we’ll have a fair idea of the amount of work involved to integrate (skitt, 16:35:00)

  8. Clustering (skitt, 16:36:44)
    1. CONTROLLER-1742 might be fixed (skitt, 16:36:51)
    2. CONTROLLER-1858 needs more debugging info, which will take some time (skitt, 16:37:31)
    3. CONTROLLER-1849 involves using Artery in a three-node cluster, and jamoluhrsen might be the first person on earth to try this (skitt, 16:37:50)
    4. jamoluhrsen needs an Artery and Docker and Linux shared memory expert to help him out with this issue (skitt, 16:39:07)
    5. OPNFLWPLUG-1022 should be fixed, but there's a CSIT issue to fix too (skitt, 16:39:59)
    6. ACTION: vishnoianil_ to update OPNFLWPLUG-1022 (skitt, 16:40:36)
    7. NETVIRT-1015 might correspond to expected messages since the test involves killing two nodes (skitt, 16:43:24)
    8. the key question is how to monitor a cluster (skitt, 16:44:07)
    9. ACTION: shague to downgrade NETVIRT-1015 (skitt, 16:46:29)

  9. Addressing CSIT at the start of a release (skitt, 16:47:36)
    1. aadam thinks that now that we've stabilised autorelease, we should address issues in our CSIT (skitt, 16:48:07)
    2. rovarga fears removing tests; if we end up disabling tests, we need some workflow to ensure they're re-enabled (skitt, 16:49:21)
    3. any lost test coverage will come back as bug reports later (skitt, 16:49:37)
    4. shague thinks we need to identify those tests which never pass and are always signed off on (skitt, 16:50:24)
    5. there are tests which haven't passed in two years (skitt, 16:50:33)
    6. those probably don't have much value at all (skitt, 16:50:46)
    7. if we end up removing all the tests for a project, that will have to be addressed by a system test waiver (skitt, 16:51:22)
    8. vishnoianil_ suggests opening a JIRA every time a test is removed or disabled (skitt, 16:52:13)
    9. LuisGomez suggests running two test jobs, one with only known-good tests to spot regressions, the other with all tests (skitt, 16:53:10)

  10. Marketing (skitt, 16:55:38)
    1. ODL 2019 planning notes for marketing: https://docs.google.com/document/d/10JQ2CkUX11Mr-64g0ugu6J18uR24LALYpmSzdRpzlf8/edit?usp=drive_web (skitt, 16:56:53)
    2. the marketing teams wants to understand what the project goals are for 2019, where the project is expected to focus (skitt, 16:57:26)
    3. both in technical terms and marketing terms (new verticals etc.) (skitt, 16:57:38)
    4. without input from the TSC, marketing will use its best guesses (skitt, 16:57:59)
    5. the document needs to be completed by the end of August (skitt, 16:58:13)
    6. ACTION: CaseyLF to send an email to the TSC list reminding everyone that the planning document needs to be completed (skitt, 16:58:47)
    7. the important aspect is the goals, tactics can be addressed later (skitt, 16:59:30)
    8. next Monday’s TWS will be dedicated to this (skitt, 16:59:39)

  11. CLM (skitt, 16:59:54)
    1. there is no migration path if we migrate to the shared LFN system, so if we migrate we'll lose our history (skitt, 17:00:12)
    2. zxiiro sent an email to the mailing list (skitt, 17:00:19)

  12. Cookies (skitt, 17:00:33)


Meeting ended at 17:00:36 UTC (full logs).

Action items

  1. zxiiro to open a bug to migrate our CLM instance to the shared infra
  2. aadam to find a way to identify the releases affected by MRI blocker bugs
  3. vishnoianil_ to update OPNFLWPLUG-1022
  4. shague to downgrade NETVIRT-1015
  5. CaseyLF to send an email to the TSC list reminding everyone that the planning document needs to be completed


Action items, by person

  1. aadam
    1. aadam to find a way to identify the releases affected by MRI blocker bugs
  2. CaseyLF
    1. CaseyLF to send an email to the TSC list reminding everyone that the planning document needs to be completed
  3. shague
    1. shague to downgrade NETVIRT-1015
  4. vishnoianil_
    1. vishnoianil_ to update OPNFLWPLUG-1022
  5. zxiiro
    1. zxiiro to open a bug to migrate our CLM instance to the shared infra


People present (lines said)

  1. skitt (82)
  2. rovarga (6)
  3. odl_meetbot (5)
  4. CaseyLF (4)
  5. vina_ermagan_ (3)
  6. anipbu (3)
  7. LuisGomez (3)
  8. zxiiro (3)
  9. vishnoianil_ (2)
  10. faseelak (2)
  11. jamoluhrsen (2)
  12. shague (2)
  13. gzhao (1)
  14. aadam (1)


Generated by MeetBot 0.1.4.