#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 16:01:01 UTC (full logs).

Meeting summary

  1. Roll-call and agenda-bashing (skitt, 16:02:30)
    1. TSC members please #info in (skitt, 16:02:35)
    2. Project reps please #project in (skitt, 16:02:42)
    3. lori (lori, 16:02:44)
    4. skitt (skitt, 16:02:44)
    5. Brady Johnson (bradyjohnson, 16:02:50)
    6. shague (shague, 16:03:17)
    7. LuisGomez (LuisGomez, 16:03:23)
    8. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (somewhat outdated) (skitt, 16:03:34)
    9. shague #project netvirt odltools serviceutils (shague, 16:03:52)
    10. anipbu (anipbu, 16:04:34)
    11. rovarga (rovarga_, 16:06:12)
    12. jamoluhrsen (jamoluhrsen, 16:06:47)
    13. Anil Vishnoi (vishnoianil, 16:07:43)
    14. The nomination period for the TSC elections will start on Nov 1st (skitt, 16:10:32)

  2. Dashboards (skitt, 16:10:42)
    1. ACTION: aadam_ to go over the list of project plans to identify projects which haven’t filed one yet (skitt, 16:15:43)
    2. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon/58/dependencies.log.gz (jamoluhrsen, 16:16:45)
    3. ACTION: jamoluhrsen to send aadam_ a simple list of all the projects we expect to see there (skitt, 16:17:00)
    4. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/autorelease-release-neon/58/dependencies.log.gz <-- autorelease file showing what we have "in code" as our managed release projects (jamoluhrsen, 16:17:05)
    5. Neon MRI is looking good (skitt, 16:18:37)
    6. discussion about preparing all MRI version bump patches for all MR projects and getting multipatch working (dfarrell07, 16:24:31)
    7. we have two possible approaches to merging: (1) start merging patches is dependency order whenever the next project in the queue is ready, breaking everyone until all patches are merged (lori, 16:24:51)
    8. there is trade-off between rebasing MRI version bump patches, keeping them working and multipatch passing as world changes under (dfarrell07, 16:24:56)
    9. (2) wait for a successful multipatch job and give releng the superpower to merge all patches (lori, 16:25:15)
    10. but by preparing all the patches before starting merge, there less not a large "break the world" window (dfarrell07, 16:25:25)
    11. for option (1) we would have a two-week window for merging all patches (lori, 16:26:07)
    12. the design of the MR is to accept breakage in this two week window (dfarrell07, 16:26:13)
    13. vorburger thinks it's hard to vote to accept a base if we don't know what problems it will bring (dfarrell07, 16:26:36)
    14. not-ready MRI patch projects: ovsdb, openflowplugin, genius, netvirt (dfarrell07, 16:41:23)

  3. Clustering (skitt, 16:45:45)
    1. ACTION: jamoluhrsen to look at validating CONTROLLER-1746 (jamoluhrsen, 16:45:53)
    2. CONTROLLER-1746 should be fixed (skitt, 16:45:56)
    3. ACTION: jamoluhrsen to check whether CONTROLLER-1746 is resolved (skitt, 16:46:18)

  4. Budgeting (skitt, 16:53:23)
    1. LFN is budgeting for 2019 (skitt, 16:53:51)
    2. we need to decide what we need budget for (other than recurring stuff such as infra) (skitt, 16:54:13)
    3. items such as specific events, hiring interns... (skitt, 16:54:22)

  5. Cookies (skitt, 17:03:13)


Meeting ended at 17:03:16 UTC (full logs).

Action items

  1. aadam_ to go over the list of project plans to identify projects which haven’t filed one yet
  2. jamoluhrsen to send aadam_ a simple list of all the projects we expect to see there
  3. jamoluhrsen to look at validating CONTROLLER-1746
  4. jamoluhrsen to check whether CONTROLLER-1746 is resolved


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send aadam_ a simple list of all the projects we expect to see there
    2. jamoluhrsen to look at validating CONTROLLER-1746
    3. jamoluhrsen to check whether CONTROLLER-1746 is resolved


People present (lines said)

  1. skitt (22)
  2. dfarrell07 (11)
  3. bradyjohnson (7)
  4. jamoluhrsen (7)
  5. vorburger (6)
  6. odl_meetbot (6)
  7. lori (5)
  8. LuisGomez (4)
  9. rovarga_ (4)
  10. shague (2)
  11. anipbu (2)
  12. vishnoianil (2)
  13. mperina (1)
  14. jmorvay (1)
  15. abhijitk (0)
  16. CaseyLF (0)


Generated by MeetBot 0.1.4.