#opendaylight-meeting: tsc

Meeting started by skitt at 15:59:34 UTC (full logs).

Meeting summary

  1. Roll-call and agenda-bashing (skitt, 15:59:59)
    1. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:00:07)
    2. Last week's minutes: https://meetings.opendaylight.org/opendaylight-meeting/2018/tsc/opendaylight-meeting-tsc.2018-10-11-16.00.html (skitt, 16:00:23)
    3. TSC members, please #info in (skitt, 16:00:32)
    4. Project representatives, please #project in (skitt, 16:00:39)
    5. Brady Johnson (bradyjohnson, 16:01:25)
    6. gzhao (gzhao, 16:01:27)
    7. anipbu (anipbu, 16:02:18)
    8. skitt (skitt, 16:02:19)
    9. rovarga (rovarga, 16:02:20)
    10. shague (shague, 16:03:04)
    11. Anil Vishnoi (vishnoianil, 16:03:33)
    12. shague #project serviceutils neutron genius (shague, 16:03:53)
    13. jmorvay (jmorvay, 16:04:56)
    14. LuisGomez (LuisGomez, 16:04:57)

  2. Neon MRI (dfarrell07, 16:06:19)
    1. skitt reports ongong fixes going in, currently in NetVirt, most projects passing unit tests, CSIT looking okay except for that NetVirt issue, maybe can start merging now (dfarrell07, 16:07:04)
    2. Thanh (zxiiro, 16:07:16)
    3. LuisGomez asks about link for tests (dfarrell07, 16:08:06)
    4. MRI jobs: https://jenkins.opendaylight.org/releng/view/integration/job/integration-multipatch-test-neon/ (skitt, 16:08:16)
    5. jamoluhrsen (jamoluhrsen, 16:08:43)
    6. folks digging into jobs (dfarrell07, 16:10:01)

  3. release dashboard (dfarrell07, 16:12:28)
    1. we missed Fluorine SR1 because milestone Jira didn't exist, wasn't on dashboard (dfarrell07, 16:12:49)
    2. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 rel dashboard (dfarrell07, 16:12:56)
    3. discussion about when to code freeze fluorine (dfarrell07, 16:13:12)
    4. rovarga says we need odlparent 3.1.4, and about one more day for yangtools after that (dfarrell07, 16:13:34)
    5. so rovarga says code freeze could be saturday, but working on the weekend sucks, so next week (dfarrell07, 16:13:52)
    6. odlparent release has security fixes says robert, maybe should have (dfarrell07, 16:14:23)
    7. abhijitk (abhijitk, 16:14:47)
    8. jackson update is security issue rovarga was talking about (dfarrell07, 16:15:00)
    9. https://git.opendaylight.org/gerrit/#/c/77056/ (rovarga, 16:15:06)
    10. skitt isn't sure we're actually impacted by these jackson problems, but good to not have red flags anyway (dfarrell07, 16:16:02)
    11. Fluorine SR2 is early december, soonish (dfarrell07, 16:16:28)
    12. there are for sure users of jackson, like Neutron, that will have trouble checking if impacted (because Michael is on PTO) (dfarrell07, 16:17:06)
    13. so maybe better to assume we're impacted (dfarrell07, 16:17:14)
    14. we also want this update for Oxygen SR4 says robert (dfarrell07, 16:17:47)
    15. skitt has a multipatch job running now, if passes he will release 3.1.4, then releng must promote, then yangtools does same (dfarrell07, 16:19:03)
    16. best case this could be done tomorrow night (dfarrell07, 16:19:17)
    17. the odlparent 3.1.4 multipatch job: https://jenkins.opendaylight.org/releng/job/integration-multipatch-test-fluorine/262/ (skitt, 16:19:27)
    18. shague and jamoluhrsen talk about a blocker bug e/// folks are working on, hope to have in today (dfarrell07, 16:21:16)
    19. AGREED: will will try to get odlparent 3.1.4 and subsequent MRI versions into Fluorine SR1, so we will delay code freeze until early next week (Monday), then review/bless/promote next autorelease (dfarrell07, 16:21:44)

  4. Clustering (abhijitk, 16:23:27)
    1. jamoluhrsen gives update about clustering, says controller clustering effrot wasn't making progress so moving on to netvirt, there are open bugs on dashboard (dfarrell07, 16:23:51)

  5. Turning off failing CI tests (abhijitk, 16:26:45)
    1. LuisGomez still working on NetConf - taking more time (abhijitk, 16:27:27)
    2. LuisGomez working on find the pattern to turn off the tests (abhijitk, 16:28:46)
    3. there is a major lack of CI folks to do this work, can't really expect magic from jamoluhrsen and LuisGomez (dfarrell07, 16:30:01)
    4. https://jenkins.opendaylight.org/releng/view/CSIT/ CSIT results (dfarrell07, 16:31:47)
    5. lots of discussion about how to clean up tests (dfarrell07, 16:43:26)
    6. seem to want to have static list of tests we think are stable, make view in jenkins (dfarrell07, 16:44:14)
    7. ACTION: shague will make static list of jobs that normally pass into a view in jenkins (dfarrell07, 16:44:27)

  6. Cookies (abhijitk, 17:02:16)


Meeting ended at 17:02:23 UTC (full logs).

Action items

  1. shague will make static list of jobs that normally pass into a view in jenkins


Action items, by person

  1. shague
    1. shague will make static list of jobs that normally pass into a view in jenkins


People present (lines said)

  1. dfarrell07 (32)
  2. skitt (12)
  3. odl_meetbot (6)
  4. abhijitk (6)
  5. rovarga (5)
  6. LuisGomez (4)
  7. bradyjohnson (4)
  8. jamoluhrsen (4)
  9. shague (3)
  10. jmorvay (2)
  11. anipbu (2)
  12. vishnoianil (2)
  13. gzhao (1)
  14. zxiiro (1)
  15. mperina (1)
  16. CaseyLF (0)


Generated by MeetBot 0.1.4.