#opendaylight-meeting: tsc

Meeting started by CaseyLF at 16:59:53 UTC (full logs).

Meeting summary

    1. Thanh Ha (zxiiro, 17:00:33)
    2. lori (lori, 17:00:56)
    3. jamoluhrsen (jamoluhrsen, 17:01:00)
    4. anipbu (anipbu, 17:01:18)
    5. abhijitk (abhijitk, 17:01:26)
    6. skitt (skitt, 17:02:09)
    7. shague (shague, 17:03:18)
    8. shague #project netvirt serviceutils genius (shague, 17:03:45)
    9. Anil Vishnoi (vishnoianil, 17:04:02)
    10. thanks for all the great work over many years lisa! (dfarrell07, 17:04:41)
    11. lisa will be stepping down from LF marketing role, taking role in member company (dfarrell07, 17:05:00)
    12. discussions ongoing about next leadership of ODL marketing work group (dfarrell07, 17:05:18)
    13. LuisGomez (LuisGomez, 17:06:17)
    14. jmorvay (jmorvay, 17:08:40)
    15. tsc nomination period is half way through, ends next week (dfarrell07, 17:08:58)
    16. find the wiki and self nominate (dfarrell07, 17:09:12)
    17. https://wiki.opendaylight.org/view/TSC:2018_Election (skitt, 17:09:32)

  1. TSC election (abhijitk, 17:09:33)
    1. Reminder of self nominations for TSC 2019 election (abhijitk, 17:09:46)
    2. https://wiki.opendaylight.org/view/TSC:2018_Election (abhijitk, 17:09:57)
    3. rovarga (rovarga, 17:10:33)

  2. Release Updates (CaseyLF, 17:10:37)
    1. Fluorine SR1 (abhijitk, 17:12:21)
    2. VOTE: Voted on "Shall the TSC approve the build specified as Fluorine SR1?" Results are (dfarrell07, 17:13:51)
    3. https://docs.google.com/spreadsheets/d/1wtT78KigRQdRi3Gj--jOJJPI7tC4tIi5brmW01vvCsg/edit#gid=591778755 tracking spreadsheet for fl sr (dfarrell07, 17:14:00)
    4. https://jenkins.opendaylight.org/releng/job/autorelease-release-fluorine/260/ autorelase we're vetting as fl sr (dfarrell07, 17:14:19)
    5. https://nexus.opendaylight.org/content/repositories//autorelease-2463/org/opendaylight/integration/karaf/0.9.1/karaf-0.9.1.zip eact artifact we are evaluating (dfarrell07, 17:15:11)
    6. https://jenkins.opendaylight.org/releng/job/integration-distribution-test-fluorine/264/ distro test results (first ones failed due to infra) (dfarrell07, 17:15:37)
    7. VOTE: Voted on "Shall the TSC bless autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs?" Results are, +1: 8 (abhijitk, 17:18:26)
    8. AGREED: TSC blesses autorelease 260 as Fluorine SR1, assuming distro test results 264 get sign-offs (abhijitk, 17:19:11)

  3. ODL Licensing (EPL) and ONAP's (Apache 2.0) (abhijitk, 17:20:43)
  4. dlux (dfarrell07, 17:21:26)
    1. brain and ONAP give briefing on DLUX use in ONAP, that they were finding value from it, we deprecated it because no maintainers (dfarrell07, 17:21:28)
    2. discussion about how best to proceed, if should try to revive dlux vs use something new, and downsides of profliration of third party options if no first party option (dfarrell07, 17:22:08)
    3. rovarga talks about ODL's perspective that project is in this state because no on has stepped up to maintain it in ODL upstream, despite many calls from us for contributions (dfarrell07, 17:22:40)
    4. Martin from High Street small team working on DLUX, would be willing to be a part of the solution but may not be able to do all of it (dfarrell07, 17:23:28)
    5. Anil V points out that if we revive it, we need folks to stick around long-term to maintain it for consumers, else we will have to depreciate it again (dfarrell07, 17:24:09)
    6. anil gives summary of how we could revive dlux inside odl, by getting folks watching release list, making it a managed project and tracking it properly (dfarrell07, 17:24:43)
    7. Martin says they know this, have knowledge, have tech experience, but can't guarantee it could be maintained for long-term (dfarrell07, 17:25:29)
    8. detailed discussion about if it should be inside of ODL or out, managed or unmanaged, implications of all (dfarrell07, 17:32:14)
    9. dfarrell07 and brain talk about how might be better to start with newer UI framework vs saving old DLUX (dfarrell07, 17:32:34)
    10. robert talks about detailed implications regarding project GUIs, strucutre, etc (dfarrell07, 17:33:08)
    11. anil v as selfish TSC member would love to have some pretty pictures to show in demos, as we've always been told we're good but have boring demos ;) (dfarrell07, 17:33:43)
    12. takeaway is that we need to go figure out plan, tech bits that will be used, unmanged project (dfarrell07, 17:37:39)

  5. Ansible Project Proposal (abhijitk, 17:37:53)
    1. https://lists.opendaylight.org/pipermail/project-proposals/2018-October/000790.html (shague, 17:38:21)
    2. https://wiki.opendaylight.org/view/Project_Proposals:Ansible (shague, 17:38:30)
    3. https://docs.google.com/presentation/d/1RZWwhQ4Pl77zbQUB-QcvE3vWZVNs2tDnhBLcqa8hWeI/edit#slide=id.g434775e8d2_0_182 (shague, 17:44:17)
    4. anil asks about if logic is generic enough to add playbooks on sb and API on nb to do basically anything, not some specific use case (dfarrell07, 17:44:31)
    5. question about what protocol is used on SB, typically ansible uses SSH to get into any box (including switches) and the does local logic (dfarrell07, 17:45:08)
    6. question about why do this in ODL, answer is that this can be used for underlay mgmt on many devices (dfarrell07, 17:46:29)
    7. anil likes it a lot if it's not restricted to any use cases, able to be used by many for much (dfarrell07, 17:47:03)
    8. lori asks if this is only ansible or if it could be abstracted in some way to include things like chef or puppet (dfarrell07, 17:48:09)
    9. VOTE: Voted on "Shall the TSC approve the Ansible Project (inside OpenDaylight) as an OpenDaylight project?" Results are (dfarrell07, 17:49:11)
    10. VOTE: Voted on "Shall the TSC approve the Ansible project as an Incubation, Managed project?" Results are, +1: 9 (dfarrell07, 17:50:33)
    11. AGREED: actually *unmanaged*, not managed, dfarrell07 mistake (abhijitk, 17:51:17)

  6. Releases (abhijitk, 17:51:54)
    1. ACTION: shague will work with helpdesk to do code import, get committer rights (dfarrell07, 17:52:05)
    2. follow up with Steve Winslow via helpdesk about IPR, ansible project and shague (dfarrell07, 17:52:38)
    3. ariel proposes moving oxygen sr4 back a bit so it doesn't conflict with fluorine release next week (dfarrell07, 17:53:38)
    4. we still need to merge odlparent 3.1.4 into oxygen before sr (dfarrell07, 17:54:01)
    5. there are important bugfixes in 3.1.4, including security fixes, so we should take our time to make sure it has these fixes in (dfarrell07, 17:54:29)
    6. there are some patches, maybe netconf, that need to be backported before ready (dfarrell07, 17:54:51)
    7. nov 28th is new oxygen sr4 date (dfarrell07, 17:55:08)
    8. ACTION: skitt rovarga to work to get 3.1.4 odlparent into stable/oxygen (dfarrell07, 17:55:24)

  7. clustering (dfarrell07, 17:55:44)
    1. jamoluhrsen asks for more people to contribute cycles (dfarrell07, 17:55:54)
    2. there's a clustering bug that jamoluhrsen is having trouble setting fixed-in, basically we need versions for all the fl srs (dfarrell07, 17:56:52)
    3. ACTION: ariel to add fluorine-sr2 release tag in jira (jamoluhrsen, 17:57:09)
    4. ACTION: ariel to add all fluorine and maybe neon release tags in jira (dfarrell07, 17:57:31)

  8. cookies (dfarrell07, 17:58:21)


Meeting ended at 17:58:24 UTC (full logs).

Action items

  1. shague will work with helpdesk to do code import, get committer rights
  2. skitt rovarga to work to get 3.1.4 odlparent into stable/oxygen
  3. ariel to add fluorine-sr2 release tag in jira
  4. ariel to add all fluorine and maybe neon release tags in jira


Action items, by person

  1. rovarga
    1. skitt rovarga to work to get 3.1.4 odlparent into stable/oxygen
  2. shague
    1. shague will work with helpdesk to do code import, get committer rights
  3. skitt
    1. skitt rovarga to work to get 3.1.4 odlparent into stable/oxygen
  4. UNASSIGNED
    1. ariel to add fluorine-sr2 release tag in jira
    2. ariel to add all fluorine and maybe neon release tags in jira


People present (lines said)

  1. dfarrell07 (55)
  2. odl_meetbot (22)
  3. abhijitk (19)
  4. shague (8)
  5. skitt (7)
  6. CaseyLF (7)
  7. rovarga (4)
  8. anipbu (4)
  9. lori (4)
  10. jamoluhrsen (4)
  11. zxiiro (4)
  12. LuisGomez (3)
  13. jmorvay (2)
  14. vishnoianil (2)
  15. mperina (1)


Generated by MeetBot 0.1.4.