#opendaylight-meeting: tsc

Meeting started by skitt at 17:00:36 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 17:01:00)

  1. Roll-call and agenda-bashing (skitt, 17:01:01)
    1. TSC members please #info in (skitt, 17:01:07)
    2. Project representatives please #project in (skitt, 17:01:14)
    3. skitt (skitt, 17:01:17)
    4. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda Agenda (dfarrell07, 17:01:55)
    5. shague (shague, 17:02:16)
    6. Thanh ha (zxiiro, 17:02:52)
    7. shague #porject netvirt serviceutils odltools (shague, 17:02:55)
    8. vorburger (vorburger, 17:03:56)
    9. LuisGomez (LuisGomez, 17:05:34)
    10. anipbu (anipbu, 17:06:50)
    11. rovarga (rovarga_, 17:07:09)

  2. tsc election (dfarrell07, 17:07:30)
    1. confusion about when nominations end, wiki says yesterday utc midnight but casey says actually today 5pm pt (dfarrell07, 17:07:55)
    2. abhijitk (abhijitk, 17:08:38)
    3. discussion about the company cap (skitt, 17:10:54)
    4. given the smaller company involvement, the context has changed (skitt, 17:11:07)
    5. but rovarga_ points out we still want to avoid company dominance, which becomes easier as involvement shrinks (skitt, 17:11:39)
    6. dfarrell07 still thinks caps are a good thing and the current limit seems fair (skitt, 17:12:03)
    7. question regarding the necessity of voting if the number of nominees equals the number of seats in each category (skitt, 17:14:40)
    8. ACTION: CaseyLF to check with phrobb to determine whether a vote is actually required in these circumstances (skitt, 17:15:16)
    9. rovarga_ asks whether the lack of nominees reflects happiness with the current TSC composition or lack of volunteers (skitt, 17:17:02)
    10. if the latter, we may want to reduce the number of seats (skitt, 17:17:13)
    11. discussion about not being lots of competition for seats, reasons why (dfarrell07, 17:18:49)
    12. robert suggests options 1. folks are happy with tsc 2. not enough folks from community interested (dfarrell07, 17:19:24)
    13. dfarrell07 also thinks could be that folks are self-selecting for who would be best before nominations (dfarrell07, 17:19:48)

  3. Releases (skitt, 17:21:49)
    1. Fluorine SR1 is still not out (skitt, 17:22:37)
    2. jamo reports that there is candidate build with test results being signed off, about 75% done (dfarrell07, 17:23:26)
    3. see mailing lists for details (dfarrell07, 17:23:36)
    4. vorburger asks about some newish bugs in openflow plugin that might be blockers, if we want to consider (dfarrell07, 17:24:20)
    5. rovarga_ says we should just get this out, pick up next blockers in sr2 which can be quite soon (dfarrell07, 17:24:43)
    6. rovarga_ says waiting on branch to be unfrozen to merge lots of things that will make things better (dfarrell07, 17:24:58)
    7. rovarga_ says stuff vorburger found in openflowplugin is cluster* and should be fixed but not in sr1 (dfarrell07, 17:25:42)
    8. go sign off (dfarrell07, 17:25:52)
    9. oxygen sr4 is targeted for two weeks, week after thanksgiving (dfarrell07, 17:26:21)
    10. we don't have a meeting next week (dfarrell07, 17:26:30)
    11. oxygen sr4 now oxygen 29th in jira too (dfarrell07, 17:27:32)
    12. AGREED: we have passed the neon version bump and CSIT checkpoints, so the neon MRI artifacts are accepted (dfarrell07, 17:29:24)
    13. there are currently two blocking bugs (dfarrell07, 17:30:05)
    14. neutron-204 is a blocker on all branches (dfarrell07, 17:31:20)
    15. vorburger says there is a fix for neutron-204 and it just needs to get merged to all branches (dfarrell07, 17:31:47)
    16. other blocker is ovsdb-470, again there seems to be patches and they need to cherry-picked (dfarrell07, 17:33:14)
    17. skitt says patch or no patch ovsdb-470 isn't a blocker (dfarrell07, 17:33:28)
    18. ovsdb-470 changed from blocker to high (dfarrell07, 17:33:37)
    19. ACTION: vorburger to move NEUTRON-204 from Fluorine-SR1 to Fluorine-SR2 (vorburger, 17:33:48)
    20. ACTION: aadam to work on filters for relmang dashboard to not show done items (dfarrell07, 17:34:45)
    21. vorburger reports that archetype project needs help after neon mri, tomp says will help (dfarrell07, 17:35:27)
    22. ACTION: aadam to make sure https://jira.opendaylight.org/browse/SRVUTILS-4 which is Status Done does not show up on the Release dashboard Neon-MRI anymore (vorburger, 17:35:28)
    23. ACTION: tomp will take care of https://jira.opendaylight.org/browse/ARCH-3 (vorburger, 17:35:52)
    24. no clustering updates, says jamoluhrsen (dfarrell07, 17:35:53)
    25. rovarga_ reports that version bump for odlparent and yang tools is happening right now (dfarrell07, 17:36:19)
    26. ACTION: aadam will do fl retrospective after thanksgiving (dfarrell07, 17:36:52)

  4. Super committer (abhijitk, 17:39:40)
    1. https://git.opendaylight.org/gerrit/#/c/77837/ supercomitter patch (dfarrell07, 17:39:46)

  5. State of infra (abhijitk, 17:41:10)
    1. zxiiro reports they are digging in with vexxhost, lf infra people, starting today hard and will update (dfarrell07, 17:42:07)

  6. Pushing artifacts to Maven Central (abhijitk, 17:50:36)
    1. discussion about making sure we are trying to optimize infra cost, that we have process in place and are doing it, that we need to share infra costs more widely (with test/releng, not just tsc) (dfarrell07, 17:50:58)
    2. we're now ready to push artifacts to Maven Central (skitt, 17:51:09)
    3. the next step is to push a release of odlparent (skitt, 17:51:17)
    4. pushing historical artifacts to Maven Central is very tedious so it's not planned for now (skitt, 17:53:51)
    5. rovarga_ wants to make "push to Maven Central" a blocker: a release of odlparent etc. isn't complete if it's not on Maven Central (skitt, 17:54:28)
    6. rovarga_ also points out that we have historical artifacts which are difficult to republish, but that we may want to push to Maven Central (skitt, 17:54:47)
    7. not exactly what I meant, but it's fine :) (rovarga_, 17:54:58)
    8. such as adsal remnants (skitt, 17:54:58)


Meeting ended at 17:55:27 UTC (full logs).

Action items

  1. CaseyLF to check with phrobb to determine whether a vote is actually required in these circumstances
  2. vorburger to move NEUTRON-204 from Fluorine-SR1 to Fluorine-SR2
  3. aadam to work on filters for relmang dashboard to not show done items
  4. aadam to make sure https://jira.opendaylight.org/browse/SRVUTILS-4 which is Status Done does not show up on the Release dashboard Neon-MRI anymore
  5. tomp will take care of https://jira.opendaylight.org/browse/ARCH-3
  6. aadam will do fl retrospective after thanksgiving


Action items, by person

  1. CaseyLF
    1. CaseyLF to check with phrobb to determine whether a vote is actually required in these circumstances
  2. vorburger
    1. vorburger to move NEUTRON-204 from Fluorine-SR1 to Fluorine-SR2
  3. UNASSIGNED
    1. aadam to work on filters for relmang dashboard to not show done items
    2. aadam to make sure https://jira.opendaylight.org/browse/SRVUTILS-4 which is Status Done does not show up on the Release dashboard Neon-MRI anymore
    3. tomp will take care of https://jira.opendaylight.org/browse/ARCH-3
    4. aadam will do fl retrospective after thanksgiving


People present (lines said)

  1. dfarrell07 (40)
  2. skitt (30)
  3. odl_meetbot (7)
  4. abhijitk (6)
  5. vorburger (6)
  6. rovarga_ (6)
  7. faseelak (5)
  8. jamoluhrsen (4)
  9. zxiiro (4)
  10. LuisGomez (3)
  11. shague (2)
  12. JMorvay (1)
  13. anipbu (1)
  14. mperina (1)
  15. vishnoianil (0)
  16. CaseyLF (0)


Generated by MeetBot 0.1.4.