#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 16:58:38 UTC (full logs).

Meeting summary

    1. TSC members please #info in (dfarrell07, 16:59:46)
    2. skitt (skitt, 16:59:53)
    3. Daniel Farrell for Thanh Ha (dfarrell07, 16:59:56)
    4. premsankar (premsankar, 17:00:06)
    5. faseelak (faseelak, 17:00:12)
    6. https://wiki.opendaylight.org/view/TSC:Meeting#Agenda agenda in the normal place (dfarrell07, 17:00:22)
    7. LuisGomez (LuisGomez, 17:00:31)
    8. jamoluhrsen (jamoluhrsen, 17:00:55)
    9. shague (shague, 17:02:38)
    10. abelur (abelur, 17:02:42)
    11. anipbu (anipbu, 17:02:45)
    12. Abhijit is sick and Ariel is at some manager meeting, so both not here I think (dfarrell07, 17:02:52)
    13. TSC members, please remember to vote for the TSC chair (skitt, 17:03:18)
    14. shague #project netvirt serviceutils odltools ovsdb (shague, 17:03:25)
    15. if you haven't received an email with the Condorcet link, ping CaseyLF (skitt, 17:03:30)

  1. TSC chair election (dfarrell07, 17:04:01)
    1. voting is open, please go vote TSC members (dfarrell07, 17:04:10)

  2. LF closure (dfarrell07, 17:04:24)
    1. there will be a holiday shutdown for LF folks (dfarrell07, 17:04:54)
    2. if you need casey he will be on IRC (dfarrell07, 17:05:07)
    3. if you need IT support check lf-releng IRC and helpdesk (dfarrell07, 17:05:16)
    4. LF it support channel is #lf-releng (CaseyLF, 17:05:23)

  3. Releases (skitt, 17:05:45)
    1. Fluorine SR1 is out, officially (skitt, 17:06:06)
    2. Luis says it's getting a bit more clear how to do these MR releases, just need to remember that it's a bit more work/time after release (dfarrell07, 17:06:55)
    3. skitt asks if it's all doc'd, LuisGomez says yes because he has no memory so he's always reading the doc (dfarrell07, 17:07:19)
    4. Releasing the distro is now the same as releasing a release-managed project (skitt, 17:07:19)
    5. Oxygen SR4 is on-going, with a number of last-minute patches, and we now have a build (skitt, 17:07:46)
    6. We are waiting for sign-offs (skitt, 17:07:52)
    7. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=1286339548 (abelur, 17:07:59)
    8. https://docs.google.com/spreadsheets/d/1dYOY99twqHV_Q0YorAOOxmL0aFc3icNXg8qA_zGwKyA/edit#gid=1286339548 <- oxy sr4 csit sign-off (jamoluhrsen, 17:08:01)
    9. there are still lots of projects that need sign-off (dfarrell07, 17:09:06)
    10. vorburger (vorburger, 17:09:10)
    11. Anil Vishnoi (vishnoianil, 17:09:28)
    12. jamoluhrsen had concern that bgpcep had signed-off first totally-bad result as okay, turns out bgpcep doesn't know who did that, but the actual lead is actually auditing (dfarrell07, 17:09:52)
    13. question about when to do SR2 Fl, since SR1 was quite late (dfarrell07, 17:12:02)
    14. can either bump it out and maybe also adjust other SR dates, or maybe just drop the SR and only have 3 for fl (dfarrell07, 17:12:27)
    15. SR3 is scheduled for Feb 7, so that's pretty good timing anyway (dfarrell07, 17:13:11)
    16. AGREED: Fluorine SR2 will happen on SR3 orig date, SR3 on SR4 date, and no SR4 (dfarrell07, 17:14:42)

  4. release (dfarrell07, 17:22:42)
    1. we went through dashboard but didn't take notes, all is okay (dfarrell07, 17:22:52)

  5. ONAP Edge using ODL (dfarrell07, 17:23:15)
    1. Prem brings discussion about ODL usage in ONAP Edge effort (dfarrell07, 17:23:28)
    2. Prem would like to see us work on reducing footprint and bring down startup time for ODL to be more useful in ONAP Edge (dfarrell07, 17:24:01)
    3. Ildiko is talking with Prem about some usage of ODL in ONAP as well (dfarrell07, 17:24:22)
    4. vorburger has some efforts, old-simple, that would help with bringing down footprint/startup (dfarrell07, 17:25:03)
    5. some +1s to bringing group together who have interests in this, but mainly need people working in the trenches to make progress (dfarrell07, 17:25:40)
    6. basically we need devs who want this to step up and do work, but can start a group and then hope we pull in those people (dfarrell07, 17:26:23)

  6. ODL rep for ONAP (dfarrell07, 17:26:43)
    1. Prem has been attending various ONAP meetings and noticed a need/ask for ODL people to come and be in their conversations (dfarrell07, 17:27:19)
    2. Prem gives info about SDNC and SDNR usage of ODL in ONAP (dfarrell07, 17:29:06)
    3. For SDNR, they want netconf to be very performate so can handle large yang models (dfarrell07, 17:29:38)
    4. tl;dr there are many consumers of ODL in ONAP and we should do a better job of interacting with them (dfarrell07, 17:30:13)
    5. maybe prem can come back and give some more detailed presentations about ODL in ONAP and help drive better collaboration, help us understand what users need (dfarrell07, 17:30:57)
    6. dfarrell07 suggests we can combine this with thoughts about getting people who get value from ODL supporting ODL (dfarrell07, 17:32:19)
    7. maybe we can work with these folks using ODL to teach them how to support/improve the parts they care about (dfarrell07, 17:32:42)
    8. anil V suggests we have something like the old advisor group, but for these open source projects vs companies (dfarrell07, 17:34:32)
    9. LuisGomez points out that a huge user for ODL is various other Open source projects, so really should work on supporting those downstreams (dfarrell07, 17:34:57)
    10. there are companies that have lots of devs working on ODL, but they are just doing it in ONAP, which is very, very sad (dfarrell07, 17:35:35)
    11. Prem says there are lots of not-shared ~forks of ODL in various places in ONAP, need to get those people working with us (dfarrell07, 17:36:21)
    12. ACTION: dfarrell07 to bring idea to TAC to start having periodic, maybe monthly, meetings with projects that consume ODL to get feedback (dfarrell07, 17:38:14)

  7. CII badging for ONAP ODL work (dfarrell07, 17:40:12)
    1. ONAP is doing lots of scanning to do CII badging (dfarrell07, 17:40:27)
    2. they have told us a number of times that they are picking up issues with ODL (dfarrell07, 17:40:45)
    3. they didn't get back to us with details of what they are seeing, per our request (dfarrell07, 17:40:56)
    4. the current email thread also doesn't have the detail we need (dfarrell07, 17:41:07)
    5. https://clm.opendaylight.org/assets/index.html ODL CLM should also show these issues (dfarrell07, 17:41:45)
    6. they have quite a few components that we don't care about, like DLUX, that are likely pulling in many problems (dfarrell07, 17:42:19)
    7. they also are on oxygen sr3, and oxygen sr4 is about to go out the door, then no more oxygen, so bit late for that version (dfarrell07, 17:42:42)
    8. ACTION: skitt will follow-up on ONAP email regarding vulns (dfarrell07, 17:44:03)
    9. michael has sent one reply, but bounced, skitt will send properly to ONAP TSC list (dfarrell07, 17:46:07)
    10. there has also been discussion about hiring an intern to clean up CLM, but that will not happen right away (dfarrell07, 17:52:46)

  8. infra (dfarrell07, 17:52:48)
    1. abelur gives updates about recent infra issues (dfarrell07, 17:52:57)
    2. just went to CentOS 7.6, which seems to have fixed some load issues (dfarrell07, 17:53:15)
    3. there also seems to be issue between a proxy and nexus, working on understanding (dfarrell07, 17:53:47)
    4. jobs with many small files might be more impacted (dfarrell07, 17:54:10)
    5. workaround is to retrigger jobs (dfarrell07, 17:54:15)
    6. vexxhost team is kinda blocker at the moment, so no eta (dfarrell07, 17:54:54)
    7. javadocs jobs seem to be main jobs impacted, verify and publish, most other seem to be stable at this point (dfarrell07, 17:55:34)
    8. many small files are causing sockets to go into wait, then run out of sockets (dfarrell07, 17:56:41)
    9. tomp says he's seeing CSIT controller job fails, jamoluhrsen says that's likely the autorelease malformed URL issue (dfarrell07, 17:57:15)
    10. if you see a mountain of red in jobs triggered from autorelease, keep this in mind (dfarrell07, 17:58:02)

  9. cookies (dfarrell07, 17:58:32)


Meeting ended at 17:58:35 UTC (full logs).

Action items

  1. dfarrell07 to bring idea to TAC to start having periodic, maybe monthly, meetings with projects that consume ODL to get feedback
  2. skitt will follow-up on ONAP email regarding vulns


Action items, by person

  1. dfarrell07
    1. dfarrell07 to bring idea to TAC to start having periodic, maybe monthly, meetings with projects that consume ODL to get feedback
  2. skitt
    1. skitt will follow-up on ONAP email regarding vulns


People present (lines said)

  1. dfarrell07 (71)
  2. skitt (12)
  3. odl_meetbot (5)
  4. abelur (4)
  5. LuisGomez (3)
  6. vorburger (2)
  7. faseelak (2)
  8. premsankar (2)
  9. jamoluhrsen (2)
  10. anipbu (2)
  11. shague (2)
  12. vishnoianil (2)
  13. CaseyLF (1)
  14. rovarga (0)
  15. phrobb (0)


Generated by MeetBot 0.1.4.