#opendaylight-meeting: tsc

Meeting started by dfarrell07 at 17:00:13 UTC (full logs).

Meeting summary

    1. TSC members please #info in (dfarrell07, 17:00:35)
    2. abhijitk (abhijitk, 17:02:26)
    3. Anil Vishnoi (vishnoianil, 17:03:14)
    4. jmorvay (jmorvay, 17:03:23)
    5. premsankar (premsankar, 17:03:29)
    6. Thanh Ha (zxiiro, 17:03:36)
    7. vorburger (vorburger, 17:03:48)
    8. abelur (abelur, 17:03:54)
    9. jamoluhrsen (jamoluhrsen, 17:04:08)
    10. XiongQuan (XiongQuan, 17:04:13)
    11. shague via jamoluhrsen proxy (jamoluhrsen, 17:04:16)
    12. LuisGomez (LuisGomez, 17:04:31)

  1. TSC Chair Elections (abhijitk, 17:05:04)
    1. Reminder to vote (abhijitk, 17:05:18)
    2. faseelak (faseelak, 17:05:21)
    3. 9 of 13 TSC members have voted, go vote! (dfarrell07, 17:05:49)

  2. DetNet Project Proposal (abhijitk, 17:06:11)
    1. https://wiki.opendaylight.org/view/Project_Proposals:DetNet_Plugin (abhijitk, 17:06:32)

  3. project propsal netdev plugin (dfarrell07, 17:06:54)
    1. https://wiki.opendaylight.org/view/Project_Proposals:DetNet_Plugin proposal wiki (dfarrell07, 17:07:07)
    2. proposal has been up on the mailing list for more than two weeks (dfarrell07, 17:07:18)
    3. this is a IETF proposal, with implementation in ODL (dfarrell07, 17:08:30)
    4. basic idea seems to be around deterministic flows with some guarantees for flows (dfarrell07, 17:09:05)
    5. so for example might reserve data plane routes that don't change, or are aggregated (dfarrell07, 17:12:55)
    6. seems like this project will be fairly large, will have many components inside of it, see diagram (dfarrell07, 17:15:34)
    7. so for example seems like will have topo manager inside this project, as well as some sb protocol, and will also have e2e managing service that does thinks like handle bandwidth guarantees (dfarrell07, 17:17:08)
    8. project will make use of ODL components like mdsal, netconf, restconf (dfarrell07, 17:17:58)
    9. so prem's question about what SBs project will use to manged devices is 'netconf' (dfarrell07, 17:18:17)
    10. dfarrell07 thinks this is exceptionally well thought-out proposal, very good details on the wiki (dfarrell07, 17:18:49)
    11. Looks like they also use the PCE and BGP-LS (premsankar, 17:20:26)
    12. BGP-LS and PCE will be reused, they will use existing ODL projects (dfarrell07, 17:22:13)
    13. this seems like a very clear example of why ODL as a platform is useful - new research idea doesn't have to re-invent much, is reusing huge chunks of ODL (dfarrell07, 17:23:19)
    14. there are IETF docs about detailed usecases, but tldr seems to be "5G" (dfarrell07, 17:23:52)
    15. there are 5 initial committers, which is a nice number, enough for robustness but not absurd-many (dfarrell07, 17:24:55)
    16. all committers are from ZTE, but seems like they are working with other folks through IETF (dfarrell07, 17:26:13)
    17. prem asks how CSIT would work, if they need real devices (dfarrell07, 17:27:12)
    18. seems like they will use software emulation for tests initially and have some ideas about real devices later (dfarrell07, 17:27:53)
    19. VOTE: Voted on "Shall the TSC approve DetNet Plugin as a Self-Managed project in Incubation state?" Results are, +1: 8 (abhijitk, 17:30:56)
    20. AGREED: OpenDaylight TSC approves DetNet Plugin as a Self-Managed project in Incubation state (abhijitk, 17:31:24)
    21. please reach out to helpdesk@opendaylight.org to add committers, get repos (dfarrell07, 17:32:31)
    22. they want to join the release after Neon, not Neon, so lots of time (dfarrell07, 17:34:01)
    23. since they are self-managed they can join the relase however they like, reach out to LuisGomez for help (dfarrell07, 17:34:21)

  4. Super committer Discussion (abhijitk, 17:34:25)
    1. https://git.opendaylight.org/gerrit/#/c/77837/ Proposal for the super committer (abhijitk, 17:34:58)
    2. idea is to put more process around who can be a super committer for releng activities like bumping versions (dfarrell07, 17:35:55)
    3. that woud allow non-LF-admins to do this work (dfarrell07, 17:36:04)
    4. there are detailed docs on exactly when this power can be turned on (dfarrell07, 17:36:17)
    5. and there are detaile docs about tthe limits of when this can be used, for what (dfarrell07, 17:36:38)
    6. the detailed docs also have a list of initial super committers (zxiiro, 17:36:55)
    7. VOTE: Voted on "Shall OpenDaylight have an official TSC Managed super committer list?" Results are, 0: 1, +1: 9 (dfarrell07, 17:37:40)
    8. dfarrell07 vote was for sam hague (dfarrell07, 17:37:50)
    9. AGREED: the TSC approves super-committer process as doc here https://git.opendaylight.org/gerrit/#/c/77837/ (dfarrell07, 17:38:56)

  5. Governing Board Meeting Update (abhijitk, 17:39:33)
    1. We gave ODL update to Board, they like idea ot onboard new devs to kernel projects by trading training for support, might get help (dfarrell07, 17:44:05)
    2. We gave proposal on direct project representation to board, also well received (dfarrell07, 17:44:41)
    3. TF TAC vote is ongoing, dfarrell07 voted against because: 1. TF is single-vendor dominated and unhealthy in a variety if ways related to that; dfarrell07 thinks unlikely to be fixable 2. they are taking a pretty huge chunk of money from existing projects (dfarrell07, 17:46:13)
    4. there are a few very vocal supporting companies that have voted +1 and a ton of company reps who don't seem to really be paying attention but just vote +1 because it's easy/friendly (dfarrell07, 17:46:56)
    5. there are a fair number of people who haven't voted because don't want company to look bad, but have told dfarrell07 off-list they disapprove (dfarrell07, 17:47:31)
    6. Board vote hasn't happened yet, but dfarrell07 suspects will pass for same reason TAC vote will pass - lots of companies that aren't paying enough attention to know better (dfarrell07, 17:48:15)
    7. dfarrell07 was wrong on the vocal update about this passing already, thanks for correction phrobb/CaseyLF, notes above are right (dfarrell07, 17:49:01)

  6. Fluorine Retrospective (dfarrell07, 17:50:22)
    1. Fluorine Retrospective https://docs.google.com/document/d/16ssjcNRzP_uQr1HMZCkb_lc8gLeYNfqrGAI6XEw9Gko (dfarrell07, 17:50:36)
    2. lots of discussion about infra but dfarrell07 fails to take minutes (dfarrell07, 17:57:39)
    3. VOTE: Voted on "Meeting next week?" Results are, 0: 8, +1: 1 (dfarrell07, 18:03:23)
    4. we mostly don't care if meeting but CaseyLF talks us out of it at last moment (dfarrell07, 18:03:43)
    5. so no meeting next week (dfarrell07, 18:03:51)
    6. do things over email and respond (dfarrell07, 18:04:00)

  7. cookies (dfarrell07, 18:04:04)


Meeting ended at 18:04:07 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dfarrell07 (70)
  2. odl_meetbot (24)
  3. abhijitk (18)
  4. jamoluhrsen (9)
  5. premsankar (8)
  6. vorburger (5)
  7. LuisGomez (5)
  8. zxiiro (5)
  9. faseelak (4)
  10. abelur (4)
  11. vishnoianil (3)
  12. jmorvay (2)
  13. arieladam (2)
  14. XiongQuan (1)
  15. lori (1)
  16. CaseyLF (1)
  17. skitt (0)
  18. rovarga_ (0)


Generated by MeetBot 0.1.4.