#opendaylight-meeting: Kernel projects call

Meeting started by rovarga at 17:06:01 UTC (full logs).

Meeting summary

    1. jmorvay asks about CDS persistence: can journal/snapshots be used to replicate data to another cluster instance? (rovarga, 17:09:09)
    2. that should be doable, assuming source and target clusters match in configuration (member names, etc.) (rovarga, 17:09:48)
    3. Tom mentions an online backup facility is available through cluster-admin service (rovarga, 17:11:15)
    4. jmorvay asks if snapshots contain the data tree (rovarga, 17:12:03)
    5. snapshots contain data tree contents plus all backend metadata -- all raft state, transaction state, etc. (rovarga, 17:12:31)

  1. Fluorine SR2 readiness (for 2/7/2019) (rovarga, 17:14:14)
    1. odlparent-3.1.6 needs a multipatch test, which should be done tomorrow (rovarga, 17:14:46)
    2. then we need yangtools bump, which should take about a day to release (rovarga, 17:15:04)

  2. Neon code freeze readiness (for 1/24/2019) (rovarga, 17:16:14)
    1. https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-userfeatures-all-neon/ (LuisGomez, 17:16:38)
    2. build #140, #142 and #144-148 are completely failing (rovarga, 17:18:00)
    3. jmorvay mentions we have had some code movement, but nothing that would be expected to regress (rovarga, 17:18:33)
    4. ACTION: jmorvay to check what is going on (rovarga, 17:19:40)
    5. https://jenkins.opendaylight.org/releng/view/netconf/job/netconf-csit-1node-userfeatures-all-fluorine/ (LuisGomez, 17:19:44)
    6. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/netconf-csit-1node-userfeatures-all-neon/148/odl_1/odl1_karaf.log.gz (rovarga, 17:20:54)
    7. Caused by: org.w3c.dom.DOMException: NAMESPACE_ERR: An attempt is made to create or change an object in a way which is incorrect with regard to namespaces. (rovarga, 17:21:57)
    8. this looks like we are getting xerces implementation when we should not (rovarga, 17:22:14)
    9. https://git.opendaylight.org/gerrit/#/c/77471/ (jmorvay, 17:23:30)
    10. https://git.opendaylight.org/gerrit/#/c/77471/ (rovarga, 17:23:57)
    11. that should help the situation (rovarga, 17:24:03)
    12. we need odlparent-4.0.8 and the usual yangtools/mdsal propagation (rovarga, 17:25:40)
    13. reverted spotbugs upgrade, because it breaks downstreams (rovarga, 17:27:40)
    14. https://git.opendaylight.org/gerrit/#/c/79317/ is the final bit, awaiting review (rovarga, 17:28:08)
    15. we should be ready to release tomorrow (rovarga, 17:28:21)
    16. https://git.opendaylight.org/gerrit/#/q/topic:odlparent-4.0.7 is the ongoing bump (rovarga, 17:29:11)
    17. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/openflowplugin-csit-1node-flow-services-all-oxygen/491/odl_1/odl1_karaf.log.gz (LuisGomez, 17:31:50)
    18. skitt will updated the outstanding patches to 4.0.8 (rovarga, 17:31:52)
    19. and push all the other necessary patches (skitt, 17:32:08)
    20. oxygen is in a busted state, as it did not complete odlparent-3.1.5 bump, which was needed to fix the xtend issues (rovarga, 17:32:26)
    21. odlparent-3.1.6 includes jackson-databind fix, which has a couple CVEs attached to it (rovarga, 17:33:19)
    22. might be a cause to release Oxygen SR5 (rovarga, 17:33:36)
    23. ACTION: rovarga to raise this at security@/tsc@ (rovarga, 17:33:50)
    24. mdsal-3.0.4 has two more patches outstanding (rovarga, 17:34:58)
    25. https://git.opendaylight.org/gerrit/79051 to add aggregate javadocs (for javadoc.io integration) (rovarga, 17:35:13)
    26. https://git.opendaylight.org/gerrit/75569 is optional, as it just brings about mdsal-trace without adding a feature (rovarga, 17:36:06)
    27. we still need to figure out how mdsal's odl-mdsal-trace and controller's odl-mdsal-trace will work together (rovarga, 17:37:51)
    28. rovarga suspects this will need the code to be published as artifacts from mdsal and then controller will do *something* (rovarga, 17:38:22)
    29. blueprint will need some more work, and should be fair for mdsal-3.0.5 (rovarga, 17:42:49)
    30. mdsal-trace should go into 3.0.4, though (rovarga, 17:43:03)
    31. mdsal/controller blueprint structure is TBD, as we may just keep the forked copy (rovarga, 17:50:40)
    32. ACTION: rovarga to ask around how controller->mdsal migration is going in downstreams (rovarga, 17:52:07)

  3. tell-based CSIT (rovarga, 17:52:50)
    1. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/controller-csit-3node-ddb-expl-lead-movement-longevity-only-neon/21/robot-plugin/log.html.gz (rovarga, 17:53:56)
    2. we are getting a DeadTransactionException (rovarga, 17:54:12)
    3. which really should not be there, as we are expecting a stateful switchover (rovarga, 17:54:52)
    4. the transaction is in purged transactions (rovarga, 17:56:10)
    5. the transaction is from the default history, i.e. not chained (rovarga, 18:00:43)
    6. ACTION: Tom to file an issue to track this (rovarga, 18:01:09)


Meeting ended at 18:02:42 UTC (full logs).

Action items

  1. jmorvay to check what is going on
  2. rovarga to raise this at security@/tsc@
  3. rovarga to ask around how controller->mdsal migration is going in downstreams
  4. Tom to file an issue to track this


Action items, by person

  1. jmorvay
    1. jmorvay to check what is going on
  2. rovarga
    1. rovarga to raise this at security@/tsc@
    2. rovarga to ask around how controller->mdsal migration is going in downstreams


People present (lines said)

  1. rovarga (45)
  2. LuisGomez (6)
  3. odl_meetbot (3)
  4. skitt (1)
  5. jmorvay (1)


Generated by MeetBot 0.1.4.