#opendaylight-meeting: Kernel Projects Call

Meeting started by rovarga_ at 16:01:59 UTC (full logs).

Meeting summary

  1. Agenda (rovarga_, 16:02:41)
    1. mdsal-4.0.1 upgrade on Sodium (rovarga_, 16:06:02)
    2. odlparent-3.1.7, yangtools-2.0.x, mdsal-3.0.x to support Fluorine SR3 (rovarga_, 16:06:21)

  2. Ajay's trouble with dev@ mailinglist (rovarga_, 16:07:21)
    1. cross-checked with archives (rovarga_, 16:07:30)
    2. https://lists.opendaylight.org/mailman/listinfo/dev (rovarga_, 16:08:29)
    3. best option is to follow-up with helpdesk at <helpdesk@opendaylight.org> (rovarga_, 16:09:34)

  3. odlparent-3.1.7 (rovarga_, 16:10:19)
    1. release notes: https://git.opendaylight.org/gerrit/#/c/82039/1/NEWS.rst (rovarga_, 16:11:21)
    2. ACTION: rovarga to release odlparent-3.1.7 once the notes are in (rovarga_, 16:15:13)

  4. yangtools-2.0.19 (rovarga_, 16:16:31)
    1. https://jira.opendaylight.org/browse/YANGTOOLS-987?jql=project%20%3D%2010188%20AND%20fixVersion%20%3D%2011001%20ORDER%20BY%20priority%20DESC%2C%20key%20ASC (rovarga_, 16:16:37)
    2. 2 issues fixed, will release once we have them consuming odlparent-3.1.7 (rovarga_, 16:16:51)

  5. mdsal-3.0.9 (rovarga_, 16:17:25)
    1. https://jira.opendaylight.org/browse/MDSAL-439?jql=project%20%3D%2010137%20AND%20fixVersion%20%3D%2011004%20ORDER%20BY%20priority%20DESC%2C%20key%20ASC (rovarga_, 16:17:38)
    2. two issues fixed, will release once we have yangtools-2.0.19 (rovarga_, 16:17:55)

  6. mdsal-4.0.1 (rovarga_, 16:18:16)
    1. patches staged, ready to merge (rovarga_, 16:18:43)
    2. https://git.opendaylight.org/gerrit/#/q/topic:mdsal-4.0.1 (rovarga_, 16:18:45)
    3. rovarga_ has supercommitter rights, will start merging as soon as infra is back online properly (rovarga_, 16:19:23)

  7. Ajay's questions to all things netconf/restconf/clustering (rovarga_, 16:20:31)
    1. NETCONF-448 is implemented, needs testing (rovarga_, 16:23:24)
    2. testtool is missing implementation of actions probably (rovarga_, 16:23:35)
    3. sal-remoterpc-connector changes seem to be straightforward (rovarga_, 16:25:12)
    4. Bala asks what are actions -- the short story is that they are equivalent of OpenDaylight Routed RPCs, i.e. RPCs which are invoked in the context of a operational data tree node (rovarga_, 16:27:47)


Meeting ended at 16:28:51 UTC (full logs).

Action items

  1. rovarga to release odlparent-3.1.7 once the notes are in


People present (lines said)

  1. rovarga_ (29)
  2. odl_meetbot (4)
  3. skitt (1)


Generated by MeetBot 0.1.4.