#opendaylight-meeting: Kernel Projects Call

Meeting started by rovarga_ at 16:01:48 UTC (full logs).

Meeting summary

  1. Clustering in ODL (skitt, 16:02:19)
    1. the default datastore is the clustered datastore (skitt, 16:02:34)
    2. by default it replicates data across all nodes and provides access to the data across the cluster (skitt, 16:02:51)
    3. for any single piece of data, there is a single master in the cluster (skitt, 16:04:10)
    4. any modification goes through the master (leader) (skitt, 16:04:19)
    5. leaders are chosen per shard (skitt, 16:04:33)
    6. from the developer's perspective, if you write a transaction and submit it, you get a future which succeeds when the data is persisted (skitt, 16:05:24)
    7. in the current implementation, success is indicated when the data is stored in a majority of the nodes (cluster consensus) — but that's an implementation detail (skitt, 16:05:53)
    8. the contract is that when the future succeeds, the data is securely stored (barring operator error as always) (skitt, 16:06:15)
    9. if you kill the leader, before a transaction succeeds, the transaction will eventually fail (skitt, 16:09:38)
    10. after a transaction succeeds, before the success message was sent, the committing client will receive a failure, but the data is actually there (skitt, 16:11:15)

  2. OpenFlowPlugin reviews (skitt, 16:16:14)
    1. rovarga_ has a few patches stuck in limbo (skitt, 16:16:21)
    2. Ericsson committers only +1 patches apparently, and when Anil doesn't merge patches nothing happens (skitt, 16:16:45)
    3. ACTION: LuisGomez to bring this up in next Monday's call (skitt, 16:17:22)

  3. https://jira.opendaylight.org/browse/MDSAL-456 (rovarga_, 16:18:04)
    1. https://git.opendaylight.org/gerrit/82558 (rovarga_, 16:18:23)

  4. karaf-4.2.6 (rovarga_, 16:22:01)
    1. with Karaf 4.2.6, there's a wiring issue between Akka persistence and LevelDB (skitt, 16:24:49)
    2. starting LevelDB first, and then persistence, works (skitt, 16:25:03)
    3. starting persistence on its own, then something else, works (skitt, 16:25:11)
    4. starting everything in one go fails (skitt, 16:25:18)
    5. triggering a bundle refresh later on fixes everything (skitt, 16:25:57)
    6. so it looks like feature:install with optional imports, skips a propagation path (skitt, 16:26:17)
    7. it feels like a resolver bug (skitt, 16:26:35)
    8. ACTION: skitt to check whether Karaf 4.2.5 + the Equinox downgrade works with multipatch (skitt, 16:28:29)

  5. MD-SAL simple patches (skitt, 16:34:31)
    1. rovarga_ merged a few of Michael's patches, the remaining ones need quite a lot of rework (skitt, 16:34:45)

  6. archetypes (rovarga_, 16:36:00)
    1. we'll skip all the Fluorine SRs until SR3 (skitt, 16:37:09)
    2. the first proper archetypes release will be 1.0.3 (skitt, 16:37:16)
    3. fluorine jobs are suspended pending SR3 activities (rovarga_, 16:37:18)


Meeting ended at 16:47:26 UTC (full logs).

Action items

  1. LuisGomez to bring this up in next Monday's call
  2. skitt to check whether Karaf 4.2.5 + the Equinox downgrade works with multipatch


Action items, by person

  1. skitt
    1. skitt to check whether Karaf 4.2.5 + the Equinox downgrade works with multipatch


People present (lines said)

  1. skitt (28)
  2. rovarga_ (8)
  3. odl_meetbot (7)
  4. rovarga (0)


Generated by MeetBot 0.1.4.