#opendaylight-meeting: Kernel Projects Call

Meeting started by rovarga at 16:02:17 UTC (full logs).

Meeting summary

  1. agenda (rovarga, 16:02:48)
    1. Actions support update (rovarga, 16:03:49)
    2. odlparent-6 (i.e. Magnesium) (rovarga, 16:04:40)
    3. stable/neon MRI update (rovarga, 16:04:51)
    4. reinstall clustering from scratch (rovarga, 16:07:19)
    5. administrative things (rovarga, 16:07:38)

  2. Actions support update (rovarga, 16:08:20)
    1. we have two trains: controller and netconf (in restconf) (rovarga, 16:08:37)
    2. reviewers requested (rovarga, 16:08:52)
    3. ACTION: rovarga to add people on review (rovarga, 16:09:08)
    4. ACTION: rovarga to send out the 'busy committers like this' rant (rovarga, 16:10:50)
    5. restconf patch by end of week (rovarga, 16:12:12)
    6. testtool magic (rovarga, 16:13:00)
    7. rovarga recently came across https://github.com/remkop/picocli (rovarga, 16:15:02)
    8. LuisGomez notes that *some* parameters are working, but not all and it takes some doing (rovarga, 16:16:49)
    9. we need a docs update to spell out how system tools are setting up testtool (rovarga, 16:18:13)
    10. java-11 required? pending the TSC's final decision (rovarga, 16:22:10)
    11. probably will have karaf-4.3.0 with OSGi R7, do we want that? (rovarga, 16:22:51)
    12. scala-2.13.0 available (with akka 2.5.x, 2.6.x) (rovarga, 16:23:24)
    13. forcing guava-28.0 is not fair (rovarga, 16:24:47)
    14. checkstyle bump? (rovarga, 16:24:55)
    15. checkstyle/spotbugs are usually easily fixed up minor version bump changes (rovarga, 16:25:47)
    16. AGREED: update odlparent policy to say that minor patch can break build, but tests need to be kept working (rovarga, 16:27:46)
    17. removing jsr305 completely (rovarga, 16:29:24)
    18. we down to 4/5 downstreams using it, before Sodium there should be at most 2 (rovarga, 16:30:04)
    19. ACTION: create a 6.0.0 release in JIRA and will open issues for the changes we want to make (rovarga, 16:30:40)
    20. karaf-4.3.0 is probably going to be painful (rovarga, 16:32:39)

  3. stable/neon MRI update (rovarga, 16:32:52)
    1. odlparent-4.0.11, yangtools-2.1.11, mdsal-3.0.9 is out (rovarga, 16:33:26)
    2. https://git.opendaylight.org/gerrit/#/q/topic:mri-neon-sr2 (rovarga, 16:34:59)
    3. odlparent-5.0.2 would be nice (rovarga, 16:36:20)
    4. https://git.opendaylight.org/gerrit/73686 (skitt, 16:36:48)
    5. yangtools is still doing some work for the next release, will roll out either 5.0.1 or 5.0.2 dependending on readiness (rovarga, 16:37:46)

  4. reinstall clustering from scratch (rovarga, 16:38:13)
    1. it's just a reinstall of a single node (rovarga, 16:38:40)
    2. https://jira.opendaylight.org/browse/CONTROLLER-1626 (LuisGomez, 16:38:42)
    3. https://docs.opendaylight.org/en/stable-neon/getting-started-guide/clustering.html#geo-distributed-active-backup-setup (LuisGomez, 16:40:45)
    4. as a workaround, is it possible to add the old *system* as a new *cluster node*? it should be possible to add a new cluster member and delete the old one -- it's just that the reinstalled node would have a different name in ODL cluster (rovarga, 16:43:00)

  5. general discussion (rovarga, 16:44:35)
    1. https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=650373173 looks a bit worrying (rovarga, 16:47:01)
    2. https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=650373173 looks a bit worrying (rovarga, 16:47:28)
    3. https://docs.google.com/spreadsheets/d/1CN-ACdIekRKMYRIuREIRALl6S8az7quAcQlRb3KeMJ8/edit#gid=588630221 (rovarga, 16:47:34)
    4. ACTION: rovarga to revert bgpcep/osgi patch (rovarga, 16:48:57)
    5. LuisGomez needs to refactor bgp tests (rovarga, 16:49:37)
    6. https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-csit-1node-userfeatures-all-sodium/ (LuisGomez, 16:51:02)
    7. https://jenkins.opendaylight.org/releng/view/bgpcep/job/bgpcep-csit-1node-throughpcep-all-sodium/ (LuisGomez, 16:52:36)
    8. for the first link it should be just the patch revert (LuisGomez, 16:53:09)
    9. for the second link I have to go deep in the suite (LuisGomez, 16:53:30)
    10. last success was https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/bgpcep-csit-1node-throughpcep-all-sodium/65/ (rovarga, 16:54:57)
    11. which was Mar 28, which is a loong time ago (rovarga, 16:55:15)
    12. https://git.opendaylight.org/gerrit/#/c/64782/ was changed on Mar 26nd in bgpceep (rovarga, 16:57:10)
    13. https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/bgpcep-csit-1node-throughpcep-all-sodium/215/odl_1/odl1_karaf.log.gz (rovarga, 16:58:07)
    14. https://jira.opendaylight.org/browse/BGPCEP-875 tracks the CME (rovarga, 17:02:01)


Meeting ended at 17:02:11 UTC (full logs).

Action items

  1. rovarga to add people on review
  2. rovarga to send out the 'busy committers like this' rant
  3. create a 6.0.0 release in JIRA and will open issues for the changes we want to make
  4. rovarga to revert bgpcep/osgi patch


Action items, by person

  1. rovarga
    1. rovarga to add people on review
    2. rovarga to send out the 'busy committers like this' rant
    3. rovarga to revert bgpcep/osgi patch


People present (lines said)

  1. rovarga (65)
  2. LuisGomez (12)
  3. odl_meetbot (7)
  4. skitt (1)


Generated by MeetBot 0.1.4.