#opendaylight-meeting: tsc

Meeting started by abhijitk at 15:59:25 UTC (full logs).

Meeting summary

  1. Agenda Bashing & Roll Call (abhijitk, 15:59:45)
    1. abhijitk (abhijitk, 16:00:35)
    2. skitt (skitt, 16:01:25)
    3. Thanh Ha (IRC only) (zxiiro, 16:01:39)
    4. Agenda: https://wiki.opendaylight.org/view/TSC:Meeting#Agenda (skitt, 16:01:43)
    5. jamoluhrsen (jamoluhrsen, 16:01:58)
    6. premsankar #project coe (premsankar, 16:03:46)
    7. faseelak (lori, 16:04:26)

  2. Releases (abhijitk, 16:06:08)
    1. https://jira.opendaylight.org/secure/Dashboard.jspa?selectPageId=10403 Release Dashboard (abhijitk, 16:06:42)
    2. rovarga (rovarga, 16:06:43)
    3. shague (shague, 16:07:25)
    4. LuisGomez (LuisGomez, 16:10:38)
    5. danieldelarosa (danieldelarosa, 16:10:56)
    6. new blocker for Fluorine SR3, CONTROLLER-1879 (skitt, 16:17:09)
    7. Neon SR1 is completed for managed projects, not all unmanaged projects are in yet (skitt, 16:17:29)
    8. Telemetry are having issues with the staging job but looking good so far (skitt, 16:17:42)
    9. SNMP4SDN probably won’t make it (skitt, 16:17:48)
    10. reminder that the dates in the release schedule are supposed to include self-managed projects (skitt, 16:18:46)
    11. the release schedule on the wiki needs to be updated to point to the docs page (skitt, 16:19:36)
    12. ACTION: abhijitk to update release schedule on the wiki to point to docs page (abhijitk, 16:20:28)
    13. Fluorine autorelease is looking bad currently (skitt, 16:20:30)
    14. failures on Sodium too (skitt, 16:20:43)

  3. Expenses (abhijitk, 16:22:11)
    1. the budgeting process for 2020 will be very different from that used for 2019 (skitt, 16:22:45)
    2. ACTION: abhijitk to forward Phil's note about the Strategic Planning Committee to the TSC (abhijitk, 16:23:45)
    3. the SPC are studying the various needs of LFN projects (skitt, 16:24:03)
    4. next year there won’t be across-the-board requirements to produce say 10% budget cuts (skitt, 16:24:23)
    5. projects will be prioritised (skitt, 16:24:29)
    6. The SPC (Strategic Planning Committee) will be looking to what is most significant to membership. (CaseyLF, 16:24:34)
    7. the slides say that the TAC rep for each TAC project is on the SPC (skitt, 16:25:39)
    8. Each projects TAC Rep will be apart of the SPC. (CaseyLF, 16:25:48)
    9. but that’s not correct because there’s a significant time investment involved (skitt, 16:25:50)
    10. each TSC will have to choose a rep for the SPC (skitt, 16:27:22)
    11. the Budget holder for ODL is the LFN Board. (CaseyLF, 16:27:55)
    12. The LF Finance team does budgeting for over 100 organizations. They don't break things down by projects. They do it at LFN level. (CaseyLF, 16:28:46)
    13. Collecting spend data for each project is complicated and not really possible in the current format. (CaseyLF, 16:29:40)
    14. Phil is happy to provide infra numbers for ODL (skitt, 16:31:55)
    15. rovarga would like to know the results of ODL’s efforts to reduce its costs, across all expenditures (not just infra) (skitt, 16:32:13)
    16. phrobb will support that request to get those numbers (skitt, 16:32:49)
    17. a finer-grained understanding of ODL’s costs would be very helpful (skitt, 16:34:35)
    18. without regular reports of our costs we can’t see the impact of our efforts (skitt, 16:34:54)
    19. ACTION: phrobb to provide reports about ODL’s costs (skitt, 16:35:07)
    20. phrobb mentions that the board currently doesn’t have the time to look into projects’ issues (skitt, 16:37:50)
    21. this is one of the ideas behind SPC, to give more time to track projects’ needs (skitt, 16:38:07)
    22. currently there are three core projects everyone cares about: ONAP, OPNFV, ODL (skitt, 16:38:39)
    23. ODL does not currently have a directed fund, but if it did the TSC would control the usage of those funds exclusively. (CaseyLF, 16:43:50)
    24. Phil worked to reduce scanning costs so that we could add the Docs contractor. Thanh's departure was a loss but we are looking to fill that role. (CaseyLF, 16:46:20)
    25. the Community is looking to understand the changes in their costs. (CaseyLF, 16:46:55)
    26. Phil: Our team is also working with Vexxhost to reduce our costs. (CaseyLF, 16:47:12)
    27. ACTION: Casey to try again to automate the distribution of the Vexxhost pricing. (CaseyLF, 16:48:06)
    28. CaseyLF brings up topic of legal subcommittees for each subprojects, in particular to look at the licensing of all the code in the subprojects before each release (skitt, 16:51:36)
    29. this is to replace Steve Winslow’s scanning activities (skitt, 16:52:35)
    30. CaseyLF suggests that ODL should look into forming a legal subcommittee for the project (abhijitk, 16:52:37)
    31. skitt and abhijitk wonder if this was not part of the IPR process done by LF (abhijitk, 16:53:21)
    32. approving license exceptions (non-EPL) is now part of the TSC’s duties (skitt, 16:54:02)
    33. (Steve is still scanning but not as much) (skitt, 16:55:29)

  4. Neutron (skitt, 16:56:41)
    1. rovarga asks who is taking care of Neutron nowadays (skitt, 16:56:49)
    2. the answer is no one (skitt, 16:56:53)
    3. I need one patch merged :) (rovarga, 16:57:31)
    4. https://git.opendaylight.org/gerrit/#/c/80860/ (rovarga, 16:57:32)

  5. Interns (skitt, 16:57:49)
    1. we need to start interviewing people now (skitt, 16:57:56)

  6. Intern candidates (abhijitk, 16:58:14)
    1. https://docs.google.com/spreadsheets/d/1KWvIVZpVgm96vpG4g4I5fL3uXpN_QTyLifawjiE0vWg/edit?usp=sharing (abhijitk, 16:58:19)

  7. Cookies (skitt, 17:02:33)


Meeting ended at 17:02:35 UTC (full logs).

Action items

  1. abhijitk to update release schedule on the wiki to point to docs page
  2. abhijitk to forward Phil's note about the Strategic Planning Committee to the TSC
  3. phrobb to provide reports about ODL’s costs
  4. Casey to try again to automate the distribution of the Vexxhost pricing.


Action items, by person

  1. abhijitk
    1. abhijitk to update release schedule on the wiki to point to docs page
    2. abhijitk to forward Phil's note about the Strategic Planning Committee to the TSC
  2. UNASSIGNED
    1. phrobb to provide reports about ODL’s costs
    2. Casey to try again to automate the distribution of the Vexxhost pricing.


People present (lines said)

  1. skitt (42)
  2. abhijitk (14)
  3. CaseyLF (13)
  4. rovarga (5)
  5. odl_meetbot (4)
  6. lori (2)
  7. shague (1)
  8. LuisGomez (1)
  9. faseelak (1)
  10. premsankar (1)
  11. jamoluhrsen (1)
  12. zxiiro (1)
  13. danieldelarosa (1)


Generated by MeetBot 0.1.4.