#opendaylight-netvirt: NetVirt Weekly 06/13/17

Meeting started by shague at 15:02:29 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:30)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_06_06_17/opendaylight-netvirt-netvirt_weekly_06_06_17.2017-06-06-15.13.html last weeks minutes (shague, 15:02:32)
    2. viveknarasimhan (viveknarasimhan, 15:02:35)
    3. vpickard (vpickard, 15:02:40)
    4. Sridhar Gaddam (sridharg, 15:02:47)

  2. Review existing action items (shague, 15:03:39)
    1. Aswin Suryanarayanan (aswinsuryan, 15:04:09)
    2. daya_k (daya_k, 15:04:19)
    3. Janki Chhatbar (jchhatbar, 15:04:25)
    4. Andre Fredette (afredette, 15:04:57)
    5. [DONE] Netvirt/Ovsdb/Genius need to look at curent test failures and inform if acceptable or not (shague, 15:05:22)
    6. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=119564471 (anipbu, 15:06:25)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#SR4_Download (anipbu, 15:06:37)
    8. An and Jamo reviewed Boron SR4 netvirt bugs, links above (vpickard, 15:07:01)
    9. no blocker bugs for netvirt for sr4 (vpickard, 15:07:29)
    10. Vnkat to share list of open bugs - reach out to Venkat to get list of bugs (shague, 15:08:47)
    11. ACTION: Sam to reach out to Venkat for list of bugs (vpickard, 15:08:48)

  3. Boron sr4 (shague, 15:09:08)
  4. Carbon SR1 planning - 07/06/17, Build cutoff: 07/02/17 11:59 UTC (shague, 15:09:40)
    1. vivek 3 blocker bugs. 1. default sgs, (shague, 15:10:33)
    2. viveknarasimhan: 2. ipv6 prefix, csit issues (shague, 15:11:03)
    3. viveknarasimhan 3. arp mip learning test (shague, 15:11:19)
    4. exception bugs and other csit sporadic submitted and looking good. (shague, 15:12:07)

  5. Nitrogen Planning (shague, 15:15:57)
    1. Main goal for Nitrogen is karaf4 (vpickard, 15:16:36)

  6. karaf 4 (shague, 15:17:21)
    1. must use karaf4 by next week (vpickard, 15:18:04)
    2. plan to migrate to odlparent 1.9.0 and 2.0 (shague, 15:18:18)
    3. project update odlparent to 2.0 will have to do this manually (vpickard, 15:18:56)
    4. https://wiki.opendaylight.org/view/Karaf_4_migration (anipbu, 15:19:06)
    5. expect huge breakages next week as projects move to karaf4 (vpickard, 15:20:05)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=8669 (anipbu, 15:20:22)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=8682 (anipbu, 15:20:26)
    8. https://bugs.opendaylight.org/show_bug.cgi?id=8638 (anipbu, 15:20:32)
    9. skitt has build karaf4 distro in patch 55160, will run in csit (vpickard, 15:24:01)
    10. vorburger opening bugs for karaf4 distro build (vpickard, 15:25:07)
    11. preference would be to get at least one project, maybe netvirt, running in karaf4 before switching over all projects (vpickard, 15:26:36)
    12. Keep with orig schedule of June 19, will revisit, and move by 1 week if needed based on netvirt test results (vpickard, 15:29:43)
    13. To run csit today on the karaf4 distribution produced by Michael (viveknarasimhan, 15:30:48)
    14. based on those results we will be able to decide the complexity of fixing the current karaf4 bugs (viveknarasimhan, 15:31:15)

  7. ocata (shague, 15:32:41)
    1. adding compute nodes is still an issue (shague, 15:33:55)
    2. new startup script may fix issue (shague, 15:34:18)
    3. CSIT sporadic bugs and exceptions (shague, 15:36:23)
    4. janki mentions some longstanding bugs need to be looked at (shague, 15:39:33)
    5. viveknarasimhan says some will be looked at soon (shague, 15:40:17)
    6. viveknarasimhan focusing on bug 8585, arp responder and two others (shague, 15:42:14)
    7. https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic%22&list_id=80195 (viveknarasimhan, 15:43:08)
    8. need to triage list of open bugs again (shague, 15:43:18)


Meeting ended at 15:45:07 UTC (full logs).

Action items

  1. Sam to reach out to Venkat for list of bugs


People present (lines said)

  1. shague (25)
  2. vpickard (12)
  3. anipbu (6)
  4. viveknarasimhan (4)
  5. odl_meetbot (4)
  6. sridharg (1)
  7. daya_k (1)
  8. aswinsuryan (1)
  9. jchhatbar (1)
  10. afredette (1)


Generated by MeetBot 0.1.4.