#opendaylight-netvirt: NetVirt Weekly 07/18/17
Meeting started by shague at 14:59:20 UTC
(full logs).
Meeting summary
- Roll call and agenda bashing (please #info <your-nick>) (shague, 14:59:33)
  - Vishal (vthapar,
    15:02:28)
 
 
- Review existing action items (shague, 15:03:52)
  - https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_07_11_17/opendaylight-netvirt-netvirt_weekly_07_11_17.2017-07-11-15.01.html
    (shague,
    15:04:07)
- skitt (skitt,
    15:04:32)
- vpickard (vpickard,
    15:04:42)
- Andre Fredette (afredette,
    15:04:45)
- Janki (janki,
    15:04:45)
- Aswin Suryanarayanan (aswinsuryan,
    15:04:45)
- Matt Welch (mattw4,
    15:04:49)
- Sridhar Gaddam (sridharg,
    15:04:51)
- odlparent 2.0.2 patches merged to
    netvirt (vpickard,
    15:05:18)
 
 
- karaf 4 (shague, 15:05:23)
  - daya_k (daya_k,
    15:05:46)
- dhcp config changes (shague,
    15:06:43)
- ACTION: vthapr still
    looking if changes are needed (shague,
    15:07:11)
- vthapar has different solution to use neutron
    changes instead (shague,
    15:07:42)
- vthapar to discuss at next neutron northbound
    meeting (shague,
    15:08:44)
- venkat done list bugs NEC is tracking
    (shague,
    15:10:08)
- need to triage those bugs (shague,
    15:10:44)
- 5 new exceptions found (shague,
    15:11:43)
- janki will take 8860 (vpickard,
    15:12:19)
- ACTION: janki to add
    test cases to bug-8684 (shague,
    15:19:36)
- should we freeze code until all exceptions are
    cleared (shague,
    15:22:45)
- https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=82037
    exception list (shague,
    15:22:50)
- merge excpetion related patches and reevaluate
    list (shague,
    15:23:22)
- https://bugs.opendaylight.org/show_bug.cgi?id=8346
    (shague,
    15:25:00)
- rebase and reun csit on patch. it might help
    with the sporadic failures (shague,
    15:25:13)
- likely good to merge patch even if it doesn't
    help excpetion, but adds other pros (shague,
    15:26:41)
 
 
- eos deprecated (shague, 15:28:16)
  - https://lists.opendaylight.org/pipermail/ovsdb-dev/2017-July/004368.html
    (shague,
    15:28:19)
- vthapar: can we get signoff from mdsal to fix
    two existing bugs before migrating to CSS (shague,
    15:28:42)
- need to understand how much work it will take
    to move to CSS, initial feel is it shouldnt be too much (shague,
    15:29:33)
- need to come up with plan if we want to move to
    CSS in Nitrogen (vthapar,
    15:29:48)
- to move to css the two bugs must be
    fixed (shague,
    15:30:56)
- ACTION: anil to track
    eos deprecation and two css bugs (shague,
    15:31:19)
 
 
- deprecate transparent (shague, 15:32:28)
  - stateful andlearn work well now so transparent
    doesn't add much value (shague,
    15:32:45)
- are there other orchestrations beyond Openstack
    that could use transparent (shague,
    15:33:57)
- afredette there might be people using ovs
    offload (shague,
    15:34:33)
- keep thread open until to kow about other
    orchestrations (shague,
    15:37:06)
- does deprecation require the one release
    deprecate process (shague,
    15:37:40)
- csit needs to have tests for using the
    disable-port security (shague,
    15:39:10)
- aswin: says dhcp ports do ahve port-security
    disabled (shague,
    15:39:26)
- sridharg tempest has tests to cover
    scenario (shague,
    15:39:43)
- not running those tempest tests currently, need
    to enable (shague,
    15:39:59)
- ACTION: jamoluhrsen
    to look at enabling tests (shague,
    15:40:28)
 
 
- jamo thinks we might have some regressions in carbon sr1 (shague, 15:41:44)
  - new sporadic failures popping (shague,
    15:42:01)
- ACTION: jamoluhrsen
    identify new failing tests (shague,
    15:42:51)
 
 
- version matrix (shague, 15:45:33)
  - venkat test carbon and ocata (shague,
    15:46:29)
- venkta use osp11 (shague,
    15:47:08)
- venkat use osp11 (shague,
    15:47:15)
- https://lists.opendaylight.org/pipermail/netvirt-dev/2017-July/005030.html
    (shague,
    15:47:36)
- above link is test matrix coverage for ODL and
    Openstack releases (vpickard,
    15:48:10)
- no pike jobs currently (shague,
    15:48:11)
- do we wait for pike or just use openstack
    master (shague,
    15:48:31)
- master jobs will likely fail, but it is good to
    ahve jobs running for visibility (shague,
    15:50:26)
- ACTION: shague
    followup with isaku on networking-odl jobs (shague,
    15:50:58)
 
 
- can snat conntrack be enabled as default (shague, 15:52:12)
  - aswin: there is one patch still open
    (shague,
    15:52:46)
- : https://git.opendaylight.org/gerrit/56709
    gre patch (shague,
    15:52:54)
- daya_k need a job in csit still using
    controller snat (shague,
    15:53:19)
- the current stateful job meets the needs, there
    is a new snat contrack job (shague,
    15:54:12)
- daya_k learn mode can be removed (shague,
    15:56:08)
- ACTION: start thread
    on list to finalize (shague,
    15:57:13)
 
 
- vpickard:l2gw commands not recognized in netvirt csit - plugin looks correct (shague, 15:57:39)
  - gvrangan thinks there might be an openstack cli
    issue (shague,
    15:59:28)
- use the ssh workaround that was added recently
    to run commands from different vm (shague,
    16:00:13)
- openstack cli might not have the l2gw
    commands (shague,
    16:01:16)
-  (shague,
    16:01:48)
- ACTION: gvrangan to
    find workaround (shague,
    16:02:49)
- ACTION: venkat to
    check on neutronclient for netvirt hwvtep csit (vpickard,
    16:02:55)
- ACTION: gvrangan to
    check on neutronclient for netvirt hwvtep csit failures for
    l2-gateway-list command not found (vpickard,
    16:03:48)
 
Meeting ended at 16:07:28 UTC
(full logs).
Action items
  - vthapr still looking if changes are needed
- janki to add test cases to bug-8684
- anil to track eos deprecation and two css bugs
- jamoluhrsen to look at enabling tests
- jamoluhrsen identify new failing tests
- shague followup with isaku on networking-odl jobs
- start thread on list to finalize
- gvrangan to find workaround
- venkat to check on neutronclient for netvirt hwvtep csit
- gvrangan to check on neutronclient for netvirt hwvtep csit failures for l2-gateway-list command not found
Action items, by person
  -  janki 
    - janki to add test cases to bug-8684
 
-  shague 
    - shague followup with isaku on networking-odl jobs
 
- UNASSIGNED
    - vthapr still looking if changes are needed
- anil to track eos deprecation and two css bugs
- jamoluhrsen to look at enabling tests
- jamoluhrsen identify new failing tests
- start thread on list to finalize
- gvrangan to find workaround
- venkat to check on neutronclient for netvirt hwvtep csit
- gvrangan to check on neutronclient for netvirt hwvtep csit failures for l2-gateway-list command not found
 
People present (lines said)
  - shague (68)
- vpickard (7)
- odl_meetbot (3)
- vthapar (2)
- skitt (1)
- daya_k (1)
- aswinsuryan (1)
- afredette (1)
- sridharg (1)
- janki (1)
- mattw4 (1)
Generated by MeetBot 0.1.4.