#opendaylight-netvirt: NetVirt Weekly 08/08/17

Meeting started by shague at 14:59:31 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 14:59:41)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_08_01_17/opendaylight-netvirt-netvirt_weekly_08_01_17.2017-08-01-15.00.html previous actions (shague, 15:00:29)
    2. Vic (vpickard, 15:01:49)
    3. viveknarasimhan provide list of bugs - putting list together (shague, 15:02:07)
    4. jamoluhrsen push tempest debugging patch: https://git.opendaylight.org/gerrit/#/c/60224/ - still wip (shague, 15:02:19)

  2. Carbon SR2 8/17/17 (shague, 15:05:57)
    1. Aswin Suryanarayanan (aswinsuryan, 15:07:09)
    2. acl changes based on boron, but need to be upstreamed and will conflict with master features (shague, 15:08:09)
    3. master has more features (shague, 15:08:21)
    4. dhcp feature needs to be looked at (shague, 15:09:31)
    5. Sridhar Gaddam (sridharg, 15:10:30)

  3. nitrogen (shague, 15:11:45)
    1. remote acl changes being worked by Aswin - thinks they look good (shague, 15:12:33)
    2. dual stack feature is not merged yet (shague, 15:13:41)
    3. single stack patches can be included and fixed to pass csit (shague, 15:15:28)
    4. viveknarasimhan (viveknarasimhan, 15:15:42)
    5. ACTION: viveknarasimhan kiran identify single router patches (shague, 15:16:58)
    6. single router does not have csit test coverage (shague, 15:18:34)
    7. ACTION: viveknarasimhan kiran valentina investigate how to add basic csit for single router code (shague, 15:20:09)
    8. sridharg mentions tempest has a test already (shague, 15:21:10)
    9. ACTION: sridharg email link to tempest tests (shague, 15:23:07)

  4. revert SNAT conntarck pnf patch (shague, 15:25:03)
    1. merged the revert patch since tests passed with it (shague, 15:25:17)

  5. https://bugs.opendaylight.org/show_bug.cgi?id=8895 (shague, 15:26:04)
    1. aswinsuryan to look at soon (shague, 15:26:15)

  6. bug 8859 (shague, 15:29:07)
    1. is problem fully addressed (shague, 15:29:15)

  7. https://bugs.opendaylight.org/show_bug.cgi?id=8918 (shague, 15:30:13)
    1. viveknarasimhan mentions it is an elan issue (shague, 15:30:36)
    2. ACTION: viveknarasimhan assign to elan person (shague, 15:30:50)

  8. downstream patches needed to be upstreamed (shague, 15:33:39)
    1. work is just starting to upstream (shague, 15:33:57)
    2. bug list is being triaged to identify priorities (shague, 15:34:23)
    3. many patches cover high cpu jvm nad other scaling issues (shague, 15:35:19)
    4. 3node cluster has high cpu issues (shague, 15:35:50)
    5. second case are publishing to external entities like bgpvpn (shague, 15:36:58)
    6. triage bug list to prioritize wanted patches (shague, 15:41:05)
    7. ACTION: jamoluhrsen shague add config option to csit for mdsal config for timeout issue (shague, 15:42:44)

  9. acl changes (shague, 15:43:23)
    1. aswinsuryan reviewing slides (shague, 15:43:35)


Meeting ended at 15:52:44 UTC (full logs).

Action items

  1. viveknarasimhan kiran identify single router patches
  2. viveknarasimhan kiran valentina investigate how to add basic csit for single router code
  3. sridharg email link to tempest tests
  4. viveknarasimhan assign to elan person
  5. jamoluhrsen shague add config option to csit for mdsal config for timeout issue


Action items, by person

  1. shague
    1. jamoluhrsen shague add config option to csit for mdsal config for timeout issue
  2. sridharg
    1. sridharg email link to tempest tests
  3. viveknarasimhan
    1. viveknarasimhan kiran identify single router patches
    2. viveknarasimhan kiran valentina investigate how to add basic csit for single router code
    3. viveknarasimhan assign to elan person


People present (lines said)

  1. shague (41)
  2. odl_meetbot (3)
  3. vpickard (1)
  4. viveknarasimhan (1)
  5. sridharg (1)
  6. aswinsuryan (1)


Generated by MeetBot 0.1.4.