#opendaylight-netvirt: NetVirt Weekly 08/22/17

Meeting started by shague at 15:01:55 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:10)
    1. Vishal (vthapar, 15:02:38)
    2. Hanamantagoud (Hanamantagoud, 15:06:30)

  2. Review existing action items (shague, 15:08:12)
    1. daya_k (daya_k, 15:08:16)
    2. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_08_08_17/opendaylight-netvirt-netvirt_weekly_08_08_17.2017-08-08-14.59.html (shague, 15:08:40)
    3. Vic (vpickard, 15:08:53)
    4. Aswin (aswinsuryan, 15:09:03)

  3. jamoluhrsen shague add config option to csit for mdsal config for timeout issue (shague, 15:10:11)
    1. ACTION: jamoluhrsen to try another job with the tell based config in sandbox to make sure it works (jamoluhrsen, 15:11:27)

  4. viveknarasimhan kiran identify single router patches (shague, 15:11:28)
    1. vivek: patches landed but not merged (shague, 15:12:12)
    2. ACTION: vivek to send list of patches (shague, 15:12:53)
    3. patches can go in for nitrogen sr1 (shague, 15:13:24)
    4. viveknarasimhan (viveknarasimhan, 15:15:35)
    5. https://git.opendaylight.org/gerrit/62136 https://git.opendaylight.org/gerrit/62087 (viveknarasimhan, 15:15:36)
    6. https://git.opendaylight.org/gerrit/62136 (shague, 15:15:49)
    7. https://git.opendaylight.org/gerrit/62087 (shague, 15:16:00)

  5. carbon sr2 (shague, 15:18:12)
    1. controller oom patch is breaking ha and holding up release (shague, 15:19:49)

  6. csit exceptions (shague, 15:20:19)
    1. ACTION: jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there (jamoluhrsen, 15:20:43)
    2. bug-8953: kiran: found issue in external network csit (shague, 15:22:47)
    3. datastore for physnet1 network is not being cleaned up (shague, 15:23:45)
    4. ACTION: viveknarasimhan_ kiran to investigate why mdsal is not removing the network (shague, 15:25:24)
    5. viveknarasimhan_ mentions patch that might be able to help with issue (shague, 15:25:42)
    6. https://bugs.opendaylight.org/show_bug.cgi?id=9013 (shague, 15:27:02)
    7. need to work with genius to fix (shague, 15:27:13)
    8. Sridhar Gaddam (sridharg, 15:28:32)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=7826 (shague, 15:28:33)
    10. swati wip on patch (shague, 15:29:06)
    11. ACTION: shague send email to viveknarasimhan_ (shague, 15:29:18)
    12. https://bugs.opendaylight.org/show_bug.cgi?id=7830 (shague, 15:29:51)
    13. viveknarasimhan_: difficult to troubleshoot, needs more investigation (shague, 15:30:22)
    14. duplicate attempts to modify the same flow id (shague, 15:30:40)

  7. exception fail test (shague, 15:33:16)
    1. jamoluhrsen: about to add test to enable failing if exceptions found during a test (shague, 15:33:42)
    2. add check during test teardown debug (shague, 15:34:27)

  8. downstream patches to upstream (shague, 15:35:36)
    1. some patches merged (shague, 15:35:43)
    2. two acl patches remaining (shague, 15:35:56)
    3. are some of the fixes blockers and needed for sr2? (shague, 15:37:09)
    4. ACTION: shague to work with viveknarasimhan_ to identify any for post carbon sr2 (shague, 15:37:34)

  9. dualstack branching (shague, 15:38:29)
    1. three large patch stacks (shague, 15:38:49)
    2. ps1: single router (shague, 15:39:13)
    3. ps2: v4 and v6 routers (shague, 15:39:44)
    4. ps3: enable access to extrnal router (shague, 15:39:57)
    5. ps1 is under review (shague, 15:40:16)
    6. ps2 and ps3 might need a topic branch (shague, 15:40:39)
    7. ACTION: viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3 (shague, 15:41:28)
    8. csit patches have been raised (shague, 15:42:18)

  10. bug 8823 (shague, 15:45:30)
    1. https://git.opendaylight.org/gerrit/#/c/61168/ (shague, 15:45:33)
    2. blocker for carbon sr2 (shague, 15:46:14)
    3. need genius devs to review (shague, 15:47:48)
    4. vthapar concerned with performance (shague, 15:48:23)
    5. patch removes batching and migth lead to performance issues (shague, 15:49:49)
    6. ACTION: vthapar to work with gvrangan_odl on solution (shague, 15:50:41)

  11. yamahata openstack is at end of Pike cycle (shague, 15:51:46)
    1. yamahata: jobs are unstable (shague, 15:52:06)
    2. what branch should be used (shague, 15:52:15)
    3. http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate?panelId=7&fullscreen (yamahata, 15:52:42)
    4. sync carbon with pike (shague, 15:54:10)
    5. pike releases in two weeks. ideally issues should be fixed by then, otherwise by queens early cycle - 1 or 2 months (shague, 15:55:22)
    6. http://grafana.openstack.org/dashboard/db/networking-odl-failure-rate?panelId=7&fullscreen (shague, 15:55:51)

  12. 3node csit (shague, 15:58:19)
    1. downstream ha testing looks good - what is different compared to upstream failing tests (shague, 15:59:23)
    2. vthapar mentions adding cpu logging (shague, 15:59:38)
    3. vthapar asks about haproxy and shard configuration (shague, 16:00:43)
    4. viveknarasimhan_ downstream doesn't use load balancing (shague, 16:01:53)
    5. v1 and v2 are both used in upstream (shague, 16:02:28)
    6. viveknarasimhan_ should only use v2 in upstream (shague, 16:02:40)
    7. ACTION: gvrangan_odl add the shard and leader debugging to tests (shague, 16:03:39)
    8. ACTION: vthapar gvrangan_odl work offline on how to collect debugging (shague, 16:04:02)
    9. vthapar asks how to know when ODL is up and ready for tests (shague, 16:05:05)


Meeting ended at 16:07:38 UTC (full logs).

Action items

  1. jamoluhrsen to try another job with the tell based config in sandbox to make sure it works
  2. vivek to send list of patches
  3. jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
  4. viveknarasimhan_ kiran to investigate why mdsal is not removing the network
  5. shague send email to viveknarasimhan_
  6. shague to work with viveknarasimhan_ to identify any for post carbon sr2
  7. viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3
  8. vthapar to work with gvrangan_odl on solution
  9. gvrangan_odl add the shard and leader debugging to tests
  10. vthapar gvrangan_odl work offline on how to collect debugging


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to try another job with the tell based config in sandbox to make sure it works
    2. jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
  2. shague
    1. shague send email to viveknarasimhan_
    2. shague to work with viveknarasimhan_ to identify any for post carbon sr2
  3. viveknarasimhan_
    1. viveknarasimhan_ kiran to investigate why mdsal is not removing the network
    2. shague send email to viveknarasimhan_
    3. shague to work with viveknarasimhan_ to identify any for post carbon sr2
    4. viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3
  4. vthapar
    1. vthapar to work with gvrangan_odl on solution
    2. vthapar gvrangan_odl work offline on how to collect debugging
  5. UNASSIGNED
    1. vivek to send list of patches
    2. gvrangan_odl add the shard and leader debugging to tests


People present (lines said)

  1. shague (69)
  2. vthapar (6)
  3. vpickard (5)
  4. odl_meetbot (3)
  5. viveknarasimhan (2)
  6. jamoluhrsen (2)
  7. viveknarasimhan_ (1)
  8. daya_k (1)
  9. yamahata (1)
  10. aswinsuryan (1)
  11. Hanamantagoud (1)
  12. sridharg (1)


Generated by MeetBot 0.1.4.