#opendaylight-netvirt: NetVirt Weekly 08/29/17

Meeting started by shague at 15:01:29 UTC (full logs).

Meeting summary

    1. daya_k (daya_k, 15:01:41)

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:42)
    1. daya_k (daya_k, 15:02:05)
    2. Hanamantagoud (Hanamantagoud, 15:03:06)

  2. Review existing action items (shague, 15:03:44)
    1. jamoluhrsen (jamoluhrsen, 15:03:55)

  3. pre created bridge issues (shague, 15:04:37)
    1. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-August/005369.html thread (shague, 15:04:54)
    2. Vic (vpickard, 15:05:49)
    3. Aswin (aswin__, 15:06:12)
    4. timing issues where patch ports created stomp on previous ports in mdsal (shague, 15:06:28)
    5. jhershbe: can ODL take ownership of br-int? (shague, 15:07:28)
    6. jhershbe: external entities cannot change br-int properties after this. (shague, 15:08:04)
    7. can csit be updated to test scenario (shague, 15:15:30)
    8. add br-int before devstack starts (shague, 15:15:41)
    9. ACTION: daya_k to review jhershbe proposal (shague, 15:16:02)
    10. ACTION: jhershbe work on patch (shague, 15:16:10)
    11. ACTION: jamoluhrsen jhershbe look at adding csit test case (shague, 15:16:37)
    12. Kiran (Kiran_, 15:17:10)

  4. [wip] jamoluhrsen to try another job with the tell based config in sandbox to make sure it works (shague, 15:21:05)
    1. many failures with changed setting (shague, 15:21:16)
    2. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-ocata-jamo-upstream-stateful-nitrogen/ <-- 1 node job with tell based (jamoluhrsen, 15:21:30)
    3. https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-3node-openstack-ocata-jamo-upstream-stateful-nitrogen/ <-- 3node tell based job (jamoluhrsen, 15:21:54)
    4. ACTION: jamoluhrsento reply on thread for debugging (shague, 15:21:58)

  5. [wip] vivek to send list of patches for single router to merge (shague, 15:22:16)
    1. [done] (shague, 15:22:39)

  6. [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there (shague, 15:22:53)
    1. ACTION: [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there (shague, 15:23:05)

  7. [wip] viveknarasimhan_ kiran to investigate why mdsal is not removing the network. physnet1 network is not being cleaned up (shague, 15:23:11)
    1. csit tests running for patch (shague, 15:24:30)
    2. https://git.opendaylight.org/gerrit/62186 (shague, 15:24:32)
    3. need to investigate why oxygen tests are failing (shague, 15:26:17)

  8. [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2 (shague, 15:27:28)
    1. vivek working on list (shague, 15:29:31)
    2. ACTION: [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2 (shague, 15:29:42)
    3. vivek looking at l2gw and elan patches (shague, 15:29:58)

  9. [wip] viveknarasimhan_ to talk with 6wind team on plan for ps2 and ps3, do we need a topic branch they can maintain? (shague, 15:30:14)
    1. a branch is requested for the patch sets 2 and 3 (shague, 15:30:32)
    2. ACTION: vivek to followup on if branch is needed (shague, 15:32:41)
    3. need to fix aclservice npe to make progress on master (shague, 15:38:05)
    4. https://git.opendaylight.org/gerrit/#/q/topic:l3vpn-dual-stack-internet (shague, 15:39:50)

  10. [wip][agenda] vthapar to work with gvrangan_odl on solution for bug-8823 - auto tunnels and batching (shague, 15:40:18)
  11. dhcp port allocation feature breaks sr-iov usecase (shague, 15:41:31)
    1. feature is in carbon sr2 and nitrogen (shague, 15:41:51)
    2. likely not a blocker since neutron dhcp agent is the default and does not have problem (shague, 15:42:46)

  12. [wip][agenda] vthapar to work with gvrangan_odl on solution for bug-8823 - auto tunnels and batching (shague, 15:43:08)
    1. discuss during genius call (shague, 15:43:40)
    2. viveknarasimhan (viveknarasimhan, 15:43:43)

  13. [wip] gvrangan_odl add the shard and leader debugging to tests - needed for 3node testing (shague, 15:43:54)
    1. gvrangan__odl to push patch later in week (shague, 15:44:17)

  14. [wip] vthapar gvrangan_odl work offline on how to collect debugging (shague, 15:44:36)
  15. hardware offload support for openvswitch - https://git.opendaylight.org/gerrit/#/c/60259/ (shague, 15:46:12)
    1. odl will only process nw_odl marked ports (shague, 15:50:27)
    2. moshe patch removes the check for these vnic types (shague, 15:50:52)
    3. https://review.openstack.org/#/c/448536/ openstack patch (shague, 15:51:13)
    4. daya_k: l2gw dhcp usecase requires the vnic type check (shague, 15:54:59)
    5. ACTION: moshe to add spec (shague, 16:02:59)
    6. ACTION: spec fo acl reflection (shague, 16:03:38)
    7. https://trello.com/c/lDeLcKB1/39-spec-for-acl-change-reflection-on-existing-communication (shague, 16:03:48)
    8. aswin__ spec looks good, minor comments (shague, 16:04:18)

  16. csit:exceptions (shague, 16:07:35)
    1. ACTION: shague work with vorburger to add logs for bug-8860 (shague, 16:07:54)


Meeting ended at 14:21:13 UTC (full logs).

Action items

  1. daya_k to review jhershbe proposal
  2. jhershbe work on patch
  3. jamoluhrsen jhershbe look at adding csit test case
  4. jamoluhrsento reply on thread for debugging
  5. [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
  6. [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2
  7. vivek to followup on if branch is needed
  8. moshe to add spec
  9. spec fo acl reflection
  10. shague work with vorburger to add logs for bug-8860


Action items, by person

  1. daya_k
    1. daya_k to review jhershbe proposal
  2. jamoluhrsen
    1. jamoluhrsen jhershbe look at adding csit test case
    2. [wip] jamoluhrsen to put a patch to "FAIL" when exceptions occur. we can have a whitelist to not fail on the ones that are currently there
  3. shague
    1. [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2
    2. shague work with vorburger to add logs for bug-8860
  4. UNASSIGNED
    1. jhershbe work on patch
    2. jamoluhrsento reply on thread for debugging
    3. vivek to followup on if branch is needed
    4. moshe to add spec
    5. spec fo acl reflection


People present (lines said)

  1. shague (57)
  2. gvrangan (11)
  3. odl_meetbot (3)
  4. jamoluhrsen (3)
  5. daya_k (2)
  6. vpickard (1)
  7. Kiran_ (1)
  8. viveknarasimhan (1)
  9. aswin__ (1)
  10. Hanamantagoud (1)


Generated by MeetBot 0.1.4.