#opendaylight-netvirt: NetVirt Weekly 09/05/17

Meeting started by shague at 15:01:19 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:01:28)
  2. Review existing action items (shague, 15:01:56)
    1. http://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_08_29_17/opendaylight-netvirt-netvirt_weekly_08_29_17.2017-08-29-15.01.html (shague, 15:02:16)
    2. daya_k (daya_k, 15:02:27)
    3. Aswin (aswin__, 15:04:56)

  3. ACTION: jamoluhrsento reply on thread for debugging - using tell-based config in csit (shague, 15:06:44)
    1. jamoluhrsen replied on thread with issues list (shague, 15:06:57)
    2. needs to be debugged (shague, 15:07:04)
    3. jamoluhrsen (jamoluhrsen, 15:07:28)
    4. ACTION: jamoluhrsen to add releng job so that logs remain (shague, 15:07:32)

  4. ACTION: [wip] shague to work with viveknarasimhan_ to identify any downstream patches needed for post carbon sr2 - nothing done yet (shague, 15:07:51)
    1. wait until sr2 is released (shague, 15:08:16)
    2. viveknarasimhan (viveknarasimhan, 15:08:53)

  5. carbon sr2 (shague, 15:11:17)
    1. branch was reopened without releasing sr2 (shague, 15:11:27)
    2. begin cherry-picking remaining patches (shague, 15:11:39)
    3. kiran to work with devs to post patches (shague, 15:11:49)

  6. ACTION: [wip] moshe to add spec (shague, 15:12:19)
    1. wip (shague, 15:12:22)

  7. ACTION: spec fo acl reflection - needs to be reviewed https://trello.com/c/lDeLcKB1/39-spec-for-acl-change-reflection-on-existing-communication (shague, 15:12:43)
    1. aswin__ and viveknarasimhan had comments, new patch ahs been pushed (shague, 15:13:00)
    2. aswin__ viveknarasimhan to review and +1 (shague, 15:13:17)

  8. ACTION: [wip] shague work with vorburger to add logs for bug-8860 (shague, 15:13:30)
    1. viveknarasimhan added patch to handle excpetion but not fix root cause (shague, 15:14:32)
    2. abhinav will push a fix (shague, 15:14:51)

  9. ACTION: daya_k to review jhershbe proposal for br-int [62347](https://git.opendaylight.org/gerrit/#/c/62347/) [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-August/005369.html) (shague, 15:15:38)
    1. daya and vishal had concerns over node-id (shague, 15:16:04)
    2. node id is set depending on active or passive conenction (shague, 15:16:20)
    3. how to handle reconciliation use cases (shague, 15:17:34)
    4. https://git.opendaylight.org/gerrit/#/c/62347/ (shague, 15:20:38)
    5. ACTION: vishal to review patch (shague, 15:21:49)
    6. have option to add id for bridges if needed, similar to port and node external iid's (shague, 15:22:17)
    7. request help from Michael on fixing build issue on ACL bug: https://git.opendaylight.org/gerrit/#/c/62458/ (viveknarasimhan, 15:22:22)

  10. ACTION: jamoluhrsen jhershbe look at adding csit test case for testing proposal (shague, 15:23:31)
  11. bug-8860 (shague, 15:24:26)
    1. ask vorburger to verify fix downstream (shague, 15:24:36)

  12. nitrogen release planning (shague, 15:24:54)
    1. possibly to delay (shague, 15:25:36)
    2. ACTION: jamoluhrsen to move carbon blockers to nitrogen (shague, 15:26:04)

  13. Pike CSIT (shague, 15:27:35)
    1. blocker bug for vif plugging status (shague, 15:27:51)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=9092 (shague, 15:28:22)
    3. disabling port status doesn't seem to be helping (shague, 15:29:40)
    4. anil belur needs tomerge pike vm's (shague, 15:30:29)
    5. then merge releng patch (shague, 15:30:49)

  14. https://bugs.opendaylight.org/show_bug.cgi?id=9086 (shague, 15:31:42)
    1. https://bugs.opendaylight.org/show_bug.cgi?id=9086 (shague, 15:31:44)
    2. openflowplugin looking at issue (shague, 15:31:52)
    3. issue with config and operational differences (shague, 15:33:23)

  15. prioritize [csit:exception](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=81703) [sporadic failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=82353) 7380: under review, failing UT, 7826: debugging patch, 7830: no progress, 8860: under review tohelp with excpetion, but does not fix issue, 9013: confusion on (shague, 15:34:29)
    1. bug-7830 - kerthikeyan has fix that needs more review (shague, 15:35:30)
    2. viveks first patch is failing UT - shague looking at (shague, 15:35:40)
    3. retest with opnfv when patches are merged (shague, 15:36:21)
    4. bug-7826 : swati needs mroe debugging (shague, 15:49:54)
    5. bug-8860: patch coming in couple days (shague, 15:50:51)
    6. bug-9013: new exceptions in patch (shague, 15:51:04)

  16. ddf (shague, 15:59:22)
    1. others still thinking (shague, 15:59:31)

  17. trigger to run 3node test-patch (shague, 16:00:35)
    1. ACTION: jamoluhrsen to add 3node trigger (shague, 16:00:44)


Meeting ended at 16:07:40 UTC (full logs).

Action items

  1. jamoluhrsen to add releng job so that logs remain
  2. vishal to review patch
  3. jamoluhrsen to move carbon blockers to nitrogen
  4. jamoluhrsen to add 3node trigger


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to add releng job so that logs remain
    2. jamoluhrsen to move carbon blockers to nitrogen
    3. jamoluhrsen to add 3node trigger


People present (lines said)

  1. shague (61)
  2. viveknarasimhan (3)
  3. odl_meetbot (3)
  4. daya_k (1)
  5. aswin__ (1)
  6. jamoluhrsen (1)


Generated by MeetBot 0.1.4.