#opendaylight-netvirt: NetVirt Weekly 10/24/17

Meeting started by shague at 15:02:26 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 15:02:41)
  2. Review existing action items (shague, 15:02:43)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_17_17/opendaylight-netvirt-netvirt_weekly_10_17_17.2017-10-17-15.01.html (shague, 15:02:51)
    2. [Review previous minutes](https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_17_17/opendaylight-netvirt-netvirt_weekly_10_17_17.2017-10-17-15.01.html) (shague, 15:03:18)
    3. Vishal (vthapar, 15:03:59)
    4. jamoluhrsen (jamoluhrsen, 15:04:15)
    5. Vic (vpickard, 15:04:22)
    6. Janki Chhatbar (janki, 15:05:26)
    7. Hanamantagoud (Hanamantagoud, 15:05:32)
    8. siva to report bug (shague, 15:05:49)
    9. jhershbe (jhershbe, 15:05:52)
    10. sridharg to meet with e/// team to dicsuss changes (shague, 15:06:33)

  3. shague to look at https://bugs.opendaylight.org/show_bug.cgi?id=9149 [jira](https://jira.opendaylight.org/browse/NETVIRT-905) - unable to reproduce in latest jobs (shague, 15:06:51)
    1. Sridhar Gaddam (sridharg, 15:07:06)
    2. ACTION: jamoluhrsen to doublecheck (shague, 15:07:33)
    3. daya_k (daya_k, 15:07:44)
    4. ACTION: jamoluhrsen to doublecheck bug 9149 (jamoluhrsen, 15:07:45)

  4. jamoluhrsen, shague, Hanamantagoud, kiran to start email with openflowplugin - [thread](https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-October/007746.html) (shague, 15:07:46)
  5. shague initial triage at 3node tests - no progress yet (shague, 15:08:22)
  6. janki need to look at tempest test case - initial triage and root cause found [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-October/005683.html) (shague, 15:08:36)
    1. janki found config issue needed for the one failing test (shague, 15:09:22)

  7. https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning - SR1 10/26/17 (shague, 15:13:36)
  8. Jira migration is complete (shague, 15:14:08)
  9. Spec reviews should include CSIT updates as mandatory. Code should not merge until CSIT tests are written. (shague, 15:20:24)
    1. by time code is to be merged, there should be a CSIT patch to verify the code (shague, 15:21:41)
    2. how to create CSIT tests for features spanning multiple patches (shague, 15:22:51)
    3. possibly create a feature specific job (shague, 15:23:05)
    4. does this change infra (shague, 15:24:47)

  10. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 15:27:45)
  11. [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - [bug-7826](https://bugs.opendaylight.org/show_bug.cgi?id=7826) - openflowplugin patch was abandoned, new patch [63896](https://git.opendaylight.org/gerrit/63896) (shague, 15:28:23)
    1. sunil making progress, recreating locally to further debug (shague, 15:28:46)

  12. [bug-9245]() - [NETVIRT-940](https://jira.opendaylight.org/browse/NETVIRT-940) - [gerrit 64382](https://git.opendaylight.org/gerrit/64382) (shague, 15:29:34)
    1. fix will cover all table 21 bugs, NETVIRT-940 and 946 (shague, 15:31:11)

  13. [bug-9297](https://bugs.opendaylight.org/show_bug.cgi?id=9297) - adjacency]} does not exist - [NETVIRT-959](https://jira.opendaylight.org/browse/NETVIRT-959) (shague, 15:32:05)
    1. Hanamantagoud fip is present but no adjacency is found (shague, 15:32:45)
    2. looks like fip is moving from node to node (shague, 15:33:03)
    3. Hanamantagoud requested help from NAT guys (shague, 15:33:57)

  14. [bug-9298](https://bugs.opendaylight.org/show_bug.cgi?id=9298) - port-name=e21f56c9-1513-4753-bf40-f9d391c45658}] does not exist - [NETVIRT-960](https://jira.opendaylight.org/browse/NETVIRT-960) (shague, 15:36:14)
    1. Cheta is out will look when back (shague, 15:37:02)

  15. [gerrit 64124](https://git.opendaylight.org/gerrit/64124) - Updated to use bind-service update instead of bind and unbind in Acl VPN - listener - doesn't seem to help with [NETVIRT-962](https://jira.opendaylight.org/browse/NETVIRT-962) or [NETVIRT-963](https://jira.opendaylight.org/browse/NETVIRT-963) - shold we still commit if change is useful? (shague, 15:37:17)
    1. Aswin doublecheck (shague, 15:38:39)

  16. L2GW CSIT - Move BGP VPN service into it's own CSIT so we can make L2GW CSIT gating for HWVTEP and L2GW related patches (shague, 15:38:52)
    1. vpnservice suites are in both netvirt and l2gw - should it be removed from l2gw (shague, 15:39:47)
    2. should bgpvpn be moved to genius? (shague, 15:40:01)
    3. no, it is netvirt suite. (vthapar, 15:40:46)
    4. vthapar bgpvpn should not be in the netvirt or l2gw suite (shague, 15:42:15)
    5. daya_k bgpvpn is not decoupled from l3 so it will cause issues if not ran as part of the full suite (shague, 15:42:53)
    6. l2gw should not have bgpvpn (shague, 15:44:04)
    7. need to decide then where bgpvpn should be - in netvirt basic suite or in separate suite (shague, 15:44:32)
    8. ACTION: jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw (shague, 15:45:42)
    9. use the new feature job (shague, 15:46:22)
    10. vpnservice suites should remain in netvirt. (shague, 15:47:22)
    11. ACTION: vpickard to push patch to remove vpnservice suite from l2gw (shague, 15:47:40)
    12. vthapar should l2gw gates be ran on all patches? (shague, 15:49:00)
    13. all ovsdb hwvtep patches should run the l2gw gate (shague, 15:50:04)
    14. how to identify what netvirt patches should run l2gw gates (shague, 15:50:25)
    15. most code has l2gw or hwvtep in the patch so that can be used as a guide (shague, 15:51:12)

  17. Auto transport zone, Auto tunnels, and L2GW https://bugs.opendaylight.org/show_bug.cgi?id=7743 (shague, 15:52:26)
    1. l2gw does not full support the autotunnel feature (shague, 15:54:50)
    2. also seeing issues in basic netvirt around autotunnel, timing issues (shague, 15:55:43)
    3. should we disable autotunnel and use other mechanism to create the zone and full tunnel mesh (shague, 15:56:33)
    4. port-status has issues in clustered setup, this is needed for auto-tunnels to work (shague, 15:57:43)
    5. jhershbe patches have been pushed to fix port-status clustering issues. need to be verified (shague, 15:58:11)
    6. restconf is combersome (shague, 15:59:26)
    7. genius autotunnel is easier to use (shague, 15:59:39)
    8. look at genius spec for autotunnel (shague, 16:01:17)
    9. daya_k no work is needed in l2gw if the genius autotunnel is used (shague, 16:02:08)
    10. ACTION: vpickard to vrify the genius autotunnel (shague, 16:02:45)
    11. http://docs.opendaylight.org/en/stable-nitrogen/submodules/genius/docs/specs/itm-tunnel-auto-config.html (shague, 16:03:04)
    12. after vpickard verifies genius autotunnel, need to continue discussion to decide if we can move to genius autotunnel (shague, 16:06:25)

  18. clustering topics (shague, 16:07:34)
    1. daya_k to start email with ideas discussed at dDF (shague, 16:07:45)


Meeting ended at 16:08:48 UTC (full logs).

Action items

  1. jamoluhrsen to doublecheck
  2. jamoluhrsen to doublecheck bug 9149
  3. jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw
  4. vpickard to push patch to remove vpnservice suite from l2gw
  5. vpickard to vrify the genius autotunnel


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to doublecheck
    2. jamoluhrsen to doublecheck bug 9149
    3. jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw
  2. vpickard
    1. vpickard to push patch to remove vpnservice suite from l2gw
    2. vpickard to vrify the genius autotunnel


People present (lines said)

  1. shague (66)
  2. odl_meetbot (3)
  3. jamoluhrsen (3)
  4. vthapar (2)
  5. sridharg (2)
  6. janki (2)
  7. vpickard (1)
  8. jhershbe (1)
  9. daya_k (1)
  10. Hanamantagoud (1)


Generated by MeetBot 0.1.4.