#opendaylight-netvirt: NetVirt Weekly 11/07/17

Meeting started by shague at 16:01:43 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:01:57)
  2. Review existing action items (shague, 16:01:59)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_10_31_17/opendaylight-netvirt-netvirt_weekly_10_31_17.2017-10-31-15.03.html (shague, 16:02:07)
    2. Hanamantagoud (Hanamantagoud, 16:02:07)
    3. Vic Pickard (vpickard, 16:02:19)

  3. [DONE] Action: jamoluhrsen: verify if bug still present [NETVIRT-905](https://jira.opendaylight.org/browse/NETVIRT-905) - bug is not present, bug resolved (shague, 16:02:55)
    1. jamoluhrsen (jamoluhrsen, 16:03:00)

  4. ACTION: jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw (shague, 16:03:11)
    1. wip ACTION: jamoluhrsen to create a new job for the bgpvpn suite, remove from l2gw (shague, 16:03:32)
    2. job will be used for sandbox for new features (shague, 16:03:45)
    3. can we remove stateful from job names (shague, 16:04:56)
    4. shague would prefer to keep jobs a little longer (shague, 16:05:06)

  5. ACTION: jamoluhrsen add genius autotunnel to netvirt suite (shague, 16:05:22)
    1. vpickard vthapar debugged hwvtep autotunnel csit, found ovsdb node is restarted (shague, 16:06:06)
    2. vpickard changes to remove restart, good progress (shague, 16:06:29)
    3. vpickard made changes to netvirt csit to enable autotunnel (shague, 16:06:53)
    4. not just restarted, but recreated bridge etc. everything. (vthapar, 16:06:55)
    5. New feature - ITM refactoring - address genius auto-tz to handle dpnid changes. Planned, need to figure out when it will be available.. discussed in last ODL DFG. (shague, 16:07:13)
    6. Need genius csit to test auto-tz use cases (shague, 16:07:50)
    7. the auto-tz genius csit will cover the other use cases (shague, 16:08:33)
    8. l2gw tests did nto need the recreate steps (shague, 16:09:30)
    9. netvirt jobs with auto-tx enabled: (shague, 16:09:59)
    10. Netvirt CSIT runs in progress using genius auto-tz https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-pike-upstream-stateful-carbon/3/console https://jenkins.opendaylight.org/sandbox/job/netvirt-csit-1node-openstack-pike-upstream-stateful-nitrogen/3/consoleFull (shague, 16:10:01)
    11. ACTION: vpickard jamoluhrsen verifying the sandbox jobs are working (shague, 16:11:10)

  6. Action: jamoluhrsen to file a jira issue to help track the odl crashing problem (shague, 16:12:03)
    1. issue resolved, OS images have problems with ODL (shague, 16:12:29)
    2. new centos vm created (shague, 16:12:53)
    3. jamoluhrsen latest jobs using new image are looking good (shague, 16:14:21)

  7. https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning - SR1 10/26/17 (shague, 16:14:37)
    1. blocker bugs requrie respin, need retest (shague, 16:15:08)
    2. ACTION: jamoluhrsen update tracking sheet (shague, 16:15:32)

  8. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 16:15:42)
  9. [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - [bug-7826](https://bugs.opendaylight.org/show_bug.cgi?id=7826) - openflowplugin patch was abandoned, new patch [63896](https://git.opendaylight.org/gerrit/63896) - patch merged on carbon, still need cherry-picks to nitrogen and master, Anil might be helping (shague, 16:15:58)
    1. patch needs cherry-pick to nitrogen and carbon (shague, 16:16:43)
    2. anil and sunil to work on cherry-pick (shague, 16:16:52)

  10. [bug-9297](https://bugs.opendaylight.org/show_bug.cgi?id=9297) - adjacency]} does not exist - [NETVIRT-959](https://jira.opendaylight.org/browse/NETVIRT-959) - CSIT looking good so far, run again to be sure (shague, 16:17:18)
    1. latest csit looking good (shague, 16:17:28)
    2. shague to add more queens jobs (shague, 16:17:55)

  11. [bug-9298](https://bugs.opendaylight.org/show_bug.cgi?id=9298) - port-name=e21f56c9-1513-4753-bf40-f9d391c45658}] does not exist - [NETVIRT-960](https://jira.opendaylight.org/browse/NETVIRT-960) - chetan pushed https://git.opendaylight.org/gerrit/#/c/64930/ - running csit to verify, had tempest failures, need to rerun (shague, 16:18:44)
    1. last csit run tempest test passed (shague, 16:19:09)
    2. run more times to verify (shague, 16:19:15)
    3. cehck if queens is needed (shague, 16:19:34)

  12. https://jira.opendaylight.org/browse/NETVIRT-972 (shague, 16:20:28)
    1. not seen recently, close if not seen (shague, 16:20:53)

  13. https://jira.opendaylight.org/browse/NETVIRT-971 (shague, 16:21:14)
    1. not seen recently, close if not seen (shague, 16:21:17)

  14. https://jira.opendaylight.org/browse/NETVIRT-942 (shague, 16:21:28)
    1. not seen recently, close if not seen (shague, 16:21:30)

  15. vthapar: CSIT requirement in new specs [test template](https://git.opendaylight.org/gerrit/65081) - [rendered html](https://logs.opendaylight.org/releng/jenkins092/docs-rtd-verify-oxygen/330/html/submodules/genius/docs/testplans/index.html) (shague, 16:22:07)
    1. vivekn add test table (shague, 16:25:32)
    2. devs initially should write expected steps, int/test devs can review and help with actual robot code (shague, 16:28:02)
    3. daya is there a overall doc that lists all suites and tests (shague, 16:29:08)
    4. daya add gate identification section (shague, 16:32:26)
    5. add suite identification section - what suite should test be part of, should it be in gates... (shague, 16:33:15)
    6. vthapar: need to document existing tests (shague, 16:34:38)
    7. does the [Documentation] get pulled into a html doc? (shague, 16:37:29)
    8. jamoluhrsen: yes it can be rendered to an html doc (shague, 16:37:58)
    9. need to add hook to automatically generate the html (shague, 16:38:46)
    10. http://opendaylight.readthedocs.io/en/latest/_static/integration/robot/DevstackUtils.robot.html <-- how we autogenerate robot test libs (jamoluhrsen, 16:39:04)
    11. ACTION: jamoluhrsen look into test doc generation (shague, 16:42:59)

  16. start reviewing specs (shague, 16:45:28)
    1. new spec for evpn support (shague, 16:46:03)
    2. spec for weighted napt selection (shague, 16:46:19)
    3. need to review https://trello.com/c/QBPzg5Uw/40-hardware-offload-support-for-openvswitch (shague, 16:46:54)

  17. daya: updating the csit environments (shague, 16:47:43)
    1. ovs updates, hardware offload (shague, 16:48:02)
    2. http://docs.opendaylight.org/en/stable-carbon/submodules/netvirt/docs/user-guide/support.html?highlight=verified%20combinations <-- ovs/odl/openstack support matrix (jamoluhrsen, 16:48:38)
    3. ACTION: daya to send email with list of updates (shague, 16:49:40)
    4. daya: vpn datapath tests are coming soon - they will need ovs 2.8 (shague, 16:50:31)
    5. daya: bundles, resync can bet tested with ovs 2.6 (shague, 16:51:07)
    6. jamoluhrsen: openflowplugin should have csit for testing budles (shague, 16:51:25)
    7. jamoluhrsen: openflowplugin should have csit for testing bundles (shague, 16:51:29)

  18. manjeet: n-odl gate jobs for upgrade (shague, 16:52:31)
    1. manjeet: grenade job not passing (shague, 16:53:01)
    2. http://logs.openstack.org/33/501833/13/check/networking-odl-grenade-dsvm/c43b5af/logs/old/local_conf.txt.gz (shague, 16:53:36)
    3. https://lists.opendaylight.org/pipermail/netvirt-dev/2017-November/005711.html (shague, 16:53:48)
    4. local tests work with different config (shague, 16:54:48)
    5. works locally, but neither config works in gate (shague, 16:55:17)


Meeting ended at 16:58:41 UTC (full logs).

Action items

  1. vpickard jamoluhrsen verifying the sandbox jobs are working
  2. jamoluhrsen update tracking sheet
  3. jamoluhrsen look into test doc generation
  4. daya to send email with list of updates


Action items, by person

  1. jamoluhrsen
    1. vpickard jamoluhrsen verifying the sandbox jobs are working
    2. jamoluhrsen update tracking sheet
    3. jamoluhrsen look into test doc generation
  2. vpickard
    1. vpickard jamoluhrsen verifying the sandbox jobs are working


People present (lines said)

  1. shague (74)
  2. jamoluhrsen (4)
  3. odl_meetbot (3)
  4. vpickard (1)
  5. vthapar (1)
  6. Hanamantagoud (1)


Generated by MeetBot 0.1.4.