#opendaylight-netvirt: NetVirt Weekly 11/14/17

Meeting started by shague at 16:02:49 UTC (full logs).

Meeting summary

    1. jamoluhrsen (jamoluhrsen, 16:02:53)

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:02:59)
  2. Review existing action items (shague, 16:03:00)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_11_07_17/opendaylight-netvirt-netvirt_weekly_11_07_17.2017-11-07-16.01.html (shague, 16:03:13)
    2. daya_k (daya_k, 16:03:27)
    3. Vishal (vthapar, 16:03:50)
    4. Aswin Suryanarayanan (aswins, 16:04:10)

  3. [Review previous minutes](http://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_11_07_17/opendaylight-netvirt-netvirt_weekly_11_07_17.2017-11-07-16.01.html) (shague, 16:04:16)
    1. Janki Chhatbar (janki, 16:04:20)

  4. vpickard jamoluhrsen verifying the sandbox jobs are working for auto-tz (shague, 16:04:35)
    1. jamoluhrsen jobs looking good (shague, 16:04:45)
    2. jamoluhrsen don't want to lose coverage of dynamic tunnels if we change to auto-tz (shague, 16:05:12)
    3. vpickard auto-tz does not cover changing dpid (shague, 16:05:38)
    4. similar to when ovsdb node reboots - without tep id (shague, 16:06:05)
    5. HELP: need to test reboot scenarios (shague, 16:06:57)
    6. vthapar should add test cases to genius (shague, 16:07:29)
    7. vthapar issue is deleting bridge and adding it back in (shague, 16:07:59)
    8. daya_k need to understand all use cases using auto-tz (shague, 16:09:45)
    9. ACTION: vpickard vthapar work to understand restart use cases (shague, 16:14:50)
    10. ACTION: jamoluhrsen switch default for oxygen to use auto-tz (shague, 16:15:10)
    11. ACTION: jamoluhrsen leave carbon job with netvirt auto-tunnel as default (shague, 16:15:37)
    12. ACTION: jamoluhrsen add genius auto-tz job (shague, 16:16:40)
    13. Andre Fredette (afredette, 16:17:21)

  5. jamoluhrsen update nitrogen sr1 tracking sheet [tracking sheet](https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=546991363) (shague, 16:21:28)
    1. jamoluhrsen finish sheet today (shague, 16:21:46)
    2. ACTION: vthapar jamoluhrsen use Genius auto tunnel for opnstack master/queen job, rest to continue netvirt auto-tunnel (vthapar, 16:21:51)
    3. ACTION: jamoluhrsen to move pike/queens jobs to genius auto-tunnel, leave ocata jobs to netvirt auto-tunnel (daya_k, 16:21:57)

  6. [DONE] jamoluhrsen look into test doc generation - email discussion ongoing (shague, 16:22:43)
  7. [DONE] daya to send email with list of updates (shague, 16:22:59)
  8. add exception checking logic to CSIT test cases? (shague, 16:23:13)
    1. add whitelist and enable exception test (shague, 16:26:48)

  9. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 16:27:46)
  10. [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - carbon patch merged, looks good. Need nitrogen and master patches (shague, 16:28:02)
    1. carbon looks to have problem again (shague, 16:28:10)

  11. [NETVIRT-987](https://jira.opendaylight.org/browse/NETVIRT-987) - l3 flow bugs. Still many variations. (shague, 16:29:41)
  12. [NETVIRT-994](https://jira.opendaylight.org/browse/NETVIRT-994) - SelectNewNAPTSwitch (shague, 16:30:44)
    1. chetan to look at bug (shague, 16:31:49)

  13. Jira and Gerrit Workflow Suggestions - [list email](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-November/005774.html) (shague, 16:32:12)
  14. https://trello.com/c/QBPzg5Uw/40-hardware-offload-support-for-openvswitch-sriov-hardware-offload (shague, 16:35:00)
    1. shague do these patches help any? These patches were for supporting vpp (shague, 16:43:44)
    2. https://git.opendaylight.org/gerrit/#/c/50259/ (shague, 16:43:47)
    3. https://git.opendaylight.org/gerrit/#/c/53632/ (shague, 16:44:00)
    4. running netvirt gates on current patch (shague, 16:55:08)
    5. new patch will be pushed and gates ran again for comparison (shague, 16:55:27)
    6. daya_k asks what does the hw offload feature support (shague, 16:59:04)
    7. sg's are disabled (shague, 16:59:16)

  15. findbugs (shague, 17:04:35)
    1. tomp finding issues (shague, 17:04:49)
    2. ACTION: shague to merge findbug patches (shague, 17:10:54)


Meeting ended at 17:11:01 UTC (full logs).

Action items

  1. vpickard vthapar work to understand restart use cases
  2. jamoluhrsen switch default for oxygen to use auto-tz
  3. jamoluhrsen leave carbon job with netvirt auto-tunnel as default
  4. jamoluhrsen add genius auto-tz job
  5. vthapar jamoluhrsen use Genius auto tunnel for opnstack master/queen job, rest to continue netvirt auto-tunnel
  6. jamoluhrsen to move pike/queens jobs to genius auto-tunnel, leave ocata jobs to netvirt auto-tunnel
  7. shague to merge findbug patches


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen switch default for oxygen to use auto-tz
    2. jamoluhrsen leave carbon job with netvirt auto-tunnel as default
    3. jamoluhrsen add genius auto-tz job
    4. vthapar jamoluhrsen use Genius auto tunnel for opnstack master/queen job, rest to continue netvirt auto-tunnel
    5. jamoluhrsen to move pike/queens jobs to genius auto-tunnel, leave ocata jobs to netvirt auto-tunnel
  2. shague
    1. shague to merge findbug patches
  3. vthapar
    1. vpickard vthapar work to understand restart use cases
    2. vthapar jamoluhrsen use Genius auto tunnel for opnstack master/queen job, rest to continue netvirt auto-tunnel


People present (lines said)

  1. shague (43)
  2. odl_meetbot (3)
  3. daya_k (2)
  4. vthapar (2)
  5. jamoluhrsen (1)
  6. janki (1)
  7. aswins (1)
  8. afredette (1)


Generated by MeetBot 0.1.4.