#opendaylight-netvirt: NetVirt Weekly 11/28/17

Meeting started by shague at 16:03:56 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:04:05)
  2. Review existing action items (shague, 16:04:07)
    1. Vishal (vthapar, 16:04:10)
    2. vpickard (vpickard, 16:04:15)
    3. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_11_21_17/opendaylight-netvirt-netvirt_weekly_11_21_17.2017-11-21-16.03.html (shague, 16:04:15)
    4. Sridhar Gaddam (sridharg, 16:04:29)
    5. Hanamantagoud (Hanamantagoud, 16:04:34)

  3. [DONE] ELAN and L2GW contributors to review https://git.opendaylight.org/gerrit/#/c/65520 - CSIT passed, merged (shague, 16:05:46)
  4. Vivek to review the router-gw-mac related to upgradeability (shague, 16:06:04)
  5. jamo to send the order of suites in the current oxygen upstream job (shague, 16:06:31)
    1. wip (shague, 16:07:06)

  6. Hanumant / Vivek to assign the 1-node exception bugs assigned to right folks (shague, 16:07:22)
    1. Hanamantagoud did bug scrub and assigned exception bugs, next to look at 3node (shague, 16:07:51)

  7. [DONE] Michael to send a pointer to netvirt-dev for retry-genius method for OptimisticLockException related 1-node exception bugs - [thread](https://lists.opendaylight.org/pipermail/netvirt-dev/2017-November/005829.html) (shague, 16:08:08)
    1. elan team has conflict with Michael's patches (shague, 16:08:31)
    2. thought is that Michael's patches woudl fix elan issues (shague, 16:09:44)
    3. Hanamantagoud to work with Swati and elan team to review patches (shague, 16:10:32)

  8. Sunil to look into upstream bug and provide update [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) (shague, 16:12:58)
    1. Sunil mentioned a stats issue (shague, 16:13:52)

  9. [WIP] vishal, daya, abhinav to review hw-offload code-patch reviews - [spec patch](https://git.opendaylight.org/gerrit/#/c/62481/) (shague, 16:15:08)
    1. need to review gate jobs ran on impl patch (shague, 16:16:31)
    2. need to rerun gates on latest impl patches (shague, 16:16:42)
    3. ACTION: shague run gate also with https://git.opendaylight.org/gerrit/#/q/I65644f32551124c61e30c02831ac4193d12471d2 (shague, 16:18:07)
    4. https://git.opendaylight.org/gerrit/60259 (shague, 16:18:17)
    5. ocata or pike should be ok (shague, 16:19:05)

  10. https://trello.com/c/iD2fOfF1/16-nitrogen-release-planning (shague, 16:19:32)
    1. shague to start merging nitrogen patches (shague, 16:20:02)
    2. viveknarasimhan (viveknarasimhan, 16:20:22)
    3. ipv6, dualstack patches need to be on nitrogen (shague, 16:21:14)
    4. viveknarasimhan to work offline to identify remaining 6 dualstack patches and conflicts (shague, 16:32:21)

  11. bug scrub [jira query exception](https://jira.opendaylight.org/issues/?filter=10116) - [bugzilla query for exceptions](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Aexception%22&list_id=75946) - [jira query failures](https://jira.opendaylight.org/issues/?filter=10118) - [bugzilla query sporadic_failures](https://bugs.opendaylight.org/buglist.cgi?quicksearch=sw%3A%22csit%3Asporadic_failures%22&list_id=75946) (shague, 16:40:36)
  12. [NETVIRT-993](https://jira.opendaylight.org/browse/NETVIRT-993) - VrfEntryListener: OptimisticLockFailedException: (shague, 16:45:20)
  13. [NETVIRT-972](https://jira.opendaylight.org/browse/NETVIRT-972) - flow/flow...id=L3.17727960133108.21.fc5d2787-75f1-4509-88aa-c55132567d69.42.50.0.0.11, id=L3.110886530182186.21.98987c53-48e6-4545-b63c-7d1d3c3a6ee1.138.2001:db8:0:3:f816:3eff:fe3e:1bdf (shague, 16:45:42)
    1. Hanamantagoud work with shague on running snat gates, though stateful has the table 21 issues (shague, 16:48:14)
    2. viveknarasimhan Hanamantagoud sync up on table 21 patches (shague, 16:53:24)
    3. viveknarasimhan mentions vm cidrs shoudl be different issues (shague, 16:54:00)

  14. [NETVIRT-1023](https://jira.opendaylight.org/browse/NETVIRT-1023) - ItmTepRemoveWorker (shague, 16:54:27)
  15. Faseela's bind/unbind patches - what is left? Which branches? (shague, 16:58:33)
    1. patches need tobe on master and nitrogen (shague, 17:00:40)
    2. netvirt patches need to go in before genius patches (shague, 17:01:11)

  16. Genius auto-tz update. OVS restart worked with both netvirt and genius auto tz. Reboot verification: WIP on OOO setup. Next: switch oxygen to genius auto-tz. (shague, 17:01:34)
    1. reboot case is last use case to check. (shague, 17:02:31)
    2. vpickard has csit patches to update for auto-tz (shague, 17:06:29)

  17. [NETVIRT-1019](https://jira.opendaylight.org/browse/NETVIRT-1019) - CSIT Sporadic failures - port leak in tempest suite (shague, 17:06:49)
    1. pike is leaking resources (shague, 17:08:13)


Meeting ended at 17:09:00 UTC (full logs).

Action items

  1. shague run gate also with https://git.opendaylight.org/gerrit/#/q/I65644f32551124c61e30c02831ac4193d12471d2


Action items, by person

  1. shague
    1. shague run gate also with https://git.opendaylight.org/gerrit/#/q/I65644f32551124c61e30c02831ac4193d12471d2


People present (lines said)

  1. shague (42)
  2. odl_meetbot (3)
  3. vpickard (1)
  4. viveknarasimhan (1)
  5. vthapar (1)
  6. sridharg (1)
  7. Hanamantagoud (1)


Generated by MeetBot 0.1.4.