#opendaylight-netvirt: NetVirt Weekly 01/09/18

Meeting started by shague at 16:03:14 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:03:24)
  2. Review existing action items (shague, 16:03:25)
    1. https://meetings.opendaylight.org/opendaylight-netvirt/2017/netvirt_weekly_12_19_2017/opendaylight-netvirt-netvirt_weekly_12_19_2017.2017-12-19-16.02.html (shague, 16:03:34)
    2. vpickard' (vpickard, 16:03:35)
    3. vpickard (vpickard, 16:03:52)
    4. jhershbe (jhershbe, 16:03:57)
    5. vorburger (vorburger, 16:04:04)

  3. [WIP] - daya to look one final time at hw offload spec - [spec](https://git.opendaylight.org/gerrit/#/c/62481/) - [sriov-hardware-offload](https://git.opendaylight.org/gerrit/#/q/topic:sriov-hardware-offload+(status:open+OR+status:merged) (shague, 16:05:00)
    1. janki (janki, 16:05:04)
    2. daya's comments were addressed (shague, 16:05:38)
    3. Sridhar Gaddam (sridharg, 16:05:56)
    4. likely merge spec, shague do one final review (shague, 16:06:01)
    5. more patches to review for the impl (shague, 16:07:06)

  4. [WIP] - vthapar to follow up with vpickard on 3 issues on the genius auto-tz switch https://jira.opendaylight.org/browse/NETVIRT-1041 https://jira.opendaylight.org/browse/OVSDB-444 Other issue was with netvirt dyn tunnels, which I was not able to reproduce, so only 2 related to genius auto-tz. (shague, 16:07:24)
    1. vpickard ostly ready, one item still open: https://jira.opendaylight.org/browse/NETVIRT-1041 (shague, 16:08:20)
    2. problem is only present on an odl ds wipe (shague, 16:10:49)
    3. workaround is available, so can merge (shague, 16:11:29)
    4. ACTION: vpickard add workaround to bug (shague, 16:12:18)
    5. other bug, https://jira.opendaylight.org/browse/OVSDB-444 - bug for reboots should be fixed, but not related to auto-tz changes (shague, 16:14:11)
    6. vthapar: https://jira.opendaylight.org/browse/OVSDB-439 could be related (shague, 16:17:34)

  5. Carbon sr3 - build is out - Jamo can you sign off on failures? [tracking sheet](https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633) (shague, 16:18:10)
    1. dhcp bug and sg networking-odl open (shague, 16:22:20)
    2. keep dhcp bug as blocker and hold release (shague, 16:23:34)

  6. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - M3 12/21/17 Feature Freeze - Need to have specs reviewed (shague, 16:23:48)
    1. update hwoffload and chaining specs (shague, 16:24:44)
    2. other specs unde review (shague, 16:24:49)
    3. add hanamant to https://git.opendaylight.org/gerrit/#/c/65948/ (shague, 16:26:39)
    4. M4: 01/21/18: Code Freeze (shague, 16:27:33)
    5. queue of patches to go in dualstack, upgrade fixes, transaction (shague, 16:28:01)
    6. tpantelis has cache patches in queue (shague, 16:28:43)
    7. focus on oxygen for dualstack (shague, 16:31:26)
    8. daya to get reviewers from E/// side to sign-off (shague, 16:32:44)
    9. shague, jamoluhrsen review the dualstack csit patches (shague, 16:33:39)

  7. carbon, nitrogen and oxygen: can we focus solely on oxygen? There are exceptions in all branches, but tests seem to pass so can possibly be ignored. (shague, 16:34:11)
    1. team Ok with focusing on oxygen (shague, 16:36:02)

  8. https://jira.opendaylight.org/browse/NETVIRT-1038 (shague, 16:36:26)
    1. looks like lport tag recycling too quickly (shague, 16:37:34)
    2. default table 220 flow is installed, then quickly removed (shague, 16:37:54)
    3. vthapar need to trace flow back to config inventory (shague, 16:39:31)

  9. [OPNFLWPLUG-858](https://jira.opendaylight.org/browse/OPNFLWPLUG-858) - group-id bug. carbon is ready once branch unlocks, nitrogen running gate, oxygen needs rebase and gate (shague, 16:41:07)
  10. [NETVIRT-896](https://jira.opendaylight.org/browse/NETVIRT-896) - tempest.api.network precommit_delete failure on security group delete (shague, 16:41:47)
    1. need networking-odl to look at bug (shague, 16:42:15)
    2. josh has rebased patches (shague, 16:43:41)
    3. daya added reviewers (shague, 16:43:47)
    4. janki working on csit changes (shague, 16:44:27)
    5. ensure gate passes on current patch stack (shague, 16:46:31)

  11. yang compatibility (shague, 16:47:16)
    1. dualstack introduces non-backward compatible changes. (shague, 16:48:13)
    2. daya evpn in nitrogen also has non-backward compatible changes (shague, 16:48:46)
    3. clustered-data-app-config plan to be handled by upgrade tooling (shague, 16:51:19)
    4. current replay upgrade process wipes datastore so alleviates many compatibility concerns (shague, 16:52:37)


Meeting ended at 17:00:55 UTC (full logs).

Action items

  1. vpickard add workaround to bug


Action items, by person

  1. vpickard
    1. vpickard add workaround to bug


People present (lines said)

  1. shague (48)
  2. odl_meetbot (3)
  3. vpickard (2)
  4. vorburger (1)
  5. jhershbe (1)
  6. sridharg (1)
  7. janki (1)


Generated by MeetBot 0.1.4.