#opendaylight-netvirt: NetVirt Weekly 01/16/18

Meeting started by shague at 16:01:22 UTC (full logs).

Meeting summary

  1. Roll call and agenda bashing (please #info <your-nick>) (shague, 16:01:49)
  2. Review existing action items (shague, 16:01:50)
    1. jamoluhrsen (jamoluhrsen, 16:02:03)
    2. vpickard (vpickard, 16:02:09)
    3. aswinsuryan (aswins, 16:05:14)
    4. Sridhar Gaddam (sridharg, 16:05:39)

  3. carbon - sr3 blocked on netvirt blockers. patches pushed yesterday, need to reevaluate status [tracking sheet](https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=40307633) (shague, 16:05:49)
    1. jhershbe (jhershbe, 16:07:29)
    2. do we unlock carbon branch or release sr3 with blockers (shague, 16:10:34)

  4. nitrogen is blocked on netvirt updates due to genius changes [genius 66787](https://git.opendaylight.org/gerrit/#/c/66787/) - [netvirt 66886](https://git.opendaylight.org/gerrit/#/c/66886/) (shague, 16:13:33)
  5. https://trello.com/c/BTurOwXh/42-oxygen-release-planning - 1/21/18 Code Freeze (shague, 16:14:27)
    1. odl parent bumps are delaying progress (shague, 16:15:43)
    2. need dualstack patches reviewed and merged (shague, 16:17:08)
    3. kiran has reviewed patches (shague, 16:17:19)
    4. existing csit broken with some patches (shague, 16:18:04)
    5. kiran working with philippe to fix (shague, 16:18:13)
    6. jamoluhrsen and shague to review csit dualstack patches (shague, 16:19:42)
    7. raja has some csit scripts that need to be pushed also (shague, 16:20:29)
    8. upgrade patches need to be merged also (shague, 16:21:44)
    9. cleanup and cache patches need merge (shague, 16:22:01)

  6. odlparent [status](https://wiki.opendaylight.org/view/ODL_Root_Parent:BigBumpOfJan2018) (shague, 16:23:55)
    1. issues with neutron, ovsdb, restconf yang models caused problems (shague, 16:24:30)
    2. json processing was issue for neutron (shague, 16:24:41)
    3. yangtools more strict on model revisions (shague, 16:24:55)
    4. vthapar has workaround patch for ovsdb (shague, 16:25:26)
    5. further model revision issues exist and need to be fixed (shague, 16:26:55)
    6. yangtools will need a respin (shague, 16:27:08)
    7. build remaining patches locally, then int/distro to build a distro (shague, 16:45:07)

  7. patch port issues - how to support bridge and ports for provider networks (shague, 16:49:45)
    1. host_config is the likely long term solution (shague, 16:51:22)
    2. most users pre create provider bridges so don't hit problem (shague, 16:52:00)

  8. [josh] CI...use websocket port status? (shague, 16:52:43)
    1. port status is not being used in csit (shague, 16:53:35)
    2. local.conf has odl_features=nothing (shague, 16:53:47)
    3. ACTION: jamoluhrsen to test port status in the sandbox (jamoluhrsen, 16:54:49)
    4. port-status should work with haproxy in the same way upstream csit uses haproxy (shague, 16:56:44)
    5. skitt mentions a carbon was fixed (shague, 16:58:07)


Meeting ended at 16:58:58 UTC (full logs).

Action items

  1. jamoluhrsen to test port status in the sandbox


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to test port status in the sandbox


People present (lines said)

  1. shague (34)
  2. odl_meetbot (3)
  3. jamoluhrsen (2)
  4. vpickard (1)
  5. sridharg (1)
  6. jhershbe (1)
  7. aswins (1)


Generated by MeetBot 0.1.4.